Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 50

Thread: NFS problem

  1. #16
    Quote Originally Posted by qz3fwd View Post
    I also wonder if it could be a userID/password thing?
    Maybe. I mount the shares as root on my FreeBSD box.

    - K.C.

  2. #17

    Mount NFS share?

    I'm having troubles mounting a NFS share on the router. Perhaps someone can help me with this as this is way beyond my knowledge


    Code:
    [admin@Router root]$ mount -t nfs 192.168.0.254:/Share /tmp/harddisk/server
    mount: RPC: Unable to receive; errno = Connection refused
    mount: nfsmount failed: Bad file descriptor
    mount: Mounting 192.168.0.254:/Share on /tmp/harddisk/server failed: Bad file descriptor

  3. #18

    USB disk+Transmission=Stale NFS file handle ???

    Hi guys

    I am quite new of Oleg..

    I have a strange problem, this is the main configuration:
    -USB FAT32 harddisk mounted un /tmp/harddisk (formatted with Part.Magic 8)
    -all mouts are performend in post-boot (stupid-ftpd disable)
    -nfs server disabled
    All seem OK ..

    But whwn i download torrents whis Transmission I often have this strange
    error:
    /opt/share/www/cgi-bin/transmission.cgi: /opt/share/www/cgi-bin/transmission.cgi: 4: cannot create /tmp/harddisk/torrent/work/TORRENTDIRNAME/.info: Stale NFS file handle

    I have got the same error also if I try to CD to that directory from
    terminal..

    Rebooting fix the problem...

    This look quite strange for me !!!
    Is the USB storage implementation a sort of NFS file system?

    Can you help me?

    Regards
    Primo525
    Last edited by primo525; 29-11-2007 at 19:11.

  4. #19
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    Format key in ext3!

  5. #20
    Tkanks Oleg

    do you mean that VFAT file system implementation is not so good ?

  6. #21
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    No. It seems that file locking is not working wit VFAT.

  7. #22

    TVIX 5100SH + WL 700ge

    All should work. It is just necessary to register correctly a full way to a folder. Example:

    1. "/shares/MYVOLUME1/MYSHARE1" - for acces to folder myshare1 (built in hdd).
    2. "/foreign_share/NTFS" - for access to external disk (usb connected) resources.

    Using telnet it is possible to look a full way in shell.

    Join!

  8. #23

    TVIX 5100SH + WL 700ge

    But there is one bug:
    Russian names of files are displayed incorrectly - the codepage does not coincide. TVIX work propertly with charsets 8bit per symbol. Unicode not supporting.

    Firmware 1.0.7.8 kfurge
    Last edited by @lexeich; 17-02-2008 at 20:23.

  9. #24
    hi qz3fwd,

    I have mine working with a Tvix 4000

    It's working on NFS but I cannot get it working on Samba. Anyway NFS is better as it provides faster speeds.

    Your line should be /shares/MYVOLUME1/tvixhd1.
    I noted from above that you have it in /tvixd1.
    Maybe it was only a typo for you on the post
    anyway it does work.

  10. #25
    Yeah-I got it working long ago but must have forgotten to post.
    I too used " /shares/MYVOLUME1/tvixhd1" and my 2 5000's and 4100 connect flawlessly.
    I never dumb it down to SMB & just stick with NFS since it just works.

  11. #26

    Question How to connect on NFS server r/w?

    Hello.
    I have AsusWL500gP, with Oleg's firmware and HeadStart II from this tutorial:http://www.wl500g.info/showthread.ph...117#post112117,

    I enabled NFS Server at web interface. Export "/mnt (rw)".
    I can connect to Asus/mnt, but only "read only". How to connect "read/write"?

    content of file "/etc/exports":
    /mnt (rw)

    content of file "/proc/fs/nfs/exports":
    # Version 1.1
    # Path Client(Flags) # IPs
    /mnt 192.168.1.2(ro,root_squash,sync,wdelay) # 192.168.1.2
    /mnt 192.168.1.76(ro,root_squash,sync,wdelay) # 192.168.1.76

    But I need from address 192.168.1.2 "rw". How do it? Where is generated this file?
    Thx for help.

  12. #27
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    PHP Code:
    cat /etc/exports
    /opt         192.168.1.10(rw,async,no_root_squash,no_wdelay

  13. #28

    NFS How to?

    This might be stupidest questions of all time but here goes. I have had my WL-500g Deluxe for years working nicely. FTP and SAMBA which is mainly what I use works like a charm with out me having to know anything about linux.
    A few days ago I purchased Popcorn Hour A-110 which is a very strong and silent Media Tank. Sadly it fails to browse my SAMBA share on the WL-500g Deluxe. Then I had the great idea of trying to set up the NFS on my WL-500g Deluxe which the Popcorn Hour also supports. But I haven't got the faintest of ideas how to. I have search the forum vividly the last couple of days but have found nothing.

    WL-500g Deluxe has IP: 192.168.1.1
    Popcorn Hour IP: 192.168.1.4.

    Is it possible at all to set up the NFS through the Web Interface only?
    What has to be exported?
    I have tried:
    /tmp/harddisk/part1/ 192.168.0.4(rw) (This is the dir structure)
    /share 192.168.0.4(rw) (This is name of the SAMBA demo mode share)

    Is there a way to test the NFS leaving the Popcorn Hour out of the picture. Say f.x. installing some kind of NFS client on my Windows XP machine?

    Any help is very much appreciated as I would really like the Popcorn Hour to see the attached drive on WL-500g Deluxe.
    Last edited by Tiger road; 30-11-2008 at 22:00. Reason: Forgot something

  14. #29
    Anyone? I got chocolates

  15. #30
    Finally got it to work. I had the path mixed up. In order to make NFS work you just have enable NFS server in the web interface and add server export.
    I added:
    /tmp/harddisk/ftp_pub 192.168.1.1/255.255.255.0(rw)
    this give read/write permissions to ip all ip adresses between 192.168.1.1-192.168.1.255 which is all machines connected to my WL-500g deluxe. The "/tmp/harddisk/ftp_pub" is the file path to my data I wish to share. I just did a telnet to my WL-500g deluxe and did some browsing to find the file path.

Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. NFS probleem - Portmap draait als user '1'
    By koetjeboeh in forum Dutch Discussion - Nederlands
    Replies: 2
    Last Post: 21-01-2010, 16:46
  2. Kein Zugriff per NFS + Samba+Mac Problem
    By tuxianer in forum German Discussion - Deutsch (DE)
    Replies: 4
    Last Post: 21-02-2008, 15:57
  3. WL-500gP and Asus support experience
    By Blezi in forum WL-500gP Q&A
    Replies: 6
    Last Post: 03-12-2006, 13:59
  4. Problems with sharing USB disc over NFS
    By Jean-Fabrice in forum WL-500g Custom Development
    Replies: 53
    Last Post: 18-10-2006, 18:33

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •