Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 50

Thread: NFS problem

  1. #31
    TY it also works for mediaplayer Egreat m31b

  2. #32
    Quote Originally Posted by Tiger road View Post
    I have tried:
    /tmp/harddisk/part1/ (This is the dir structure)
    /share (This is name of the SAMBA demo mode share)

    2008-2013 ABATAPA WL-500gP/128M / Asus RT-N16 / USB Flash / VLAN / PPPoE / VoIP / nShaper / NAS: iStor is607, Sarotech NAS-20, QNap 109 Pro / NFS / / etc

  3. #33
    Use "insecure" option in /etc/exports file. For example:

  4. #34

    After installing xinetd/samba2 i got trouble with nfs...

    Hi together,

    after i managed to get my Samba running well, it seems that i now got trouble with NFS. Maybe this has to do with xinetd, because this was the last modification done before i got this message after trying to mount my usual nfs-share:
    mount.nfs: access denied by server while mounting (null)
    The mount should be done with:
    #! /bin/bash
    mount -t nfs /mnt/wlhdd -o rw,soft,udp,rsize=32768,wsize=32768
    The /etc/exports on my WL-HDD ( shows:
    # automagically generated from web settings
    /tmp/harddisk/ *(rw,async,no_root_squash)
    /tmp/harddisk/naspics/ *(ro,async,no_root_squash)
    /tmp/harddisk/nasmusic/ *(ro,async,no_root_squash)
    /tmp/harddisk/nasvideo/ *(rw,async,no_root_squash)
    From the client side i can see the exports:
    showmount -e
    Export list for
    /tmp/harddisk           *
    /tmp/harddisk/nasmusic  (everyone)
    /tmp/harddisk/nasvideo  (everyone)
    /tmp/harddisk/naspics   (everyone)
    Do i have to change any settings in xinetd.conf to make my nfs-mount work again?

    Thanks in advance,


  5. #35

    [Solved] (Post may be deleted...)


    It hasn't t do anything with WL-HDDs services.
    On the client side something went wrong with the directories where the share should be mounted. So after unmount the obsolete mount and remount, all works fine.

    Mabe the Board-Admin can delete the post because its useless...

    Regards, Thorsten

  6. #36
    Join Date
    Feb 2008
    Copenhagen, Denmark
    Quote Originally Posted by Tiger road View Post
    A few days ago I purchased Popcorn Hour A-110 which is a very strong and silent Media Tank. Sadly it fails to browse my SAMBA share on the WL-500g Deluxe.
    Password encryption has to be set to 'Yes' in samba for a Popcorn Hour 110 to be able to browse your share.

  7. #37
    Join Date
    Aug 2010
    Poland / Wrocław

    NFS crashes

    I'm using RT-N16 with firmware

    During using of NFS filesystem exported from connected via USB dysk my NFS server on RT-N16 sometimes crashes. (I have to restart nfsd end mountd deamons).
    In syslog there is information:
    Aug 27 19:36:06 kernel: dentry_open called with NULL vfsmount
    Aug 27 19:36:06 kernel: Call Trace:
    Aug 27 19:36:06 kernel: [<8000de20>] dump_stack+0x8/0x34
    Aug 27 19:36:06 kernel: [<80079acc>] dentry_open+0x7c/0xc8
    Aug 27 19:36:06 kernel: [<c00da284>] get_name+0xcc/0x19c [exportfs]
    Aug 27 19:36:06 kernel: [<c00da7e0>] find_exported_dentry+0x2d8/0x6ec [exportfs]
    Aug 27 19:36:06 kernel: [<c00dac48>] export_decode_fh+0x54/0xac [exportfs]
    Aug 27 19:36:06 kernel: [<c0264454>] fh_verify+0x364/0x6f4 [nfsd]
    Aug 27 19:36:06 kernel: [<c02715a8>] nfsd3_proc_getattr+0xc8/0x180 [nfsd]
    Aug 27 19:36:06 kernel: [<c026029c>] nfsd_dispatch+0xbc/0x2ac [nfsd]
    Aug 27 19:36:06 kernel: [<c01f207c>] svc_process+0x500/0x964 [sunrpc]
    Aug 27 19:36:07 kernel: dentry_open called with NULL vfsmount
    Aug 27 19:36:07 kernel: Call Trace:
    Does anyone know some fix for nfs ?

  8. #38

    NFS problem

    I am having problems with the NFS-server on my RT-16N, using an Oleg firmware of this july. It stalls when copying a lot of files from one of the attached USB drives. An error 521 and something like cannot find files.
    I see only a few references on google on this (kernel problem). However I am wondering whether the mount options might cause a problem; much more people should have problems. What options do you use?

  9. #39
    More info. I have problems mounting with this command:
    mount -t nfs -o vers=3,tcp,lock,intr,hard,rw /Asus

    The error I get when copying a large amount of files from the Asus to my Kubuntu 10.04 PC (by dmesg through telnet): dentry_open called with NULL vfsmount
    Call Trace:
    [<8000de20>] dump_stack+0x8/0x34
    [<80079eec>] dentry_open+0x7c/0xc8
    [<c00da284>] get_name+0xcc/0x19c [exportfs]
    [<c00da77c>] find_exported_dentry+0x274/0x6ec [exportfs]
    [<c00dac48>] export_decode_fh+0x54/0xac [exportfs]
    [<c01bb454>] fh_verify+0x364/0x6f4 [nfsd]
    [<c01c8598>] nfsd3_proc_getattr+0xc8/0x180 [nfsd]
    [<c01b729c>] nfsd_dispatch+0xbc/0x2ac [nfsd]
    [<c024807c>] svc_process+0x500/0x964 [sunrpc]
    [<c01b7b90>] nfsd+0x224/0x460 [nfsd]
    [<8000a05c>] kernel_thread_helper+0x10/0x18

    NFS stalls for a minute than resumes working, though filecopying must start again.

    My (unsafe) /etc/exports: /mnt *(rw,no_subtree_check,no_root_squash,sync)

    I'll now try:
    mount -t nfs -o hard,rw,async,noauto /Asus

  10. #40
    It's already fixed in svn. So, just get the latest build

  11. #41
    That's great, thanks. I was using the svn-version of July

    Edited: it is fixed indeed
    Last edited by verjikd; 11-09-2010 at 17:17.

  12. #42

    [How to] Install/set up NFS client?


    I have a NAS (HDD My Book World 2 Western Digital 2TB with 10/100/1000 ethernet interface) with NFS folders.
    I tried to mount the NFS folders from NAS on my RT-N16 but with no success.
    I added
    insmod nfs.ko
    mount // /usr/local/mnt/temp
    I would appreciate it, if someone could help me with some suggestions.

    Many thanks
    Last edited by Foxem; 14-01-2011 at 11:32.

  13. #43

    Question NFS works for Opensuse client and Wetab, but not for Kubuntu and Xubuntu

    I've updated my RT-16n with the latest OLEG-firmware of 3th of July. Now I am having trouble to get the NFS-server on my RT-16n to work for all clients. The following command works from Opensuse and my Wetab: sudo mount -t nfs -o vers=3,tcp,lock,intr,hard,rw,nolock /Asus
    In syslog.log: mountd[365]: authenticated mount request from for /mnt/nfs-data (/mnt/nfs-data)

    However from Kubuntu 11.04 and Xubuntu 11.04 I get on the client side: mount.nfs: access denied by server while mounting
    In syslog.log:mountd[365]: refused mount request from EEElaptop for /mnt/nfs-data (/): no export entry

    My only exports-line is: /mnt/nfs-data 192.168.123.*(rw,async,insecure)

    Why the ubuntu-variants won't connect, is beyond me.
    Anyone an idea?

  14. #44


    I found it. The error has to do with the Asus RT-16N router not being able to resolve the IP address of both PC's. For both PC's were I had created fixed IP addresses for their MAC-addresses in the Asus router, with an earlier firmware version.

    After updating the firmware of the router this caused the problem, although it gave both PC's the right IP address. Removing both fixed IP addresses made it working again. It is more or less a bug in the OLEG-firmware of the RT-16N (and other WL500-routers with the same kind of firmware).

    Glad I found it :P

  15. #45
    And in the end it wasn't the Asus router after all, as one PC continued to have a problem. It needed to have these options to run:

    mount -t nfs -o vers=3,tcp,nolock,intr,hard,rw,noauto /Asus

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. NFS probleem - Portmap draait als user '1'
    By koetjeboeh in forum Dutch Discussion - Nederlands
    Replies: 2
    Last Post: 21-01-2010, 16:46
  2. Kein Zugriff per NFS + Samba+Mac Problem
    By tuxianer in forum German Discussion - Deutsch (DE)
    Replies: 4
    Last Post: 21-02-2008, 15:57
  3. WL-500gP and Asus support experience
    By Blezi in forum WL-500gP Q&A
    Replies: 6
    Last Post: 03-12-2006, 13:59
  4. Problems with sharing USB disc over NFS
    By Jean-Fabrice in forum WL-500g Custom Development
    Replies: 53
    Last Post: 18-10-2006, 18:33

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts