Page 1 of 4 123 ... LastLast
Results 1 to 15 of 50

Thread: NFS problem

  1. #1

    NFS problem with Microsoft SFU

    Hi Guys,

    Since I bought wl-500gx I've learned a lot from the community. Thanks to you!

    Now I've encountered a problem related to NFS. Recently I installed the latest firmware, but found the problem with Samba persists: it is not very stable, sometimes the network folder closes by itself, and sometimes file transfer was broken. That was why I was seeking to use NFS instead, while I did not turn off Samba. I downloaded ServicesforUnix 3.5 and installed NFS client on my Win XP notebook.

    now my /etc/exports is like:
    #automatically generated from web settings

    and when I run "showmount -e wl-500g" from notebook running NFS client, I can see this showing up. But when I try to mount this NFS share through:

    mount *
    or "mount \\wl-500g\tmp\harddisk *"

    I always got message "Network Error - 53" or "Network Error - 67" (can't find network path or network name). I ran
    "insmod sunrpc
    insmod lockd
    insmod nfs

    on wl-500g already. Can anybody show me how to trouble this? It was strange that yesterday I succeeded in mapping the NFS share to my e: drive yesterday. but today I could not make it happen again.


  2. #2
    Hi Guys,

    I can mount the NFS share now but I could not write into it (deleting file etc). I now have "no root squash" in export list but don't know how I can log in to it as root user under SFU. "rw" has been set but doesn't work. Anybody can help?

  3. #3
    Let me summarize the problems with NFS:

    1. SFU can work sometimes under unknown reasons. But the next time XP starts, there might be a prompt "An error occured while connecting to the NFS Server. Make sure the NFS client services have started. If the problem still exists, make sure your NFS client can communicate with User Name Mapping or PCNFS server".

    2. I tried another NFS client named Omni. But it keeps asking for user authentication (NIS, PCNFS or UID). Anyway this does not work.

    Can't anybody offer some help, please?

  4. #4

    Thumbs down Re

    I have the same problem using WL500gP and Windows XP.
    Can somebody post an instruction how to solve it ?

  5. #5
    Quote Originally Posted by fwbj01 View Post
    Hi Guys,

    I can mount the NFS share now but I could not write into it (deleting file etc). I now have "no root squash" in export list but don't know how I can log in to it as root user under SFU. "rw" has been set but doesn't work. Anybody can help?
    you must redirect the anonid and the anongid to 0 (root) and all requests to anon. then you can acces with all rights

    it shoul work with

    /path/to/directory (rw,insecure,all_squash,anonuid=0,anongid=0)
    then you have full root rights on the share

  6. #6

    Thumbs up Re

    Thank you HoLE !

    That works really fine.

    But why it is not possible to map the drive sometimes (50%) ?

  7. #7
    thats a good question i am working on, too

    but i have other problems with nfs at the moment: reading is fine but writing does not work. he starts to write with 40MB/s and then does not response any more. reading from nfs is fine @ 4MB/s

  8. #8

    NFS kills the router

    I have Oleg's and tried to use nfs server from router - with nfs client from MS SFU 3.5 - for higher transfer speed. After some successful tests I tried to transfer a ~3GB folder (with few hundreds files) from router to pc and the router died. After recovery (reflash, reinstall ipkg etc - here may be another story about recovery without pin 9 ) the problem remains (while transfer that folder via nfs, router dies). I transfered successfully the folder via samba.
    Well, is anybody here which use nfs without problems?

  9. #9
    Join Date
    Jun 2005

    Thumbs up

    Quote Originally Posted by tsedeq View Post
    Well, is anybody here which use nfs without problems?
    Me. Using linux as a client. Automounter.
    My config:
    /opt *(rw,async,no_root_squash)

  10. #10

    NFS Volumes failed to mount with MAC OS X?

    Connection to an NFS server may fail in certain configurations, with a server log message that looks like this one:

    Aug 4 05:44:43 leeloo kernel: nfsd: request from insecure port (11685b22:50528)!

    This can happen with any version of Mac OS X. Here's why:

    Mac OS X tries to make NFS connections from port numbers outside the traditional range expected by some NFS servers. Configuring your NFS server to accept connections on "insecure" ports above 1024 should resolve the issue. Please consult your server's documentation for configuration information.

    Is there a way to get it work with MAC OS X and the WL500GD?


  11. #11

    NFS read much slower than Samba

    I have a problem with performance of NFS reading from disc. I have a 200G disc connected over USB to Asus-WL500gP and I access to it from a notebook (Debian) over WiFi.
    I achieve a data transfer about 300kB/s (as it is reported by mc) reading from disc over NFS. Moreover the connection often freezes (kwifimanager shows that signal is often lost).
    When I read the same data over Samba, I get approx. 900kB/s.
    If I write to the disc over NFS, it is about 1.5MB per second. I can't provide data for samba write because I have Samba read-only.

    Firmware release is

    Please can somebody help me with the NFS issue?


  12. #12

    Question foo2zjs package available through the package system? NFS support?


    I was wondering if you are planning to create a foo2zjs package available through the package manager for Asus WL-500g? I have an HP Laser Jet 1020 which I want to connect to my WL-500g by using CUPS instead of HP JetDirect printing mechanism.

    Is it possible to make the foo2zjs available for this architecture or is it a workaround in order to make HP Laser Jet 1020 work with CUPS without installing the foo2zjs as a package through the ipkg package manager?

    Is it possible to include support for NFS?


    Best regards,


  13. #13

    Tvix 5000/4000/4100 + Asus using NFS (not SMB)?

    I have several Tvix media player boxes and cannot get them to connect to the Asus routers shares using NFS. SMB works fine, however I have never been able to get a connection using NFS. I need to use NFS because high bitrate files choke using SMB, and have been using NFS with my Infrants for over a year without problem. I have the tvixd1 share setup as required.

    Does the NFS implementation work on the Asus firmware?

    Has anyone been able to connect to the shares using NFS?

    Thank You.

  14. #14
    NFS to my FreeBSD box works just fine for me. Make sure you're using the proper export name. To see the exports type the following from a unix box (or the router itself if you're running the custom software or optware):

    showmount -e <server ip address>

    - K.C.

  15. #15
    Thanks-I will try the showmount tonight.

    I also wonder if it could be a userID/password thing?

    This problem is driving me nuts. My Infrants connect no problem, the ASUS does not. So I cannot access the 700GB's of HDTV transport streams on any of my HDTV's

Page 1 of 4 123 ... LastLast

Similar Threads

  1. NFS probleem - Portmap draait als user '1'
    By koetjeboeh in forum Dutch Discussion - Nederlands
    Replies: 2
    Last Post: 21-01-2010, 16:46
  2. Kein Zugriff per NFS + Samba+Mac Problem
    By tuxianer in forum German Discussion - Deutsch (DE)
    Replies: 4
    Last Post: 21-02-2008, 15:57
  3. WL-500gP and Asus support experience
    By Blezi in forum WL-500gP Q&A
    Replies: 6
    Last Post: 03-12-2006, 13:59
  4. Problems with sharing USB disc over NFS
    By Jean-Fabrice in forum WL-500g Custom Development
    Replies: 53
    Last Post: 18-10-2006, 18:33

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts