Page 11 of 18 FirstFirst ... 910111213 ... LastLast
Results 151 to 165 of 262

Thread: Помогите с настройкой Samba

  1. #151

    Samba не пускает!

    Друзья, замучался! Поставил Samba2, отконфигурировал, вроде всё правильно. Но она не пускает, что из под Windows 7, что из под Ubuntu 10.04. Хочу зайти под admin, в логе это:
    Code:
    [2010/07/31 17:49:34, 1] source/smbd/password.c:pass_check_smb(545)
      Couldn't find user 'tinc' in passdb.
    [2010/07/31 17:49:34, 1] source/smbd/reply.c:reply_sesssetup_and_X(1023)
      Rejecting user 'tinc': authentication failed
    [2010/07/31 17:49:51, 1] source/smbd/reply.c:reply_sesssetup_and_X(1023)
      Rejecting user 'admin': authentication failed
    smb.conf таков:
    Code:
    [global]
    interfaces = br0
    bind interfaces only = yes
    workgroup = WORKGROUP
    server string = WWW
    guest account = nobody
    security = user
    browseable = yes
    dns proxy = no
    guest only = no
    guest ok = no
    log level = 1
    max log size = 100
    encrypt passwords = yes
    preserve case = yes
    short preserve case = yes
    client code page = 866
    character set = 1251
    wins support = yes
    time server = yes
    os level = 255
    local master = yes
    
    [www$]
    path = /opt/share/www
    comment = WEB-server folder
    guest ok = no
    writable = yes
    force user = admin
    browseable = no
    valid users = admin

  2. #152
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    На что Вы рассчитываете, создавая каждый раз отдельную тему по каждому вопросу, не пользуясь поиском (не указывая о том, что делали)?
    Собрал все Ваши темы в одну.

  3. #153
    Join Date
    Jun 2010
    Location
    Moscow, Russia
    Posts
    322
    Quote Originally Posted by tolly777 View Post
    Совсем инфы тут по sambe нет
    Ну дык форум-то какбэ не по Sambe...
    Может ТУТ глянуть?

  4. #154
    Так как с другими темами я, вроде бы, разобрался.

  5. #155

    samba2 проблема с кодировкой

    Добрый день.Много всего написано про samba,но я перепробовал почти все комбинации,ничего не помогло.

    У меня 2 компа и 2 медиаплеера iconbit.На плеере iconbit стоит linux и он поддерживает сетевое подключение.В данном плеере кодировка UTF-8.
    Проблема в том что расшаренный диск с фильмами и папками с русскими именами при настройках самбы

    [global]
    interfaces = br0
    bind interfaces only = yes
    workgroup = UL
    server string = WL500W
    guest account = nobody
    security = share
    browseable = yes
    guest ok = yes
    guest only = yes
    log level = 1
    max log size = 100
    encrypt passwords = no
    preserve case = yes
    short preserve case = yes
    client code page = 866
    coding system = utf8

    [share]
    path = /tmp/mnt/disc0_1
    writable = yes
    force user = admin

    виден в винде нормально,а на плеере иероглифы.
    Либо если из конфига убрать
    client code page = 866
    coding system = utf8
    То на плеере iconbit в шаре на диске все читается и он распознает русские имена и папки.
    Как выяснилось у разработчика на плеере кодировка utf8.
    Как мне сделать так чтобы читались русские имена и папки везде.И в винде и на линуксе(iconbit).
    Перепробовал все мыслимые и не мыслимые комбинации
    unix charset = utf8
    display charset = utf8
    dos charset = utf8,cp1251,866
    Вобщем уже почти неделю вбиваю разные комбинации.Но всегда в винде иероглифы.Либо при этих строка
    client code page = 866
    coding system = utf8
    в винде все читабельно,а на плеере нет.((((((

    Помогите спецы.

  6. #156
    Quote Originally Posted by xlazex View Post
    проверьте,нет ли в папке,которую вы собираетесь снести файла Thumbs.db
    его создает винда для кэширования картинок,точнее эскизов(thumbnails) в папке.
    видать просто детище гейтса не дает удалять файл Thumbs,

    убирается "Мой комп" - "Сервис" - "свойства папки" - "Вид" - "Не кешировать эскизы" для ХР, а на 7 такой опции нет =(
    на висте не пробовал.
    http://ru.wikipedia.org/wiki/Thumbs.db

    А по теме :O используем TotalComander - самый удобный вариант
    или рекурсивные батники
    или подключайтесь через ssh и rm -rf /folder/to/delete

    а вобще это явно samba как-то криво настроена

  7. #157
    что никто не сталкивался?

  8. #158
    Join Date
    Oct 2008
    Location
    Saint-Petesburg, Russia
    Posts
    253
    Quote Originally Posted by Amlet1 View Post
    Как выяснилось у разработчика на плеере кодировка utf8.
    Как мне сделать так чтобы читались русские имена и папки везде.И в винде и на линуксе(iconbit).
    я бы попробовал менять конфигурацию в зависимости от клиента.
    Примерно так:
    - различаем комп с виндой и плеер по ip-адресам.
    - в smb.conf пишем что-то типа:
    Code:
    include = /opt/etc/samba/charset_%I
    Далее создаем файлы для винды и плеера:
    /opt/etc/samba/charset_192.168.1.1
    /opt/etc/samba/charset_192.168.1.2
    в которых прописываем подходящий charset.

    Идея в том, что при обращении соответствующего клиента будет подгружаться подходящий файл с параметрами.
    P.S. Не уверен, что будет работать, не уверен, что эти опции есть в samba2....
    WL500gp-1.9.2.7-d-r2624

  9. #159
    Join Date
    Apr 2008
    Location
    город самоваров и пряников
    Posts
    1,492
    Проэкспетиментировал тут давеча.
    Записал запуск samba в post-boot при подключенном и отключенном внешнем диске.
    Всё доступно.
    Как оказалось, самба "на лету" подхватывает нужные шары и писать её запуск в post-mount нет никакого смысла.
    Свой первый пост поправил.
    Last edited by MrGalaxy; 24-08-2010 at 17:00.
    Ламер, деградировавший до чайника.

    1. WL-500gP(v1)|RAM 128M|Entware 3.0.4-r4844M|Доработаны цепи питания|Заменены светодиоды
    Samsung G2 Portable HX-MU050DC|Скрипт поднятия wan после падения|transmission|dlengine|vnstat
    2. DIR-320|RAM 64M|Flash 8M|Entware 1.9.2.7-rtn-r4772M|Принт-сервер для HP 1000-1022, P1005-P1505

  10. #160

    скорость samba WL-500W -> Linux delphin

    Суть в следующем: на wl-500w поставлена олеговская прошивка, он настроен, запущен rtorrent, самба стандартная, но с моим конфигом (изменена рабочая дирректория), подключен винт на 500ГБ. Подключаюсь по wi-fi.
    С винды все относительно неплохо. При копировании файлов по wi-fi с роутера скорость порядка 3МБ/с, можно смотреть видео (не высшего качества к сожалению) прямо с роутера.
    Но вот на 2й комп поставил linux opensuse... Это просто какой-то полный финиш. Скорость по wi-fi копирования с роутера порядка 100-150КБ/с. Скорость коннекта в этот момента 54МБ/с. Подключаюсь кабелем скорость копирования 300-450КБ/с, и это при 100МБ/с коннекта. Я из инета быстрее скачаю, чем с собственного винта.
    Иногда в редкие моменты скорость копирования по wi-fi на linux бывает вполне удобоворимой 1,5 МБ/с. Но все равно это не то. Кино не посмотришь.

    проблема решена. Kde-дельфин делая превью для файла забивает весь канал самбы. Отключить превью - и скорость поднимается до 3 МБ/С.

    Только вот хочу узнать, это предел скорости? Даже с кабелем не получается сделать больше.
    Last edited by borpavlenko; 25-08-2010 at 22:54. Reason: проблема решена.

  11. #161
    Кодировка стоит как UTF-8 а нужно 1251...

  12. Exclamation Помогите настроить кодировку transmission или samba за $WM$

    Отчаявшись найти нормальный мануал прошу помочь настроить русский язык на WL500gp + transmission + samba. Помощь готов оплатить WebMoney в разумных пределах.
    Задача: есть настроенный WL500gp, установлен transmission, который пишет торренты в cp1251. Через веб-интерфейс русские буквы отображаются нормально. Samba показывает всё это в utf-8, соответственно результат работы transmission не читаем. Требуется или научить transmission сохранять файлы в utf-8 или настроить самбу на cp1251 или найти другое решение.
    Стучитесь в аську 9445145.

  13. #163
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    Quote Originally Posted by Диди View Post
    Отчаявшись найти нормальный мануал прошу помочь настроить русский язык на WL500gp + transmission + samba. Помощь готов оплатить WebMoney в разумных пределах.
    Задача: есть настроенный WL500gp, установлен transmission, который пишет торренты в cp1251. Через веб-интерфейс русские буквы отображаются нормально. Samba показывает всё это в utf-8, соответственно результат работы transmission не читаем. Требуется или научить transmission сохранять файлы в utf-8 или настроить самбу на cp1251 или найти другое решение.
    Стучитесь в аську 9445145.
    Сделать одну из двух настроек:

    Настройка Самбы на кодировку CP1251:
    1. Ставим 3 Самбу.
    2. Немного изменяем ее конфиг:
    в smb.conf поменять:
    Code:
    dos charset = UTF-8
    unix charset = UTF-8
    display charset = CP1251
    3. Если будет ругаться наподобие:
    Code:
    init_iconv: Conversion from ..... to ..... not supported
    делаем, как написано тут.

    Либо:
    Настройка на кодировку UTF-8
    И переконвертировать все файлы в UTF-8 по ссылке из п.3 выше.

    Все уже расписано, нужно лишь научиться этим пользоваться ...

  14. #164
    Join Date
    Apr 2008
    Location
    город самоваров и пряников
    Posts
    1,492
    Да ничего там не надо переконвертировать. Трансмишшен пишет всё в utf-8. Встроенная Самба понимает.
    Ламер, деградировавший до чайника.

    1. WL-500gP(v1)|RAM 128M|Entware 3.0.4-r4844M|Доработаны цепи питания|Заменены светодиоды
    Samsung G2 Portable HX-MU050DC|Скрипт поднятия wan после падения|transmission|dlengine|vnstat
    2. DIR-320|RAM 64M|Flash 8M|Entware 1.9.2.7-rtn-r4772M|Принт-сервер для HP 1000-1022, P1005-P1505

  15. #165
    Quote Originally Posted by MrGalaxy View Post
    Да ничего там не надо переконвертировать. Трансмишшен пишет всё в utf-8. Встроенная Самба понимает.
    Вообще, он пишет так, как назван файл при создании. Т. е. если автор использовал программу, которая не переименовала в utf-8 файлы из, скажем, koi8-r, то пользователи Windows увидят "крокозябры". Но это бывает очень редко.
    © 2008-2013 ABATAPA WL-500gP/128M / Asus RT-N16 / USB Flash / VLAN / PPPoE / VoIP / nShaper / NAS: iStor is607, Sarotech NAS-20, QNap 109 Pro / NFS / Принтер / etc

Page 11 of 18 FirstFirst ... 910111213 ... LastLast

Similar Threads

  1. Помогите с настройкой Virtual Server
    By idtelecom in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 379
    Last Post: 28-02-2016, 17:39
  2. Помогите чайнику с настройкой FTP (vsftpd)
    By FOXTREE in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 322
    Last Post: 11-11-2014, 18:35
  3. Проблема с установкой и настройкой Transmission
    By Silkmann in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 187
    Last Post: 14-12-2012, 10:31
  4. Oleg firmware/Samba 2.2.12 and OS X 10.7.2 Lion - No more Samba ?
    By QMax in forum WL-500gP Firmware Discussion
    Replies: 11
    Last Post: 29-04-2012, 21:49
  5. Проблемы с настройкой VPN на WL-500gP
    By Pavel in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 272
    Last Post: 28-09-2007, 01:01

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •