Page 5 of 21 FirstFirst ... 3456715 ... LastLast
Results 61 to 75 of 306

Thread: Настройка PPTP VPN (accel-pppd) на роутере Asus

  1. #61
    Join Date
    Jun 2008
    Location
    Харьков, Украина
    Posts
    34
    Прешил домой, решил попробвать на своём wl-500gP V1. Адрес впн сервера прописал, мак уже стоит как положено, PPTP Options: None, Additional pppd options: require-pap

    Jan 1 02:00:06 pptp[84]: Plugin pptp.so loaded.
    Jan 1 02:00:06 pptp[84]: PPTP plugin version 0.8.4 compiled for pppd-2.4.5, linux-2.4.37.6
    Jan 1 02:00:06 pptp[84]: The remote system is required to authenticate itself
    Jan 1 02:00:06 pptp[84]: but I couldn't find any suitable secret (password) for it to use to do so.
    Под Debian с таким конфигом впн поднимается без проблем:

    lock noauth nobsdcomp nodeflate
    user 'my_login'
    password 'my_pass'
    sync pty 'pptp --idle-wait 0 172.25.254.254 --nolaunchpppd --nobuffer --sync'
    demand
    maxfail 0
    persist
    ktune
    ipcp-accept-remote ipcp-accept-local noipdefault
    default-asyncmap nopcomp noaccomp
    novj nobsdcomp nodeflate
    lcp-echo-interval 10
    lcp-echo-failure 6
    nodefaultroute
    unit 999
    wl-500gP V1 (1.9.2.7-d-r1222) + Flash 1 Gb без корпуса

  2. #62
    Quote Originally Posted by OperVil View Post
    Прешил домой, решил попробвать на своём wl-500gP V1. Адрес впн сервера прописал, мак уже стоит как положено, PPTP Options: None, Additional pppd options: require-pap
    Нужно добавить noauth в конце
    Code:
    require-pap noauth

  3. #63
    Join Date
    Jun 2008
    Location
    Харьков, Украина
    Posts
    34
    как я писал выше require-pap вписывал, и оно выдавало ошибку, под дебианом с этим же параметром выдаёт ту же ошибку. А noauth и так стоит по умолчанию.
    wl-500gP V1 (1.9.2.7-d-r1222) + Flash 1 Gb без корпуса

  4. #64
    Quote Originally Posted by OperVil View Post
    как я писал выше require-pap вписывал, и оно выдавало ошибку, под дебианом с этим же параметром выдаёт ту же ошибку. А noauth и так стоит по умолчанию.
    повторяю еще раз, noauth нужно добавлять после require-pap
    или же а additional прописать refuse-chap refuse-mschap
    Last edited by theMIROn; 09-11-2009 at 14:41.

  5. #65
    Join Date
    Jun 2008
    Location
    Харьков, Украина
    Posts
    34
    Что бы было яснее привожу конфиги/
    Это конфиг с роутера:
    noauth refuse-eap
    user 'my_login'
    password 'my_pass'
    plugin pptp.so
    pptp_server 172.25.254.254
    nomppe-stateful -mppc mtu 1400
    maxfail 0
    persist
    ipcp-accept-remote ipcp-accept-local noipdefault
    ktune
    default-asyncmap nopcomp noaccomp
    novj nobsdcomp nodeflate
    lcp-echo-interval 10
    lcp-echo-failure 6
    unit 0
    nodefaultroute
    Вот логи:
    Nov 9 15:13:51 pptp[86]: route_add: not adding existing route
    Nov 9 15:13:52 pptp[86]: Using interface ppp0
    Nov 9 15:13:52 pptp[86]: Connect: ppp0 <--> pptp (172.25.254.254)
    Nov 9 15:14:22 pptp[86]: LCP: timeout sending Config-Requests
    Nov 9 15:14:22 pptp[86]: Connection terminated.
    Nov 9 15:14:22 pptp[86]: Modem hangup
    Nov 9 15:14:52 pptp[86]: route_add: not adding existing route
    Nov 9 15:14:53 pptp[86]: Using interface ppp0
    Nov 9 15:14:53 pptp[86]: Connect: ppp0 <--> pptp (172.25.254.254)
    Nov 9 15:15:23 pptp[86]: LCP: timeout sending Config-Requests
    Nov 9 15:15:23 pptp[86]: Connection terminated.
    Nov 9 15:15:23 pptp[86]: Modem hangup
    И так по кругу.

    Копирую этот конфиг с мелкими изменениями (омечено жирным) в дебиан, после чего под дебианом впн подрубается, выдаются айпишники.

    noauth refuse-eap
    user 'my_login'
    password 'my_pass'
    sync pty 'pptp --idle-wait 0 172.25.254.254 --nolaunchpppd --nobuffer --sync'
    nomppe-stateful mtu 1400
    maxfail 0
    persist
    ipcp-accept-remote ipcp-accept-local noipdefault
    ktune
    default-asyncmap nopcomp noaccomp
    novj nobsdcomp nodeflate
    lcp-echo-interval 10
    lcp-echo-failure 6
    unit 777
    nodefaultroute
    Если добавить require-pap, то дебиан выдаёт это:

    /usr/sbin/pppd: The remote system is required to authenticate itself
    /usr/sbin/pppd: but I couldn't find any suitable secret (password) for it to use to do so.
    Под роутером то же сообщение.

    Скрин настройки впн под виндой:

    wl-500gP V1 (1.9.2.7-d-r1222) + Flash 1 Gb без корпуса

  6. #66
    Join Date
    Jun 2008
    Location
    Харьков, Украина
    Posts
    34
    Quote Originally Posted by theMIROn View Post
    повторяю еще раз, noauth нужно добавлять после require-pap
    или же а additional прописать refuse-chap refuse-mschap
    Прописываю в Additional pppd options:

    refuse-chap refuse-mschap require-pap noauth
    Лог:

    Nov 9 15:30:42 pptp[86]: Using interface ppp0
    Nov 9 15:30:42 pptp[86]: Connect: ppp0 <--> pptp (172.25.254.254)
    Nov 9 15:31:09 pptp[86]: LCP: timeout sending Config-Requests
    Nov 9 15:31:09 pptp[86]: Connection terminated.
    Nov 9 15:31:09 pptp[86]: Modem hangup
    wl-500gP V1 (1.9.2.7-d-r1222) + Flash 1 Gb без корпуса

  7. #67
    Quote Originally Posted by OperVil View Post
    Прописываю в Additional pppd options:
    или refuse-chap refuse-mschap или require-pap noauth

    для детальных логов - еще нужно добавить debug
    Last edited by theMIROn; 09-11-2009 at 15:11.

  8. #68
    Join Date
    Jun 2008
    Location
    Харьков, Украина
    Posts
    34
    прописал require-pap noauth debug. Лог тот же, что и выше.

    Извеняюсь за шумиху, проблема была в другом.
    Знаю ж что прописывал роут 172.25.0.0/16 что бы шел через 172.25.103.1, но в прошивка оказалась умнее и пускала адрес впн сервера 172.25.254.254 через гейтвей, указанный в вэб морде, а там стоял другой. Пменял на 103.1 всё подключилось.

    Спасибо за терпение и дельные советы.
    Last edited by OperVil; 09-11-2009 at 15:26.
    wl-500gP V1 (1.9.2.7-d-r1222) + Flash 1 Gb без корпуса

  9. #69
    Quote Originally Posted by OperVil View Post
    Извеняюсь за шумиху, проблема была в другом.
    Знаю ж что прописывал роут 172.25.0.0/16 что бы шел через 172.25.103.1, но в прошивка оказалась умнее и пускала адрес впн сервера 172.25.254.254 через гейтвей, указанный в вэб морде, а там стоял другой. Пменял на 103.1 всё подключилось.
    при подъеме соединения автоматически прописывается маршрут до vpn сервера через дефолтный шлюз.

    Quote Originally Posted by OperVil View Post
    Спасибо за терпение и дельные советы.
    в итоге, с какими параметрами заработало только pap подключение?

  10. #70
    Join Date
    Jun 2008
    Location
    Харьков, Украина
    Posts
    34
    require-pap noauth - работает
    С пустой строкой так же работает. Главное что бы гейтвей стоял через который ему нужно идти.
    Ещё у соседа сбивала надпись об ошибке CHAP авторизации(при том что было прописано require-pap noauth). А причиной тому был не правильно введенный пароль на впн.

    Quote Originally Posted by theMIROn View Post
    при подъеме соединения автоматически прописывается маршрут до vpn сервера через дефолтный шлюз.
    хм.. под дебианом ни на одной из сетевых не указан гейтвей, только роутами указаны диапазоны локлаьных айпи, но тем не менее автоматом прописывается маршрут к впн серваку через шлюз той сетевой карты, через которую он должен подключаться. Т.о. дефолт роут появляется после подключения впн.
    Last edited by OperVil; 09-11-2009 at 17:36.
    wl-500gP V1 (1.9.2.7-d-r1222) + Flash 1 Gb без корпуса

  11. #71
    Проблема решена.
    Косяк был на стороне провайдера.

  12. #72

    Скорость VPN

    Вообщем ребят такая проблема

    Локалка, инет через VPN

    Сделал вот это
    Code:
    #!/bin/sh
    iptables -t nat -nvL POSTROUTING | grep MASQUERADE | awk '{
        "ifconfig "$7" | grep Mask" | getline ip;
        split(ip,ip,":"); split(ip[2],ip," ");
        split($8,src,"!");
        if (src[1]=="") {src="! -s "src[2]} else {src="-s "src[1]};
        if ($9=="0.0.0.0/0") {dst=""} else {dst="-d "$9};
        system("iptables -t nat -A POSTROUTING -o "$7" "src" "dst" -j SNAT --to-source "ip[1]);
        system("iptables -t nat -D POSTROUTING -o "$7" "src" "dst" -j MASQUERADE");
    Все заработало проверил, но скорость vpn больше 10-15мегабит не поднимается, когда через локалку идет 40-50

    Подскажите что можно еще сделать

    Тариф 100 мегабит, просто если подключать к компу напрямую скорость в разы выше

    Product ID: WL500gpv2
    Firmware Version: 1.9.2.7
    Firmware Release: 1.9.2.7-10

  13. #73
    установить прошивку из подписи, и то, что сделали - делать станет не обязательно.

  14. #74
    Ну так разницы же получится не будет ?

  15. #75
    Quote Originally Posted by P@R@D!SE View Post
    Ну так разницы же получится не будет ?
    будет. еще разок: прошивку смените на ту, которая у меня в подписи.

Page 5 of 21 FirstFirst ... 3456715 ... LastLast

Similar Threads

  1. Настройка DynDNS на роутере Asus
    By idtelecom in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 360
    Last Post: 23-08-2015, 17:31
  2. Настройка IPTV на роутере Asus RT-N16/N66U/AC66U
    By Lion in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 246
    Last Post: 14-03-2015, 20:10
  3. Периодически падает соединение Pptp на роутере
    By kookahman in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 210
    Last Post: 08-05-2013, 07:39
  4. Настройка mpcs на роутере
    By poptab in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 1059
    Last Post: 17-07-2012, 07:22
  5. pppd problem with Olegs firmware on Asus WL-500gP
    By pelle in forum WL-500gP Firmware Discussion
    Replies: 0
    Last Post: 13-06-2011, 22:51

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •