Page 4 of 4 FirstFirst ... 234
Results 46 to 57 of 57

Thread: [HowTo] Asus RT-N16 (Oleg) - optware the simple way

  1. #46
    This is the log what I get from following your commands:
    [admin@TV root]$ mount
    rootfs on / type rootfs (rw)
    /dev/root on / type squashfs (ro)
    proc on /proc type proc (rw)
    sysfs on /sys type sysfs (rw)
    devfs on /dev type tmpfs (rw,noatime)
    devpts on /dev/pts type devpts (rw)
    tmpfs on /tmp type tmpfs (rw,noatime)
    usbfs on /proc/bus/usb type usbfs (rw)
    nfsd on /proc/fs/nfsd type nfsd (rw)
    /dev/discs/disca/part1 on /tmp/mnt/disca_1 type fuseblk (rw,user_id=0,group_id=0,allow_other,blksize=4096)
    [admin@TV root]$ cat /etc/exports
    # automagically generated from web settings
    /tmp/harddisk/# automagically generated from web settings
    /tmp/harddisk/cat > /usr/local/.files << __EOF__
    [admin@TV root]$ /mnt,insecure,all_squash,anonuid=0,anongid=0,
    -sh: syntax error: unexpected "("
    [admin@TV root]$ showmount -e
    Export list for
    /tmp/harddisk/__EOF__ *
    /tmp/etc/group        *
    /tmp/etc/passwd       *
    /tmp/etc/exports      *
    /etc/fstab            *
    /tmp/harddisk/cat     /usr/local/.files
    [admin@TV root]$ Exports list on
    -sh: Exports: not found
    [admin@TV root]$ /mnt All Machines
    -sh: /mnt: Permission denied
    [admin@TV root]$ mount \\\mnt *
    mount: mounting \ on * failed: No such file or directory
    [admin@TV root]$

  2. #47


    Hi and thanks for all the help for a newby like i'am. I've tryed to do all the procedure with my wl500gp and in the beginning it work's fine but after a while it starts to go very slow in the access to the router, the internet is not working...My need is only to install the new version of torrent on the wl500gp. So now i've done again the procedure till the formattation of the Hard disk but if i try to install transmission following your other post it doesn't work. So could you please tell me what procedure i need to install transmission on my router, after having done the first two steps of your tutorial and without having installed the optware? Thank you for your help

    PS i've used your procedure because is very fast and easy instead of Wengi tutorial that is more difficoult for me... Thank you

  3. #48
    Quote Originally Posted by tex View Post
    So could you please tell me what procedure i need to install transmission on my router, after having done the first two steps of your tutorial and without having installed the optware?
    That's not an option. The reason why you cannot install transmission without basic optware is that it contains essential files/configuration for the subsequent installs (including transmission).

    If your router contains only 32MB RAM, I can understand your request. What you can do is (after basic optware install but before transmission install):
    1. remove the old transmissiond with the following command
    ipkg remove transmissiond
    2. Prevent the start of unnecessary services from /opt/etc/init.d/ and that can be done via renaming them to DS...., e.g. S45php -> DS45php or S80busybox_httpd->DS80busybox_httpd.
    Please note however that e.g. php can be needed for other programs...
    (The busybox_httpd is not, however you don't gain too much with it.)

    Also reducing max. bandwidth of transmission and memory usage may help.

    The best is however to use 128MB RAM router (either upgraded or factory) if you plan to run many programs. 32MB RAM restricts too much what you can do.

  4. #49
    Thank you for your answer. I'm not able to upgrade the router memory so the best way is to follow again Wengi's tutorial, because transmission worked very good for some years till a crush of the system. Thank you.

  5. #50
    Hi Ecaddict,
    i followed your advise. Installed your image and then renamed all the services i don't need
    This is my init.d folder. And now everything is working properly, a little bit slow..... but working
    This is my free
    [admin@hd asus root]$ free
    total used free shared buffers cached
    Mem: 30052 29204 848 0 1084 4644
    -/+ buffers/cache: 23476 6576
    Swap: 506008 65416 440592
    Do you think that i can improve my memory performance without adding RAM?
    Thank you

  6. #51
    The WL-500 family of routers has a relatively slow CPU (as today's standards go) so for slowness it can be also the reason not just the RAM. I don't have too much experience with 32MB RAM as I've made an upgrade to 128MB very quickly (as with 32MB too much swapping was going on and HDD usage LED was way to active; this was with WL-500gPv1) .

    If it does what you need, don't care after all this is a router, not a real server or NAS.

    If it becomes annoying you can still change to the faster RT-N16 (this is what I use, it can e.g. easily compile e.g. minidlna within 5 minutes, the rest of the time is spent on downloading and configuring packages).

    One thing that occurred to me that may help you: I've noticed that Transmission memory usage becomes excessive after a while (weeks on RT-N16) and although I'm not sure yet you may try to set false "alt-speed-enabled" and "watch-dir-enabled" in /opt/etc/transmission/settings.json (as I suspect that it helps).
    Last edited by ecaddict; 26-11-2011 at 20:01.

  7. #52
    Hallo everybody,
    after a while i left the wl500gp and buy the RT-N16. Followed Ecaddict tutorial and everything works fine. I'm using this router mainly for transmission so i don't use other stuffs. I've a 500G HD on the router. Now my problem is that the torrent webpage gives this error: "unable to save resume file: no space left on device" and when i check the OPT partition is full (1 G , no available space) Both temp files and complete downloads are set to be stored in the MNT partition (MNT/storage/downloaders/transmission/done and work)
    There is a way to increase OPT space without formatting everything?
    Thank you very much for your help
    Last edited by tex; 29-01-2012 at 17:46.

  8. #53
    What you could do:

    1. Stop transmission (/opt/etc/init.d/S60transmission stop)
    2. move /opt/etc/transmission/torrents etc. to somewhere in /mnt (e.g. using mc)
    3. link the directory in /mn to /opt e.g. ln -s /mnt/protected/Downloaders/Transmission/torrents /opt/etc/transmission
    4. start transmission

  9. #54
    thank you very much for your advise, but i think that, also if i resolve the transmission problem, for the router is not so good to work with no free space in the OPT partition. So I've done again the procedure of your tutorial changing the first line from +1024 to +10240 and now i've a OPT of 10 Gb.
    Why i filled the OPT partition? I've made some error? I installed the last version of transmission and miniDLNA more then normal installation. Thank you
    Last edited by tex; 31-01-2012 at 12:16.

  10. #55

    ASUS.err file

    Hi, after some months get the same error of OPT partition full (10 Gb) and i noticed that there is a file that increases in size every moment. The file is ASUS.err and became so big to fill all the OPT partition. I cleaned it but it starts again increasing progressively in size...
    Name:  asus..jpg
Views: 1793
Size:  213.2 KB
    What is this file for??? How can i clean it? Thank you

  11. #56

    port 80

    Hi All,
    the topic is not so active. Yet this simple-way installation works flawlessly big thanks for it.
    My only question is what uses port 80? I wanted to set port 80 in lighhttpd.conf from 8082, but I got the following:
    "(network.c.379) can't bind to port: 80 Address already in use"
    How can I find out what uses port 80?
    I removed Transmission, rtorrent is configured to a different port...

  12. #57
    Join Date
    Oct 2009
    Blog Entries
    Quote Originally Posted by la7low View Post
    How can I find out what uses port 80?
    It's typically webserver serving firmware web interface.
    But you can check this. For example, on my device it's nginx
    $ netstat -nlp | grep ':80 '
    tcp        0      0    *               LISTEN      579/nginx
    $ which nginx

Page 4 of 4 FirstFirst ... 234

Similar Threads

  1. [Howto] Install DLNA media servers for Oleg firmware
    By ecaddict in forum WL-500gP Tutorials
    Replies: 18
    Last Post: 06-06-2017, 08:40
  2. Optware Entware Asus RT-N56U
    By Omega in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 220
    Last Post: 06-02-2016, 11:53
  3. Replies: 24
    Last Post: 05-05-2015, 08:42
  4. Replies: 6
    Last Post: 21-09-2012, 18:06
  5. [Howto] Install kernel modules for Oleg firmware
    By ecaddict in forum WL-500gP Tutorials
    Replies: 0
    Last Post: 05-12-2011, 17:18

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts