Page 14 of 19 FirstFirst ... 41213141516 ... LastLast
Results 196 to 210 of 283

Thread: alpha rt-n firmware releases

  1. #196
    Join Date
    Nov 2006
    Location
    Russia, Moscow
    Posts
    3,640
    Quote Originally Posted by qingz View Post
    Does this firmware supports USB Webcam?
    At this moment, you have to compile webcam driver yourself.

    P.S. If someone help us with this task (tests and maybe additional patches), it will be much faster...
    Last edited by lly; 31-07-2010 at 08:25.

  2. #197
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by lly View Post
    At this moment, you have to compile webcam driver yourself.

    P.S. If someone help us with this task (tests and maybe additional patches), it will be much faster...
    I'm always up for beta testing

    btw, what drivers would you propose?
    still stick to the good old pwc and OV511 drivers?
    http://www.saillard.org/linux/pwc/
    http://ovcam.org/ov511/

    I mean there are some other drivers out that support more and are designed for kernel 2.6

  3. #198
    Join Date
    Nov 2006
    Location
    Russia, Moscow
    Posts
    3,640
    Quote Originally Posted by wpte View Post
    btw, what drivers would you propose?
    still stick to the good old pwc and OV511 drivers?
    http://www.saillard.org/linux/pwc/
    http://ovcam.org/ov511/
    I'm not use usb webcam, so I don't know

    I mean there are some other drivers out that support more and are designed for kernel 2.6
    Of course, we should use recent drivers for 2.6 & V4L2 (video for linux v2).

  4. #199
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by lly View Post
    Of course, we should use recent drivers for 2.6 & V4L2 (video for linux v2).
    V4L2 kernel module is included in the extra modules already (v4l2-common.ko) as far as I can see, so that's the first step

    Now the webcam drivers are all a bit old, latest updates from 2006 or so...
    but our kernel is a bit old as well

    Modern distro's usually use the UVC driver (http://www.ideasonboard.org/uvc/)
    but it seems that it's unusable because it doesn't support still imaging on which the current webcam setup is based if I'm correct
    yet, it supports an impressive list of devices

    so... I'm unsure: change the webcam page with the UVC driver or use the good ol' drivers

    ov511 drivers need some extra twi/i2c kernel modules for 2.6 apparently

  5. #200

    Wireless signal weak

    I have noticed a problem with the strength/range of the wireless signal.
    As soon as I install Oleg Firmware the wireless range become very limited!!!

    With Oleg Firmware (RT-N16-1.9.2.7-rtn-r1639) the wireless signal is only good in the same room - but with Asus Firmware (1.0.1.2) I have strong signal everywhere in my house.
    Just to confirm the settings:

    This is with Asus firmware 1.0.1.2:
    # nvram show | grep power
    size: 18028 bytes (14740 left)
    wl0_radio_power_x=17
    wl_radio_power_x=17

    And this Oleg:
    nvram show | grep power
    size: 14159 bytes (18609 left)
    wl0_radio_power_x=19
    wl_radio_power_x=19

    Everything is default values (factory default after installed).
    I have tried other values (30, 50 and even 84) but no big difference!

    Is there something wrong with how Oleg handles the three antennas on the N16 - since stock Asus 1.0.1.2 has strong signal and Oleg VERY weak?
    Ive also tried Asus 1.0.1.6 (found on their FTP) and this was ALSO weak signal!
    Can somebody check and confirm this?

  6. #201
    check signal and other ssids with this
    http://www.metageek.net/products/inssider
    feel free to post screenshoots here then

  7. #202
    Quote Originally Posted by theMIROn View Post
    check signal and other ssids with this
    http://www.metageek.net/products/inssider
    feel free to post screenshoots here then
    Below are the screenshots. Notice that Asus signal strength is better (-70dBm). Oleg is almost unusable (-85dBm) - even though "radio power" is 19 in oleg but only 17 in asus! Why

    Heres asus 1.0.1.2 (Im "WATERGATE"):
    Signal strength ~ -70dBm


    And heres RT-N16-1.9.2.7-rtn-r1867:
    Signal strength ~-85dBm!!!

  8. #203
    Join Date
    Feb 2008
    Location
    Copenhagen, Denmark
    Posts
    41

    Also a speed difference

    Here come some poor observations and surggestions from a noob.

    I see that asus 1.0.1.2 has a speed of 65 and the RT-N16-1.9.2.7-rtn-r1867 a speed of 54.

    Is this due to the difference in signal strength?

    Have you tried to measure the strength with another computer/network card?
    Last edited by Bohlendach; 04-08-2010 at 09:48.

  9. #204
    Quote Originally Posted by Bohlendach View Post
    Here come some poor observations and surggestions from a noob.

    I see that asus 1.0.1.2 has a speed of 65 and the RT-N16-1.9.2.7-rtn-r1867 a speed of 54.

    1.Is this due to the difference in signal strength?

    2.Have you tried to measure the strength with another computer/network card?
    1. Dont think so - Oleg was configured G only. Maybe thats it - cause I tested again with asus 1.0.1.2 also G only and then it measured 54. Still stronger signal though!
    2. Yes - tested with another laptop (different brand) AND my PS3. Same result...

    Best would be if someone could install 1.0.1.2 and confirm if they also get stronger signal....

  10. #205
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by Bohlendach View Post
    I see that asus 1.0.1.2 has a speed of 65 and the RT-N16-1.9.2.7-rtn-r1867 a speed of 54.
    speed is the (maximum) basic rate measured if I'm correct...

    I'm wondering though... why G only?
    if you set wireless mode to auto everything is supported

    Here I can still use internet at 50m distance trough trees and walls.
    moreover, turning the wifi power up doesn't necessarily increase the network strength

  11. #206
    Quote Originally Posted by wpte View Post
    I'm wondering though... why G only?
    if you set wireless mode to auto everything is supported
    Well - I just tested all possibilities to see if anything would increase signal - and it didnt, so I just happened to make the screenshot at the "wrong time"
    Nevertheless - I still have lower signal with Oleg than with Asus firmware. Same settings...

  12. #207
    Quote Originally Posted by Magna-Flash View Post
    I have noticed a problem with the strength/range of the wireless signal.
    As soon as I install Oleg Firmware the wireless range become very limited!!!

    With Oleg Firmware (RT-N16-1.9.2.7-rtn-r1639) the wireless signal is only good in the same room - but with Asus Firmware (1.0.1.2) I have strong signal everywhere in my house.
    Just to confirm the settings:

    This is with Asus firmware 1.0.1.2:
    # nvram show | grep power
    size: 18028 bytes (14740 left)
    wl0_radio_power_x=17
    wl_radio_power_x=17

    And this Oleg:
    nvram show | grep power
    size: 14159 bytes (18609 left)
    wl0_radio_power_x=19
    wl_radio_power_x=19

    Everything is default values (factory default after installed).
    I have tried other values (30, 50 and even 84) but no big difference!

    Is there something wrong with how Oleg handles the three antennas on the N16 - since stock Asus 1.0.1.2 has strong signal and Oleg VERY weak?
    Ive also tried Asus 1.0.1.6 (found on their FTP) and this was ALSO weak signal!
    Can somebody check and confirm this?
    Quoting myself just to show what Im referring to
    Im a total noob at this - so I do not know how to check - BUT can there be something with MIMO settings for the antenna?

  13. #208
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by Magna-Flash View Post
    Quoting myself just to show what Im referring to
    Im a total noob at this - so I do not know how to check - BUT can there be something with MIMO settings for the antenna?
    in the nvram you can change:
    wl_mimo_preamble=mm
    wl0_mimo_preamble=mm
    (standard)

    moreover you can do some advanced settings with the wl command. (see attachment)

    I don't know much about this, so you can break it, or you can make it
    Attached Files Attached Files

  14. #209
    The last command in the "wl help" looks very interesting:
    mimo_ss_stf
    g/set SS STF mode.
    Usage: wl mimo_ss_stf <value> <-b a | b>
    value: 0 - SISO; 1 - CDD
    -b(band): a - 5G; b - 2.4G
    If that value is set to 0 (SISO=single input/single output) then RT-n16 would use only one antenna, right?
    Am I the only one with weak wireless signal (with Oleg firmware - Asus stock is normal)???
    Last edited by Magna-Flash; 09-08-2010 at 08:44.

  15. #210
    Quote Originally Posted by Magna-Flash View Post
    The last command in the "wl help" looks very interesting:

    If that value is set to 0 (SISO=single input/single output) then RT-n16 would use only one antenna, right?
    Am I the only one with weak wireless signal (with Oleg firmware - Asus stock is normal)???
    I have this same problem

Page 14 of 19 FirstFirst ... 41213141516 ... LastLast

Similar Threads

  1. Essential Firmware Questions
    By vladk2k in forum WL-500gP Firmware Discussion
    Replies: 9
    Last Post: 14-10-2009, 12:10
  2. wl500gP v1 not booting after successfull flash of custom firmware
    By nocturne.op.15 in forum WL-500gP Firmware Discussion
    Replies: 6
    Last Post: 13-07-2008, 02:28
  3. New Oleg firmware 1.9.2.7-9 problems?
    By wpte in forum WL-500gP Firmware Discussion
    Replies: 11
    Last Post: 18-04-2008, 00:34
  4. Visit WL-500g Firmware Releases forum
    By Oleg in forum WL-550gE Firmware Discussion
    Replies: 7
    Last Post: 18-09-2006, 11:22
  5. Flashing Oleg's Firmware in WL HDD
    By hugo in forum WL-HDD Custom Development
    Replies: 29
    Last Post: 21-10-2004, 15:55

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •