Results 1 to 8 of 8

Thread: mt-daapd itunes server

  1. #1

    mt-daapd itunes server

    Hi

    I have installed (via the fantastic ipkg package system Thanks also for the great howtos available!! ) mt-daapd to set up an Itunes server. My ultimate goal is to make this server via ssh tunnel available to my friends.

    I have set all the necessary parameters (port, mp3 location, etc) but mt-daapd just doesn't seem to work. Also I have no error messages which show up.... and its not running when I look at the running processes?!

    Somebody is running mt-daapd successfully?

    Cheers,
    Rainer

    ps: I just thought maybe this should be in the Q&A Forum, if so you can move it there
    Last edited by rdk; 29-04-2005 at 16:36. Reason: maybe better in Q&A??

  2. #2
    I've managed to to install and use it, I did one change in the /etc/init.d/S60mt-daapd

    /opt/sbin/mt-daapd -y -c /opt/etc/mt-daapd/mt-daapd.conf &

    Cant remember exactly how this line is original, notice the -y -c and & in the end.

    This works for me. just be patience if u have alot of mp3, it takes time to scan the library.

    hope this helps

    mulloG

  3. #3
    Thanks a lot for these infos!!

    I will try when I have some time

    Regards,
    Rainer

  4. #4
    I still cannot get it to work

    I have tried specifying the config file -c option and also the -y option for running it as non-root user....

    Its just starting with no error messages and when I look at running processes its not showing up at all....

    Have you changed something else in the config file?

    I just have specified the mp3 directory....

    Regards,
    Rainer

  5. #5
    Finally its runnig :-) I just had to great a guest account (adduser guest) because thats what it wants to run :-)) This is just great open itunes on any PC on the lan and see the music!!
    Now I just would like to be able to use howl or mdnsresponder to broadcast this server? Anyone has an idea?

    Regards,
    Rainer

  6. #6

    I must be stupid !

    Hello,
    I have a problem in starting mt-daapd.
    The log file says :

    Starting rendezvous daemon
    Error in drop_privs: Success
    Starting signal handler
    Signal handler stardted

    When I ps -ax no mt-daapd service is running

    I tried to runas admin in the mt-daapd.conf file since admin is obviously a declared user. No way

    I've read carefully the thread and I can't "adduser" !
    Here is the box reply...
    -sh: adduser: not found

    Did I miss something ?

    Thanks for the help guys !

  7. #7

    Am I stupid ? (2)

    I must add that when I try to connect to 192.168.1.1:3689 with my internet browser (Firefox) the connexion is refused.

    Sounds far from a solution ...

  8. #8

    No, I wasn't (stupid) !

    Here is the solution:
    in the start script /opt/etc/init.d/S60mt-daapd I have replaced the line:
    /opt/sbin/mt-daapd -c /opt/etc/mt-daapd/mt-daapd.conf
    with
    /opt/sbin/mt-daapd -f -d 5 -c /opt/etc/mt-daapd/mt-daapd.conf

    Don't ask me why it works like that, I don't know, and I'm happy like that.
    I just wanted to share this since other guys will probably have to face the same problem.

    P.S: I still don't know how to create a new user in the box, so I used runas admin in the mt-daapd.conf

Similar Threads

  1. SlimServer or daapd on wl500g?
    By pludlow in forum WL-500g Q&A
    Replies: 3
    Last Post: 17-10-2006, 14:39
  2. Replies: 6
    Last Post: 10-09-2005, 22:03
  3. iTunes en netwerk
    By moulin in forum Dutch Discussion - Nederlands
    Replies: 0
    Last Post: 10-08-2005, 15:03
  4. itunes server / ipkg
    By fhanauer in forum WL-500g Q&A
    Replies: 4
    Last Post: 07-07-2005, 12:28
  5. iTunes server
    By dsf260 in forum WL-500g Custom Development
    Replies: 9
    Last Post: 27-01-2005, 10:12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •