Page 12 of 15 FirstFirst ... 21011121314 ... LastLast
Results 166 to 180 of 212

Thread: Проблема с telnet в настройках wl-500gp

  1. Попробуйте через телнет
    Code:
    nvram set http_passwd="ваш пароль" (без кавычек)
    nvram commit
    И перезагрузите роутер, пароль должен смениться.
    WNR3500L + 1.9.2.7-rtn

  2. #167
    Спасибо пароль сменился! Хотя роутер на заданый пороль не отвечает, все ровно считаю это большим скачком! Планирую скинуть настройки "резет" Ошибка, я считаю, заключалась в том что я набрал nvram set http_passwd=******nvram commit и нажал enter, а надо было nvram set http_passwd=****** - enter - nvram commit .

  3. #168
    Join Date
    Nov 2009
    Location
    Moscow
    Posts
    3

    Пропала возможность попасть на роутер через Telnet и SSH

    Тысячу извинений, за банальный вопрос.
    Изучил все подобные посты, а ответа так и не нашел. Если бы не повторение проблемы на двух разно происталлированных системах и на разных физических WL500gP и WL500gPV, то не был бы так озабочен.
    Суть вопроса такова: На запрос о вводе правильного "password" для root терминал не реагирует "приглашением". Попытки равно безуспешные для telnet, ssh. Длительное ожидание ответа оболочки не помагает. Перед этим отваливалось автомонтирование flash-ки. В вэб интерфейсе доступ к обеим командам включен, иначе бы до ввода пароля не дошел.
    Мучит паранойя: брутфорсят???, IP-то белый.
    Поможите, добры люди советом. Причины... Советы по дальнейшим шагам... Кто чем может.

  4. #169
    Join Date
    Mar 2009
    Location
    Default City
    Posts
    2,695
    Blog Entries
    4
    Quote Originally Posted by prosto_users_WL View Post
    Тысячу извинений, за банальный вопрос.
    Изучил все подобные посты, а ответа так и не нашел. Если бы не повторение проблемы на двух разно происталлированных системах и на разных физических WL500gP и WL500gPV, то не был бы так озабочен.
    Суть вопроса такова: На запрос о вводе правильного "password" для root терминал не реагирует "приглашением". Попытки равно безуспешные для telnet, ssh. Длительное ожидание ответа оболочки не помагает. Перед этим отваливалось автомонтирование flash-ки. В вэб интерфейсе доступ к обеим командам включен, иначе бы до ввода пароля не дошел.
    Мучит паранойя: брутфорсят???, IP-то белый.
    Поможите, добры люди советом. Причины... Советы по дальнейшим шагам... Кто чем может.
    А в логе посмотреть не судьба? Он через веб-мордочку доступен даже )

  5. #170
    Join Date
    Nov 2009
    Location
    Moscow
    Posts
    3
    Quote Originally Posted by TReX View Post
    А в логе посмотреть не судьба? Он через веб-мордочку доступен даже )
    Домой приду, первым делом скопипастю лог. Прошу прощения, на работе роутер не доступен, а ответ хотелось как можно быстрее.
    И вот пришел и... доступ по SSH появился. Мне очень стыдно.
    Однако привожу лог ошибки монтирования Flash-ки.:
    Aug 23 20:05:05 kernel: scsi0 : SCSI emulation for USB Mass Storage devices
    Aug 23 20:05:06 kernel: Vendor: JetFlash Model: Transcend 4GB Rev: 8.07
    Aug 23 20:05:06 kernel: Type: Direct-Access ANSI SCSI revision: 02
    Aug 23 20:05:06 kernel: Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
    Aug 23 20:05:06 kernel: sda: Waiting for disc 0 to settle.
    Aug 23 20:05:06 kernel: SCSI device sda: 7843840 512-byte hdwr sectors (4016 MB)
    Aug 23 20:05:06 kernel: sda: Write Protect is off
    Aug 23 20:05:06 kernel: Partition check:
    ..........................
    Aug 23 20:05:06 kernel: /dev/scsi/host0/bus0/target0/lun0: p1 p2 p3
    .......................
    Aug 23 19:44:02 kernel: Adding Swap: 257000k swap-space (priority -1)
    Aug 23 19:44:04 e2fsck: /dev/discs/disc0/part2: recovering journal
    Aug 23 19:44:04 kernel: Device 08:02 not ready.
    Aug 23 19:44:04 kernel: I/O error: dev 08:02, sector 101488
    Aug 23 19:44:04 kernel: SCSI disk error : host 0 channel 0 id 0 lun 0 return code = 8000002
    Aug 23 19:44:04 kernel: Info fld=0x0, Current sd08:02: sns = f0 7
    Aug 23 19:44:04 kernel: ASC=27 ASCQ= 0
    Aug 23 19:44:04 kernel: Raw sense data:0xf0 0x00 0x07 0x00 0x00 0x00 0x00 0x0a 0x00 0x00 0x00 0x00 0x27 0x00 0x00 0x00 0x00 0x00
    Last edited by prosto_users_WL; 23-08-2010 at 17:14. Reason: дополнил сведениями системы

  6. скрипт сообщает следующее:
    /tmp/local/sbin/mail.sh: readonly: line 108: PIPE_IN: is read only
    Подскажите, пожалуйста, что я не так делаю?

  7. #172
    Quote Originally Posted by Rung View Post
    скрипт сообщает следующее:
    Подскажите, пожалуйста, что я не так делаю?
    Хм... странно, первый раз такое вижу. такое впечатление, что не может присвоить значение переменной PIPE_IN из-за того, что она read-only, хотя она как раз в этой строчке задается.
    На какой прошивке запускаете? у меня нормально работает.

    Можно попробовать убрать ключевое слово readonly в это строке и строках 110, 112

  8. Quote Originally Posted by brain-ripper View Post
    ....
    На какой прошивке запускаете? у меня нормально работает.

    ...
    •Версия ОС: Linux version 2.4.37.9
    •Прошивка: 1.9.2.7-d-r1825

    Quote Originally Posted by brain-ripper View Post
    ....

    Можно попробовать убрать ключевое слово readonly в это строке и строках 110, 112
    Убрал, скрип сработал и доставил письмо по адресу. Спасибо!

    Prepare to send mail
    Sending mail...
    Successfuly sent.

  9. #174
    Подскажите как выключить Wi-Fi через веб интерфейс толком не работает (живет своей жизнью).

  10. #175

    Exclamation

    Quote Originally Posted by Sharko 555 View Post
    Подскажите как выключить Wi-Fi через веб интерфейс толком не работает (живет своей жизнью).
    Заходим в веб рутера, выбираем Wireless - Advanced (надеюсь, хоть это, сможешь сам отыскать?!)
    Далее находим (с правой стороны): Enable Radio? тыкаем в No
    А потом нажимаются самые магические кнопки: сначала <Apply> потом <Finish> а вот только после нажатия этих двух, появицца <Save&Restart>
    После перезагрузки рутера Wi-Fi будет отключен "железно"...

    P. S. У кого не сохраняет пароль или др. настройки - не забывайте на любой станице (где есть кнопки <Apply> и <Finish>) нажать <Apply> потом <Finish> а затем <Save&Restart>
    Asus RT-N16: RT-N16-1.9.2.7-rtn-r2899.trx - 3.5'' USB HDD HP 1TB + JetFlash 2Gb
    |БП от iEEE PC 12V x 3A | Samba 3.5 + UDPxy (IPTV) Full HD Player
    D-Link DIR-320: DIR320-1.9.2.7-d-r2856M.trx <-- WAN: Huawei E220 (2G/3G)
    Asus WL-500GPv2: WL500gpv2-1.9.2.7-rtn-r2455.trx <-- WAN: Axesstel MV110 (CDMA EvDO Rev. A) | nShaper работает и на -rtn ветке!

  11. #176
    Просто раньше отключал так заходил веб интервейс роутора - Status & Log- Wireless-disabled
    Wi-Fi отключался но со временем я обнаруживал, что он работает
    (Iguana - большое спасибо за доверие оказанное мне по вопросу поиска Wireless - Advanced)

  12. #177
    Quote Originally Posted by Sharko 555 View Post
    Просто раньше отключал так заходил веб интервейс роутора - Status & Log- Wireless-disabled
    Wi-Fi отключался но со временем я обнаруживал, что он работает
    (Iguana - большое спасибо за доверие оказанное мне по вопросу поиска Wireless - Advanced)
    Ну мало-ли
    Буквально несколько дней назад обсуждалась работа: Status & Log- Wireless-disabled (речь шла о том, что это отключение/включение временное, до перезагрузки рутера, а Wireless - Advanced - надолго) - данное обсуждение поиском найти, ведь, не смог
    Asus RT-N16: RT-N16-1.9.2.7-rtn-r2899.trx - 3.5'' USB HDD HP 1TB + JetFlash 2Gb
    |БП от iEEE PC 12V x 3A | Samba 3.5 + UDPxy (IPTV) Full HD Player
    D-Link DIR-320: DIR320-1.9.2.7-d-r2856M.trx <-- WAN: Huawei E220 (2G/3G)
    Asus WL-500GPv2: WL500gpv2-1.9.2.7-rtn-r2455.trx <-- WAN: Axesstel MV110 (CDMA EvDO Rev. A) | nShaper работает и на -rtn ветке!

  13. #178
    Подскажите, у меня такая же проблема - не могу подключить по ssh к роутеру с компа, из внутренней сети.
    Прошивка - 1.9.2.7-9. Модель - ASUS WL-500G Premium
    Мне тоже до 1.9.2.7-10 обновиться?
    А то меня как-то напрягает это примечание:
    Эта прошивка не поддерживает оригинальные устройства WL-500g
    Вот тут написано:
    4) Подключиться к шеллу роутера можно по протоколу telnet программой putty (www.putty.nl), имя для входа "admin", пароль если не меняли такой же.
    Проверить настроен ли SSH-сервер:
    cat /usr/local/sbin/post-boot
    если выдаст "dropbear", то перейти к следующему пункту.
    mkdir -p /usr/local/etc/dropbear
    dropbearkey -t dss -f /usr/local/etc/dropbear/dropbear_dss_host_key
    dropbearkey -t rsa -f /usr/local/etc/dropbear/dropbear_rsa_host_key
    mkdir -p /usr/local/sbin/
    echo "#!/bin/sh" >> /usr/local/sbin/post-boot
    cp /usr/local/sbin/post-boot /usr/local/sbin/post-firewall
    cp /usr/local/sbin/post-boot /usr/local/sbin/post-mount
    cp /usr/local/sbin/post-boot /usr/local/sbin/pre-shutdown
    chmod +x /usr/local/sbin/p*
    echo "dropbear > /dev/null 2>&1" >> /usr/local/sbin/post-boot
    dropbear > /dev/null 2>&1
    flashfs save
    flashfs commit
    flashfs enable
    можно будет заходить по SSH с клиентов типа putty (в параметрах putty Windows->Translation можно выставить кодировку Win1251)
    У меня в ответ на cat /usr/local/sbin/post-boot
    выдаёт
    cat: /usr/local/sbin/post-boot: No such file or directory

    Что делать?
    Last edited by Omega; 25-12-2011 at 17:58. Reason: fixed

  14. #179
    Quote Originally Posted by MAzZY View Post
    Вот тут написано:


    У меня в ответ на cat /usr/local/sbin/post-boot
    выдаёт
    cat: /usr/local/sbin/post-boot: No such file or directory

    Что делать?
    /usr/local/sbin/post-boot - это текстовый файл, аналог autorun.bat в DOS\WIN9x. В нем прописаны команды, которые надо делать при запуске, по очереди.
    Разбор построчно вашей фигни.
    cat /usr/local/sbin/post-boot
    Показать содержимое cat /usr/local/sbin/post-boot. Защита от дурака, чтобы проверить, есть ли у нас уже post-boot и может быть там уже прописан старт SSH-сервера dropbear

    mkdir -p /usr/local/etc/dropbear
    Создать папку /usr/local/etc/dropbear . (-p значит что создать структуру каталогов, то есть "Если нет папки /usr, создать /usr, затем, если нет папки /usr/local, создать папку /usr/local....)

    dropbearkey -t dss -f /usr/local/etc/dropbear/dropbear_dss_host_key
    dropbearkey -t rsa -f /usr/local/etc/dropbear/dropbear_rsa_host_key
    Сгенерировать ключи для SSH-сервера. Ключи используются для шифрования канала.

    mkdir -p /usr/local/sbin/
    Создать папку /usr/local/sbin/

    echo "#!/bin/sh" >> /usr/local/sbin/post-boot
    ДОписать #!/bin/sh в файл /usr/local/sbin/post-boot . Строка #!/bin/sh говорит системе, что этот файл выполняется интерпретатором /bin/sh (то есть стандартной командной оболочкой). Было бы там #!/bin/php, то он бы обрабатывался как php-скрипт

    cp /usr/local/sbin/post-boot /usr/local/sbin/post-firewall
    cp /usr/local/sbin/post-boot /usr/local/sbin/post-mount
    cp /usr/local/sbin/post-boot /usr/local/sbin/pre-shutdown
    Скопировать файл /usr/local/sbin/post-boot под именами post-firewall, post-mount.

    chmod +x /usr/local/sbin/p*
    Проставить всем файлам в папке /usr/local/sbin/, начинающимся на "p" флаг "исполняемый". Это значит что файл можно запускать как любую программу (как exe-шник).

    echo "dropbear > /dev/null 2>&1" >> /usr/local/sbin/post-boot
    Дописать dropbear > /dev/null 2>&1 в /usr/local/sbin/post-boot

    dropbear > /dev/null 2>&1
    Запустить dropbear.

    flashfs save
    flashfs commit
    flashfs enable
    Сохранить память
    Затем проверьте содержимое скрипта командой
    cat /usr/local/sbin/post-boot. Вывод должен быть такой%
    Code:
    #!/bin/sh
    dropbear > /dev/null 2>&1
    Last edited by FilimoniC; 09-03-2011 at 18:32.
    Sorry for my bad English.
    Покупайте Отечественных Слонов!!!

  15. #180
    Разбор построчно вашей фигни
    Это не моя фигня, а из фака

    Спасибо, буду разбираться

Page 12 of 15 FirstFirst ... 21011121314 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •