Results 1 to 7 of 7

Thread: thttpdphp new version from yesterday (16-04-2005) problems !

  1. #1

    thttpdphp new version from yesterday (16-04-2005) problems !

    Hi

    Just tried to install the latest thttpdphp build, and that dosnt work too well :

    [ksn@utopia root]$ /opt/bin/ipkg install thttpdphp
    Installing thttpdphp (2.25b-5.0.3-2) to root...
    Downloading http://ipkg.nslu2-linux.org/feeds/un...3-2_mipsel.ipk
    ERROR: Cannot satisfy the following dependencies for thttpdphp:
    gconv-modules
    Nothing to be done
    An error ocurred, return value: 1.


    If I wget the "old" package and install that, the same problem does not occur :

    [ksn@utopia root]$ wget http://ipkg.nslu2-linux.org/feeds/un...3-1_mipsel.ipk
    Connecting to ipkg.nslu2-linux.org[66.35.250.210]:80
    thttpdphp_2.25b-5.0. 100% |************************************************* *****************| 747 KB 00:00 ETA
    [ksn@utopia root]$ /opt/bin/ipkg install thttpdphp_2.25b-5.0.3-1_mipsel.ipk
    Installing thttpdphp (2.25b-5.0.3-1) to root...
    Configuring thttpdphp


    To complete the installation, you must edit /opt/etc/thttpd.conf,
    and then run /opt/etc/init.d/S80thttpd to start thttpd.

    Successfully terminated.


    Who is maintaining the repository at :
    http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/
    ?

    I seem to have a problem with dependencies with xmail as well, just to let the person know :-)

    [ksn@utopia root]$ /opt/bin/ipkg install xmail
    Installing xmail (1.21-2) to root...
    Downloading http://ipkg.nslu2-linux.org/feeds/un...1-2_mipsel.ipk
    ERROR: Cannot satisfy the following dependencies for xmail:
    libstdc++ syslogd
    Nothing to be done
    An error ocurred, return value: 1.


    Regards
    macsat

  2. #2
    Join Date
    Jul 2004
    Location
    near Lyon @ France
    Posts
    195
    I'm maintaining the package.
    Olds one use to depends on packages I created and hosted @ bobo-rousselin.com
    Last thttpdphp package (hosted @ unslung feed) depends on unslung packages but some of them requires gconv-modules. I'm working on this to solve the problem quickly.

    jf

  3. #3
    Join Date
    Jul 2004
    Location
    near Lyon @ France
    Posts
    195
    a dummy gconv-modules has been published to short-term solve this issue.
    You should be abble to install thttpdphp (after ipkg update).

    Try it and tell me.

  4. Not working for me sadly...

    im only getting:

    [admin@dhcppc0 bin]$ ipkg install thttpdphp
    Cannot find package thttpdphp.
    Check the spelling or perhaps run 'ipkg update'
    Nothing to be done
    An error ocurred, return value: 4.

  5. #5
    Well, I concur. It's not there right now.
    Try this for now to use Jean-Fabrice's repository as well:
    Code:
    echo src bobo http://www.bobo-rousselin.com/wl/ipkg >> /opt/etc/ipkg.conf
    ipkg update
    ipkg install thttpd-php

  6. #6
    Join Date
    Mar 2005
    Location
    the hague
    Posts
    33
    Quote Originally Posted by macsat
    Hi

    Just tried to install the latest thttpdphp build, and that dosnt work too well :

    [ksn@utopia root]$ /opt/bin/ipkg install thttpdphp
    Installing thttpdphp (2.25b-5.0.3-2) to root...
    Downloading http://ipkg.nslu2-linux.org/feeds/un...3-2_mipsel.ipk
    ERROR: Cannot satisfy the following dependencies for thttpdphp:
    gconv-modules
    Nothing to be done
    An error ocurred, return value: 1.


    If I wget the "old" package and install that, the same problem does not occur :

    [ksn@utopia root]$ wget http://ipkg.nslu2-linux.org/feeds/un...3-1_mipsel.ipk
    Connecting to ipkg.nslu2-linux.org[66.35.250.210]:80
    thttpdphp_2.25b-5.0. 100% |************************************************* *****************| 747 KB 00:00 ETA
    [ksn@utopia root]$ /opt/bin/ipkg install thttpdphp_2.25b-5.0.3-1_mipsel.ipk
    Installing thttpdphp (2.25b-5.0.3-1) to root...
    Configuring thttpdphp


    To complete the installation, you must edit /opt/etc/thttpd.conf,
    and then run /opt/etc/init.d/S80thttpd to start thttpd.

    Successfully terminated.


    Who is maintaining the repository at :
    http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/
    ?

    I seem to have a problem with dependencies with xmail as well, just to let the person know :-)

    [ksn@utopia root]$ /opt/bin/ipkg install xmail
    Installing xmail (1.21-2) to root...
    Downloading http://ipkg.nslu2-linux.org/feeds/un...1-2_mipsel.ipk
    ERROR: Cannot satisfy the following dependencies for xmail:
    libstdc++ syslogd
    Nothing to be done
    An error ocurred, return value: 1.


    Regards
    macsat
    same problem for me in case of:

    ipkg install py-bittorrent
    Installing py-bittorrent (4.2.2-1) to root...
    Downloading http://ipkg.nslu2-linux.org/feeds/un...2-1_mipsel.ipk
    Nothing to be done
    An error ocurred, return value: 1.
    Collected errors:
    ERROR: Cannot satisfy the following dependencies for py-bittorrent:
    libstdc++

    i'have installed already:
    ipkg list_installed|grep modules
    gconv-modules - 2.2.5-5 - Provides gconv modules missing from the firmware. These are used.
    How to solve this problem ?

    thanxs

  7. #7
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    Several people are developing this optware packages concurrently for various target systems. wl500g is just one of them.

    For libstdc++ the problem is so complex, that it cannot be explained in single sentence. In short. No hope for all packages that depend on libstdtc++ in near future.
    Last edited by oleo; 06-01-2006 at 20:41.

Similar Threads

  1. GPL Firmware 1.9.5 release (02/09/2005)
    By tscoreninja in forum WL-500g Firmware Releases
    Replies: 17
    Last Post: 29-10-2005, 14:22
  2. Replies: 2
    Last Post: 20-09-2005, 12:50
  3. Replies: 0
    Last Post: 19-09-2005, 13:52
  4. Which version of FW most stable?
    By erikgj in forum WL-500g Q&A
    Replies: 3
    Last Post: 08-02-2005, 09:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •