Results 1 to 6 of 6

Thread: rtorrent does not download

  1. #1

    rtorrent does not download

    I've installed rtorrent, everything goes well and then I started it:
    "rtorrent -n -o import=/opt/etc/rtorrent.conf"

    It loads the torrent but never downloads anything. Always 0.0 everything, except that the file size is correct.

    Any suggestions? Thanks.

  2. #2
    Did you test if the port through the firewall is open?

  3. #3

    re:

    Just checked. It is actually open, that is, port 51779.
    Last edited by onewiki; 29-09-2009 at 00:13.

  4. #4
    do you have all dependencies installed?

    e.g.

    libtorrent, libsigc++, ncursesw, ncurses, libcurl


    maybe try another torrent first.

  5. #5
    without these packages, rtorrent wouldn't even be able to run. So they are not the issue. I certainly have tried multiple torrents, but thanks for reply.

  6. #6

    Problem solved and a tutorial available now

    I figured it out. Of course it is due to my stupid mistake. I didn't do two things:
    1. make post-firewall executable
    2. put #!/bin/sh at the beginning of the script.

    So a brief addendum to the following tutorial:
    http://wl500g.info/showthread.php?t=16416&page=2

    do two things:
    1.
    $ nano /usr/local/sbin/post-firewall

    #!/bin/sh
    # set default policy
    iptables -P INPUT DROP
    # remove last default rule
    iptables -D INPUT -j DROP

    iptables -A INPUT -p tcp --dport 51777:51780 -j ACCEPT
    iptables -A INPUT -p udp --dport 6881 -j ACCEPT

    # Restablishing INPUT chain policy
    iptables -A INPUT -j DROP

    2.
    $ chmod +x /usr/local/sbin/post-firewall

    flashfs save && flashfs commit && flashfs enable && reboot

Similar Threads

  1. [How to] rtorrent & ntorrent
    By mancub in forum WL-500gP Tutorials
    Replies: 101
    Last Post: 18-12-2008, 08:21
  2. small number of peers for rTorrent
    By ufo95 in forum WL-500gP Q&A
    Replies: 0
    Last Post: 10-11-2008, 09:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •