Results 1 to 5 of 5

Thread: Oleg + NAS

  1. #1

    Oleg + NAS

    Czy komuś udało się podmontować dysk sieciowy (NAS) w routerze z FW Olega ?
    Jeśli tak - to jak ???

    Mam WL-500W, firmware Olega (wersja z lutego 2009), dysk NAS z obsługą SMB.
    Nazwa sieciowa dysku to \\nas, udział pliki, adres 192.168.1.102, user=user i pass= pass.
    Chciałbym zamontować udział z dysku w punkcie montowania /tmp/harddisk2
    Doinstalowałem poprzez IPKG pakiet samba2 - ale nadal nie działa montowanie udziałów sieciowych poleceniem:
    mount -t smb -o username=user,password=pass //192.168.1.102/pliki /tmp/harddisk2
    (komunikat - brak urządzenia).

    Help me !

  2. #2
    Join Date
    Aug 2008
    Location
    Poland, Biała Podlaska
    Posts
    276
    Musisz załadować odpowiedni moduł kernela.

    http://lesiuk.ath.cx/smbfs.o

    Pobierz to gdzieś i daj insmod /sciezka/do/smbfs.o

    Po każdym restarcie routera będziesz musiał to ładować więc dodaj gdzieś do skryptów startowych.

    A tak poza tym to -t smbfs.

    EDIT:
    mount -t smbfs -o username=[YOUR USER NAME],ip=sam.cims.nyu.edu,workgroup=CIMSSMB //sam.cims.nyu.edu/[YOUR USER NAME] /mnt/myhome
    Last edited by Lesiuk; 31-08-2009 at 17:32.

  3. #3
    Quote Originally Posted by Lesiuk View Post
    Musisz załadować odpowiedni moduł kernela.
    Moduł załadowany - ale nadal nie działa:
    Code:
    $ mount -t smbfs -o username=slawek,password=slawek //192.168.1.102/pliki /tmp/mnt/nas
    mount: Mounting //192.168.1.102/pliki on /tmp/mnt/nas failed: No such file or directory
    Hmmm...rzeczywiście - nie ma katalogu /tmp/mnt/nas
    Utworzyłem wiec podkatalog /nas i ponowiłem próbę:

    Code:
    $ mount -t smbfs -o username=slawek,password=slawek //192.168.1.102/pliki /tmp/mnt/nas
    mount: Mounting //nas on /tmp/mnt/nas failed: Invalid argument
    znowu pudło - nie działa montowanie w katalogu.
    utworzyłem więc symlink /tmp/mnt/nas2 i:

    Code:
    $ mount -t smbfs -o username=slawek,password=slawek //192.168.1.102/pliki /tmp/mnt/nas2
    mount: Mounting //nas on /tmp/mnt/nas2 failed: Invalid argument
    z poziomu stacji Windows udział sieciowy \\nas\pliki oraz \\192.168.1.102\pliki działa bez problemu

    w logach routera znalazłem taki wpis:
    mount_data version 1919251317 is not supported


    nie mam pomysłów co dalej...
    Last edited by SlawekW; 02-09-2009 at 17:28.

  4. #4
    Join Date
    Aug 2008
    Location
    Poland, Biała Podlaska
    Posts
    276
    huh, u mnie to samo

    w syslogu:
    Code:
    [root@LesiukNET root]$ dmesg | grep smbfs
    smbfs: mount_data version 1919251317 is not supported
    właśnie szukam jakiegoś rozwiązania

    jak tylko coś znajdę do zedytuje ten post

    EDIT:
    Wyłącz sambę w panelu, zainstaluj samba2 z repo. (ipkg install samba2)
    Powinno zadziałać.

    Koniecznie napisz czy działa.
    Niestety nie miałem gdzie tego sprawdzić.

    Skrypt do montowania:
    Code:
    #!/bin/sh
    #script: mount to mountpoint "checkdir" and create folder when not present
    #the script toggles the mount option
    #you can use this script as often you need, just adjust share and checkdir
    #written by newbiefan for asus users
    
    share=//192.168.178.150/PUBLIC
    #dirname of mountpoint 
    checkdir=/tmp/mnt/extern1
    
    if [ -d $checkdir ] ; then
       echo Directory $checkdir exists, nothing to do
      else
       mkdir $checkdir
       echo Directory $checkdir created 
    fi
    
    if mount | grep $checkdir ; then   #is already mounted
       /opt/bin/smbumount $checkdir
       echo -n $checkdir " unmounted "
       date
      else # is not mounted  
       /opt/bin/smbmount $share $checkdir -o rw,guest
       sleep 1
       echo -n SMB-share  $share mounted to $checkdir 
       date
    fi
    Last edited by Lesiuk; 02-09-2009 at 19:06.

  5. #5
    Quote Originally Posted by Lesiuk View Post
    Koniecznie napisz czy działa.
    Niestety nie miałem gdzie tego sprawdzić.
    DZIAŁA !!!

    W czym był problem ?
    Zamiast pisać:
    mount -t smbfs .......
    należało użyć komendy ze ścieżką:
    /opt/bin/smbumount ..............

    i gra gitara !

    Wielkie dzięki - jesteś wielki !

Similar Threads

  1. [Prob] Mediatomb UPnP Media Server auf dem Asus Wl-500 gP (Oleg)? Wie?
    By edelknecht in forum German Discussion - Deutsch (DE)
    Replies: 15
    Last Post: 16-04-2010, 12:54
  2. NAS: Create your own caching proxy
    By vinyols in forum WL-500gP Tutorials
    Replies: 8
    Last Post: 24-09-2009, 19:38
  3. Oleg firmware ftp help
    By trxtrx in forum WL-500gP Q&A
    Replies: 8
    Last Post: 16-04-2009, 17:43
  4. Oleg firmware ftp help
    By trxtrx in forum WL-500gP Q&A
    Replies: 2
    Last Post: 24-11-2008, 11:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •