Page 1 of 6 123 ... LastLast
Results 1 to 15 of 80

Thread: Зависание вэб-морды роутера

  1. #1

    Question Зависание вэб-морды роутера

    В общем купил я 500gP. Перепрошил, все вроде работает и WIFI и Lan/ Вот только проблема, когда вхожу в роутер и скажем меняю какие нибудь параметры и нажимаю Appy то IE начинает весть, причем если нажать Finish to все работает и обновляеться и работает.
    В чем дело может кто подскажет

  2. #2

    Зависает сабака 500gp

    В поиске ничего не нашел поэтому решил найти решение в новой ветке!

    Иногда раз в день иногда раз в неделю зависает странным образом ви-фишная часть коробочки!... т.е. не видит его никто, ни один комп. Лечится выдергиваем из сети и втыканием обратно! Заметил что зависает когда к нему никто не подключен(т.е. я на работе) думаю может кто нить пробует его хакнуть ну он и зависает!

    Стоит последняя олеговская прошивка...

    Чего порекомендуете.?

  3. #3

    Question Еженедельные зависания

    Достаточно долгое время мучался спонтанными зависаниями роутера, пока не решил ради интереса добавить в логи вывод uptime. И обнаружилась интересная закономерность - железка зависает ровно спустя неделю после загрузки. Само зависание выглядит следующим образом: гаснет лампочка WiFi, полностью пропадает менеджмент и перестают отвечать все сетевые службы. В попытках разобраться отключил HDD и поотключал большую часть служб и софта. Список того, что работает в данный момент:

    PHP Code:
    [routah:~] p
      PID TTY      STAT   TIME COMMAND
        1 
    ?        S      0:01 /sbin/init
        2 
    ?        S      0:00 [keventd]
        
    ?        RN    40:01 [ksoftirqd_CPU0]
        
    ?        S      0:00 [kswapd]
        
    ?        S      0:00 [bdflush]
        
    ?        S      0:00 [kupdated]
        
    ?        S      0:00 [mtdblockd]
       
    64 ?        S      0:00 telnetd
       69 
    ?        S      0:00 httpd vlan1
       72 
    ?        S      0:00 snmpd -/tmp/snmpd.conf
       81 
    ?        Ss     0:01 nas /tmp/nas.lan.conf /tmp/nas.lan.pid lan
       84 
    ?        S      0:00 [khubd]
      
    104 ?        S      0:01 [usb-storage-0]
      
    105 ?        S      0:00 [scsi_eh_0]
      
    188 ?        S      0:03 /usr/sbin/igmpproxy -/etc/igmpproxy.conf
      192 
    ?        S      0:00 udhcpc -i vlan1 -/var/run/udhcpc0.pid -/tmp/udhcpc -b
      194 
    ?        S      1:54 l2tpd
      200 
    ?        S      0:03  \_ pppd sync nodetach noaccomp nobsdcomp nodeflate nopcomp novj novjccomp file /tmp/ppp/optio
      197 
    ?        Ss     0:00 watchdog
      199 
    ?        Ss     0:00  \_ ntp
      208 
    ?        Ss     0:00 pppd file /usr/local/etc/ppp/is15-options.pptpd
      467 
    ?        S      0:00  \_ sh -/usr/sbin/pptp vpn.firma.ru --nolaunchpppd
      468 
    ?        S      0:30      \_ pptpGRE-to-PPP gateway on /dev/ptmx    
      283 
    ?        S      0:28 upnp --L br0 -W ppp0
      325 
    ?        S      0:00 [kjournald]
      
    365 ?        Ss     0:01 syslog-ng
      377 
    ?        Ss     0:00 nmbd -D
      386 
    ?        Ss     0:00 cron
      404 
    ?        Ss     0:00 xinetd
    17640 
    ?        Ss     0:01  \_ dropbear --i
    17641 pts
    /1    Ss+    0:00      \_ screen ---RR
      416 
    ?        S      0:00 busybox_httpd -/opt/etc/httpd.conf -p 880 -/opt/share/www
      430 
    ?        S      0:00 udpxy -m vlan1 -p 850 --21 -B 2048
      462 
    ?        S      4:12 [dnsmasq]
      
    472 ?        S      0:00 pptpcall manager for 12.14.16.18
      594 
    ?        Ss     0:04 SCREEN ---RR
      595 pts
    /2    Ss     0:00  \-bash
    17751 pts
    /2    R+     0:00      \_ ps axf 
    Вот crontab:
    PHP Code:
    */* * * * djet run-parts /opt/etc/cron/cron.5mins
    */15 * * * * djet /opt/etc/init.d/rc.unslung start cron
    01 
    * * * * djet run-parts /opt/etc/cron/cron.hourly
    06 
    */12 * * * djet run-parts /opt/etc/cron/cron.12h
    #06 */12 * * * djet /opt/etc/cron/cron.12h/rsnapshot_hourly.sh
    30 5 * * * djet run-parts /opt/etc/cron/cron.daily
    22 6 
    * * 0 djet run-parts /opt/etc/cron/cron.weekly
    42 6 1 
    * * djet run-parts /opt/etc/cron/cron.monthly

    #*/30 * * * * djet nice /opt/sbin/transmission_watchdog 
    В логах за 5 минут до зависания ничего необычного:

    Code:
    [routah:~] grep 'Dec 16 00:4[0-5]' /opt/var/log/*
    
    /opt/var/log/cron.log:Dec 16 00:40:01 cron.info cron[9347]: (djet) CMD (run-parts /opt/etc/cron/cron.5mins)
    /opt/var/log/cron.log:Dec 16 00:40:01 cron.info cron[9348]: (djet) CMD (if [ -x /opt/bin/vnstat ] && [ `ls /opt/var/lib/vnstat/ | wc -l` -ge 1 ]; then /opt/bin/vnstat -u; fi)
    /opt/var/log/debug.log:Dec 16 00:40:41 local0.debug udhcpc[192]: Sending renew...
    /opt/var/log/debug.log:Dec 16 00:41:55 local0.debug udhcpc[192]: Sending renew...
    Есть какие-нибудь догадки?
    Last edited by djet; 16-12-2008 at 19:45.

  4. #4
    Неделю спустя роутер снова повесился..

    PHP Code:
    [routah:rootp
      PID TTY      STAT   TIME COMMAND
        1 
    ?        S      0:01 /sbin/init
        2 
    ?        S      0:00 [keventd]
        
    ?        RN   1006:24 [ksoftirqd_CPU0]
        
    ?        S      0:18 [kswapd]
        
    ?        S      0:00 [bdflush]
        
    ?        S      0:00 [kupdated]
        
    ?        S      0:05 [mtdblockd]
       
    64 ?        S      0:01 telnetd
     8468 pts
    /2    Ss     0:00  \-sh
     8476 pts
    /2    S+     0:00  |   \_ bash
     8480 pts
    /1    Ss     0:00  \-sh
     8486 pts
    /1    S      0:00      \_ bash
     8498 pts
    /1    R+     0:00          \_ ps axf
       81 
    ?        Ss     0:02 nas /tmp/nas.lan.conf /tmp/nas.lan.pid lan
       84 
    ?        S      0:00 [khubd]
      
    104 ?        S      0:51 [usb-storage-0]
      
    105 ?        S      0:00 [scsi_eh_0]
      
    192 ?        S      0:00 udhcpc -i vlan1 -/var/run/udhcpc0.pid -/tmp/udhcp
      194 
    ?        S     38:07 l2tpd
      200 
    ?        S      0:39  \_ pppd sync nodetach noaccomp nobsdcomp nodeflate n
      325 
    ?        S      0:02 [kjournald]
    18118 ?        S     21:18 [dnsmasq]

    [
    routah:rootuptime 
     00
    :47:51 up 6 days23:58,  0 users,  load average0.260.560.97 

  5. #5

    Зависания с Корбиной

    Недавно (месяца 2 назад) перешел на Корбину. Со старым провайдером роутер работал без нарекантй (static IP).

    Сейчас настроен инет через L2TP, последняя прошивка от Олега. Все исправно работает, проблем с загрузкой проца роутера и низкой скоростью нет (конечно когда у Корбины канал не проседает ).

    Но дело вот в чем: иногда, скажем раз в неделю, Корбина что-то шаманит и отваливается сеть, при этом роутер часто зависает (т.е. в момент пропадания сети от корбины перестает отвечать на пинги изнутри до перезагрузки по питанию). После перезагрузки убеждаюсь, что сети нет, в логе - "lease is lost" и не получает IP по DHCP. Эти явления обычно недолговременные и происходят скорее всего из-за тех. работ, в общем-то не напрягает.

    Напрягает зависание и необходимость перезагрузки роутера в половине таких случаев. Иногда после перезагрузки все сразу же нормализуется, однако в логе (сейвится на флешку) наблюдается запись "lease is lost" перед зависанием, т.е. оно было непроизвольно.

    Никто не сталкивался с подобным поведение девайса?

  6. #6
    Quote Originally Posted by SancheSZ View Post
    Никто не сталкивался с подобным поведение девайса?
    Один или два раза такое было... в итоге отваливался dhtp сервер на роутере.
    Как вариант думал писать скрипт с запуском 15 минут, к-й в логах ищет такую строчку, если находит то делает ребут.
    Но не пришлось, или у Корбины стало меньше проблем или помогает то, что роутер перегружается автоматически ночью.

  7. #7
    Лично у меня L2TP приводит к частым дисконектам. При этом если указывать сервер vpn.corbina.net то дисконектов наблюдалось меньше чем на tp.corbina.net. А вообще вернулся просто на PPTP с сервером vpn.corbina.net и пока все нормально.

  8. #8
    Quote Originally Posted by SancheSZ View Post
    Никто не сталкивался с подобным поведение девайса?
    Есть такое дело.
    WL-500W + Oleg + L2TP
    Если коннект держится ~6-7 дней, рутер виснет намертво.
    http://wl500g.info/showthread.php?t=17754

    Для начала - настроил автоперезагрузку раз в 6 дней.
    http://wl500g.info/showpost.php?p=126097&postcount=5
    Посмотрю, возможно сделаю для гарантии раз в 5 дней или попробую заюзать прошивку DD-WRT v24sp1
    Last edited by Dusha; 08-01-2009 at 12:53.

  9. #9
    Quote Originally Posted by Dusha View Post
    попробую заюзать прошивку DD-WRT v24sp1
    Попробовал....
    Вообщем на DD-WRT поднять ее ни с PPTP ни с L2TP не удалось
    Бестолковая она и много чего не умеет (например динамические маршруты в режиме гейтвэй)

    Вернулся на Олега и настроил ребут раз в 5 дней.

  10. #10

    Тормозит веб-морда

    С недавних пор стала жутко тормозить веб морда на маршрутизаторе ASUS WL-500gp V2
    Настроек никаких уже давно не менял. Пробывал с разных компов, так что кабель ни причем.
    Больше всего тормозит на IE8. Страничка может грузиться секунд 5, раньше меньше 1 секунды было. Еще иногда вылетает ошибка подключения. Что-то вроде 404. На Опере и на 7 Эксплорере получше со скоростью загрузки, но ошибки подключения тоже постоянно. Как бороться? МТУ везде выставлено по умолчанию.

  11. #11
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    Quote Originally Posted by Olsen View Post
    С недавних пор стала жутко тормозить веб морда на маршрутизаторе ASUS WL-500gp V2
    Настроек никаких уже давно не менял. Пробывал с разных компов, так что кабель ни причем.
    Больше всего тормозит на IE8. Страничка может грузиться секунд 5, раньше меньше 1 секунды было. Еще иногда вылетает ошибка подключения. Что-то вроде 404. На Опере и на 7 Эксплорере получше со скоростью загрузки, но ошибки подключения тоже постоянно. Как бороться? МТУ везде выставлено по умолчанию.
    Ребутить пробовали?
    Посмотрите загрузку ресурсов роутера командой top например в телнете.

  12. #12
    Виноват IE8.
    Тем кто активно использует веб-морду роутера ставить не советую. Пользоваться будет жутко не удобно. Вернул IE7

  13. #13
    Была такая же проблема, как раз из-за того, что долго ничего не настраивал.
    Сделай:
    ipkg update
    ipkg upgrade
    Перегрузись и все пройдет.

  14. #14
    А что делают эти команды?

  15. #15
    Join Date
    Mar 2009
    Location
    Default City
    Posts
    2,695
    Blog Entries
    4
    Quote Originally Posted by Olsen View Post
    Виноват IE8.
    Тем кто активно использует веб-морду роутера ставить не советую. Пользоваться будет жутко не удобно. Вернул IE7
    А зачем ей активно пользоваться? там только десяток настроек, остальное в командной строке, про IE, стоит 8, разницы с 7 не заметил как и следовало ожидать (для особых фанатов есть режим отключения фенечек IE8)) , торнозит только если загрузка CPU роутера стабильно выше 85%, ну тут он прав, его дело пакеты пихать, а не картинки рисовать )))

Page 1 of 6 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •