Results 1 to 7 of 7

Thread: 1TB Sata HDD not being initialized

  1. #1

    Question [solved] 1TB Sata HDD not being initialized

    Hello there,

    I'm using an SATA to IDE adaptor, which is 100% working with a 1tb western digital HDD, when connected to my pc.

    Whenever I plug my 1tb drive into my router with the adaptor, the IDE led is not flashing at the powerup. I tried to connect the IDE cable the wrong way, which caused the led to flash constantly, so the adaptor appearently does it's job.

    The only thing I noticed and I think could be the problem, is that the hdd takes about 3 seconds until it's spinning up.

    Could it be that this takes too long?
    Last edited by ganx; 23-07-2009 at 14:09.

  2. #2
    Join Date
    Apr 2005
    Vienna, Austria
    I am using such an Adapter on an older Compaq, and I had to set a BIOS delay of 15 seconds, but that still does not work 100% of the time, especially when doing a reboot.

  3. #3
    Yop, I temporary fixed this through connecting a cable from my pc on the hdd, so it was up before the router. When the HDD finished spinning up, I turned it on and flashed it.

    Then, I was able to turn it off with the power button, change the power source to the router's own power cable and let it boot from HDD again.

    The only damn thing is, that when I plug the router's power cable off the power source, I have to repeat that cablechange-procedure, else it doesn't detect the HDD again and ends up hanging with no led flashing but wan or 1,2,3,4 (if connected).

    I'm gonna test if it boots tomorrow morning, when it was turned off all night, but connected to the power source all the time.

    I can't really explain that, but I can work with it for now.. ^^

    I'll probably test it with another sata tb-hdd some other time.

  4. #4
    Oh man.. Just came back, had the router turned off for a few hours.

    Turned it on, IDE light constantly flashing, it didn't boot again.

    I just hope it's not the adaptor, I can't afford 20 adaptors until I get one that's working. Testing with another HDD tomorrow.

    I'll keep this updated, just in case anyone's interested. ^^

  5. #5


    Yay, I finally solved this issue.

    Bought a new Sata-HDD yesterday (Samsung EcoGreen F2, 1TB) and installed it into the router.

    Everything fine, disk spins up early enough to be recognised by the router.

    At the time, it already took it's place besides my Thomson Modem again, being filled up with my before backup'ed photos, videos and music.

    Ah just for Info, this is what I used, 100% working together and fitting nice into the router (cutted some of the aluminium shell below the hdd off to fit in ): --> Sata to IDE converter, about 20€ at a shop near my home> Samsung EcoGreen F2 1TB (it's so quiet, I had to look after the router the first few times)

    Thanks wl500g forum!

  6. #6


    Glad you got it working. Thanks for the details of the working parts.

    Do you know if the disc still spins down after a period of inactivity?


  7. #7
    Hi, yep - it still does. Could disable it, but I think it's better for my power bill ^^
    Last edited by ganx; 28-07-2010 at 09:56.

Similar Threads

  1. IDE Platte mit SATA Festplaten-Konvert anschliessen
    By spankingherr in forum German Discussion - Deutsch (DE)
    Replies: 0
    Last Post: 24-04-2009, 18:11
  2. Dbox (NFS) findet die am Router angeschlossene HDD nicht
    By nostradamoss in forum German Discussion - Deutsch (DE)
    Replies: 15
    Last Post: 07-04-2008, 19:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts