Results 1 to 6 of 6

Thread: My custom firmware does not work

  1. #1

    My custom firmware does not work

    I am trying to customize some scripts in the filesystem but my new modified firmware always fails.

    I tried to modify the following firmware files:
    wg0106503_WL500g_en.trx
    wl500g-1.6.5.3-5.trx

    Using two methods:
    - Manual. dd if=.... (as described by Oleg)
    - auto. RCR's wltools (wlextract, uncram,mktrx)

    I've got following errors when mounting cramfs or using uncram tool:
    several "cp: cannot create hard link 'build/ramfs/var/state/ppptp' to directory 'build/dev' (filename changes)

    After reflashing AP it boot and reboot for ever. I can ping AP 2 o 3 times before it reboots again.

    I have also tested doing:
    wlextract wl-500g-1.6.5.3-5-trx
    uncram
    mktrx

    I got the same thing.

    Bootloader version is: 2.2
    Hardware version is: 1.0

    did I forgot to do something ? could be my hardware ?

    thanks in advance,
    uidas

  2. #2
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Use firmware restoration tool to bring you AP back to live.

    As for your problems. Are you use linux? If so, which distro?
    Also, how you're copying files from the mounted cramfs? if you use cp, which args you're passing? Also, what
    alias cp
    showing?

  3. #3
    I used firmware restoration tool to flash a "good" firmware. Next I tried another "bad" firmware, next restoration again

    I used:
    Fedora Core 1
    Copying files from mounted cramfs using "cp -r /mnt/cramfs build" or cp -dpR /mnt/cramfs build"

    alias cp='cp -i' (interactive)

  4. #4
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Ok, now I see.
    Use this instead
    tar -C /mnt -cpf - cramfs/ | tar -C /path/to/build -xpf -
    Personally, I'm using mc (midnight commander) for performing copy.

  5. #5
    thanks, thanks, thanks

    It works perfect. Now I'm configuring AP in client mode. One script to config client mode and another one to auto-join a specific SSID if not associated.

  6. #6

    Hello!

    I searched this forum and I did not find anywhere RCR's wltools. (on google I did not find these scripts too).
    Could someone post them for me?
    I should try to modify asus wl500gpv2 firmware 3.0.3.6. I should make simple modifications to work with optware packages on external HDD.

Similar Threads

  1. Custom Firmware v1.1.2.7
    By JOCKYW2001 in forum WL-HDD Firmware Releases
    Replies: 59
    Last Post: 11-12-2004, 13:26
  2. New custom firmware
    By Oleg in forum WL-500g Custom Development
    Replies: 7
    Last Post: 13-08-2004, 13:54
  3. Replies: 2
    Last Post: 08-07-2004, 15:59
  4. After Custom Firmware Printer doesn't work
    By Silent3k in forum WL-500g Q&A
    Replies: 3
    Last Post: 01-06-2004, 02:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •