Page 1 of 10 123 ... LastLast
Results 1 to 15 of 137

Thread: Unslung/WL500g packages available for Oleg's firmware

  1. #1
    Join Date
    Apr 2004
    Location
    Adelaide, Australia
    Posts
    88

    Unslung/WL500g packages available for Oleg's firmware

    Oleg's latest custom firmware now has support for downloadable packages. The package format is the same "ipkg" format used in OpenZaurus, OpenWRT, OpenSlug, and other embedded linux projects.

    The NSLU2-Linux project (www.nslu2-linux.org) has a repository of about 280 packages which have been ported to the Linksys NSLU2 device. That repository of package build source files is called the "Unslung" build system, and it lives in the Unslung CVS repository at http://sf.net/projects/nslu.

    We have now modified the Unslung build system to support both the NSLU2 with the "Unslung" firmware, and the WL500g with Oleg's custom firmware. Note that the NSLU2 is an XScale (armeb) device running glibc, whilst the WL500g is a Broadcom (mipsel) device running uclibc, so a number of packages will need further modifications to compile for the WL500g. Also be aware that the startup scripts and configuration files have been designed for the NSLU2, and will probably need modification for the WL500g in many cases.

    The current status is that the following packages compile for the wl500g:

    adns_1.1-1_armeb.ipk appweb_1.2.3-3_armeb.ipk
    automake_1.9.4-2_armeb.ipk bash_2.05b-3_armeb.ipk bc_1.06-1_mipsel.ipk
    bind_9.3.0-1_mipsel.ipk bitchx_1.1-final-1_mipsel.ipk
    busybox_1.00-8_armeb.ipk bzip2_1.0.2-2_armeb.ipk
    ccxstream_1.0.15-1_armeb.ipk classpath_0.13-1_armeb.ipk
    coreutils_5.2.1-4_armeb.ipk ctags_5.5.4-1_mipsel.ipk
    cyrus-sasl_2.1.20-4_armeb.ipk dhcp_3.0.1-1_armeb.ipk
    distcc_2.18.3-1_armeb.ipk dnsmasq_2.15-5_armeb.ipk
    dropbear_0.44test4-1_armeb.ipk ed_0.2-1_armeb.ipk
    expat_1.95.8-1_armeb.ipk ffmpeg_0.4.9-pre1-1_armeb.ipk
    fixesext_2.0.1+cvs20050130-1_mipsel.ipk flac_1.1.2-2_armeb.ipk
    fontconfig_2.2.99-2_mipsel.ipk freetype_2.1.9-1_mipsel.ipk
    ghostscript_8.50-1_armeb.ipk gift-fasttrack_0.8.9-1_armeb.ipk
    gift-gnutella_0.0.10-1_armeb.ipk gift-openft_0.2.1.5-1_armeb.ipk
    gift-opennap_20050212-1_armeb.ipk gift_0.11.8.1-1_mipsel.ipk
    groff_1.19.1-2_armeb.ipk inetutils_1.4.2-4_mipsel.ipk
    iptables_1.2.11-1_armeb.ipk ircd-hybrid_7.0.3-2_armeb.ipk
    joe_3.1-1_armeb.ipk jove_4.16.0.65-1_armeb.ipk lame_3.96.1-1_armeb.ipk
    libcurl_7.12.2-1_armeb.ipk libdvdread_0.9.4-1_armeb.ipk
    libevent_0.9-1_armeb.ipk libgd_2.0.33-2_mipsel.ipk
    libid3tag_0.15.1b-1_mipsel.ipk libjpeg_6b-2_armeb.ipk
    libogg_1.0-1_mipsel.ipk libpng_1.2.8-2_armeb.ipk
    libtool_1.5.10-2_mipsel.ipk libvorbis_1.0-1_mipsel.ipk
    lua_5.0.2-1_mipsel.ipk lynx_2.8.5-2_armeb.ipk lzo_1.08-2_mipsel.ipk
    m4_1.4.1-1_armeb.ipk make_3.80-1_armeb.ipk man-pages_2.01-1_armeb.ipk
    man_1.5p-1_armeb.ipk mc_4.1.35-1_armeb.ipk
    mt-daapd_0.2.1.1-1_armeb.ipk nano_1.2.4-1_armeb.ipk
    ncftp_3.1.8-2_armeb.ipk openvpn_2.0_rc17-1_mipsel.ipk
    patch_2.5.4-2_armeb.ipk pkgconfig_0.15.0-1_mipsel.ipk
    portmap_4-2_armeb.ipk postgresql_8.0.1-2_mipsel.ipk
    proftpd_1.2.10-4_mipsel.ipk python_2.4-1_mipsel.ipk
    recordext_1.13+cvs20050130-1_mipsel.ipk
    renderext_0.8+cvs20050130-1_mipsel.ipk tcpwrappers_7.6-2_armeb.ipk
    torrent_1.0-1_armeb.ipk ttf-bitstream-vera_1.10-1_mipsel.ipk
    vdr-mediamvp_0.1.4-2_armeb.ipk w3cam_0.7.2-1_mipsel.ipk
    xau_0.1.1+cvs20050130-1_mipsel.ipk
    xdmcp_0.1.3+cvs20050130-1_mipsel.ipk xextensions_1.0.2-1_mipsel.ipk
    xproto_6.6.2+cvs20050130-1_mipsel.ipk
    xtrans_0.1+cvs20050130-1_mipsel.ipk

    [Note that I have tested very few of those packages, so even though they compile, they still may not run correctly. Over time we will sort out which is which.]

    If a package listed above has "_mipsel" in the name, then it has been modified to emit an installable ipk correctly targetted for the WL500g. If the package has "_armeb" in the name, it means that it compiles, but still requires a simple (but tedious when there are a lot of them) modification to emit the correct ipk for the WL500g.

    You can find out how to build these packages here: http://www.nslu2-linux.org/wiki/Unsl...ckageToUnslung

    I presume that someone (perhaps Oleg, or one of the other Chupa administrators) will make the "_mipsel" binary packages available somewhere for direct download. Until that time, you can build them yourself following the instructions referenced above. It's a one line ("TARGET=wl500g") change to the top-level Unslung Makefile to retarget it from the NSLU2 to the WL500g and build the packages.

    If someone wants to send me a patch for any or all of the "_armeb" packages above to make them generate the correct ipkg control file, I'll be happy to include that patch in the Unslung CVS repository. All that is involved is updating each package's <foo>.mk file to match the control file generation code in the template.mk file. Simple but tedious.

    Note that I do not intend to (nor do I have the time to) update packages that I don't personally need on my wl500g, but I am happy to accept patches from others and apply them to the Unslung CVS repository. For frequent contributors, we should be able to grant write access directly to the repository (remembering that the repository was originally set up for the NSLU2-Linux project, and that remains the primary target for the packages, so any contributed packages need to take that into account). Oleg already has write access, and I expect that at least a couple of other experienced developers here will end up being contributors with write access to the Unslung package repository too ...

    -- Rod
    Last edited by rwhitby; 29-03-2005 at 15:44.

  2. #2
    Join Date
    Apr 2004
    Location
    Adelaide, Australia
    Posts
    88
    Quote Originally Posted by rwhitby
    I presume that someone (perhaps Oleg, or one of the other Chupa administrators) will make the "_mipsel" binary packages available somewhere for direct download.
    They are now available at:

    http://ipkg.nslu2-linux.org/feeds/unslung/wl500g

    That feed will be updated from the list of packages in the WL500G_PACKAGES variable in the Unslung top-level Makefile.

    Note that I am not offering to personally support these packages in any way - they are provided on an as-is basis. In particular, I probably will not personally be answering any "how do I use this package" questions. If you wish to make changes or contribute new packages, then follow the instructions at:

    http://www.nslu2-linux.org/wiki/Unsl...ckageToUnslung

    My hope is that a number of wl500g package developers will take on the task of porting many of the Unslung packages to the wl500g. There are already two developers (Oleg and Jean-Fabrice) who have CVS write access to the Unslung source repository.

    -- Rod

  3. #3
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Rod, you've done a great job, I will remove my unslung repository shortly as it's outdated now.
    Also, I will update ipkg package, so it would point to the right place and include rc.unslung to it.

  4. #4
    Just a quick note about some big package requesting readline, and readline libs. Is it compiling for wl-500, or does it needs more work?

  5. #5
    Join Date
    Apr 2004
    Location
    Adelaide, Australia
    Posts
    88
    Quote Originally Posted by hugo
    Just a quick note about some big package requesting readline, and readline libs. Is it compiling for wl-500, or does it needs more work?
    Fixed - there were some packages that were built as required for other packages but had not been converted.

    -- Rod

  6. #6
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Several new packages added, including gift plugins, madplay and microperl.
    I've removed unslung directory from my server, so from now use this ipkg.conf line:
    Code:
    src unslung http://ipkg.nslu2-linux.org/feeds/unslung/wl500g

  7. #7
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    I've also updated ipkg package, so it's now pointing to the unslung repository. This new version also adds rc.unslung script to the /opt/etc/init.d/rc.unslung, so if some services depends on it, then just add
    Code:
    [ -x /opt/etc/init.d/rc.unslung ] && /opt/etc/init.d/rc.unslung
    to the end of your post-mount/post-boot script (this depends on the moment then /opt is get mounted).

  8. #8

    Post 2 pkgs

    Hello!

    There are 2 packages i would die for to have Namely OpenVPN 2.0 and a PHP4 enabled webserver :$ Could it be possible to package those too? :$ I'm willing to pay for it!

    Thanks in advance

    Bart

  9. #9
    Join Date
    Apr 2004
    Location
    Netherlands
    Posts
    1,307
    Webserver + PHP4 is allready available on this forum (not as an ipkg package though, just a binary).

  10. #10
    Join Date
    Jul 2004
    Location
    near Lyon @ France
    Posts
    195
    Quote Originally Posted by verwilst
    $ I'm willing to pay for it!
    Sounds interesting... How much ?

    Well, for 2 cents, I can give you the following URL :
    http://www.bobo-rousselin.com/wl/ipkg/

    EDIT : and openvpn seems to build perfectly from unslung
    Last edited by Jean-Fabrice; 04-04-2005 at 12:57.

  11. #11
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Jean-Fabrice, could you please add your thttpd+php package to the unslung? ;-)
    Feel free to send patches or files to me for review.

  12. #12
    Well, i'm looking into setting up my own build env. to compile openvpn 2.0 ( it has to be 2.0 ) on my gentoo.. Ofcourse if you want to make the openvpn2 pkg yourself for a certain amount, just let me know Thanks for the thttpd link

  13. #13
    Can you add as a package open dc hub?

  14. #14
    Join Date
    Apr 2004
    Location
    Adelaide, Australia
    Posts
    88
    Quote Originally Posted by ela002
    Can you add as a package open dc hub?
    Who are you asking?

    The Unslung packages come about by people contributing the packages that they personally need. We have 50+ developers, each of whom only contributed those packages that they personally need (and that weren't there already).

    So you should not expect someone to jump into gear and add a package just because someone asks for it ... that is not the way these things work.

    You might like to picque someone's interest by at least describing what the package is, what it is used for, and why it would be in someone's self-interest to add it.

    Having said that, you might get lucky and someone might just add it out of the goodness of their heart :-)

    -- Rod

  15. #15
    Quote Originally Posted by ela002
    Can you add as a package open dc hub?
    Though you could try that wish list thread...

Page 1 of 10 123 ... LastLast

Similar Threads

  1. Contributors needed for wl500g packages
    By Jean-Fabrice in forum WL-500g Custom Development
    Replies: 33
    Last Post: 13-07-2009, 23:20
  2. oleg's firmware vs openwrt
    By sophana in forum WL-500g Custom Development
    Replies: 5
    Last Post: 15-07-2005, 18:46
  3. Webtools - Configure installed Unslung and other packages
    By Styno in forum WL-500g Custom Development
    Replies: 22
    Last Post: 20-04-2005, 08:46
  4. FTP Connect with Oleg's Firmware?
    By stefan9113 in forum WL-HDD Custom Development
    Replies: 4
    Last Post: 27-02-2005, 01:01

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •