Results 1 to 10 of 10

Thread: IPKG INSTALL ERRORS

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Smile IPKG INSTALL ERRORS

    Hello, i am trying to install things into my router. when i try to run command ipkg install screen i am getting

    "[root@WL700gE /]$ ipkg install screen
    Installing screen (4.0.3-2) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/op...3-2_mipsel.ipk
    wget: missing URL
    Usage: wget [OPTION]... [URL]...

    Try `wget --help' for more options.
    Nothing to be done
    An error ocurred, return value: 22.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 1: `wget -q -P http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/screen_4.0.3-2_mipsel.ipk'
    Failed to download screen. Perhaps you need to run 'ipkg update'?
    WARNING: Unable to remove temporary directory: : No such file or directory
    [root@WL700gE /]$
    "

    --is their any way i can just dowload the package and upload to my router and install myself? thanks

  2. #2

    does anyone know?

    hello, does anyone have a clue to why this is going on?

  3. #3
    Join Date
    Dec 2008
    Location
    Netherlands
    Posts
    74
    Can you check if there's a default route?
    Happened to me too.

    In other words, if you enter the route command, check that there is a line that reads something like:
    Code:
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         gw_ip_address   0.0.0.0         UG    0      0      0   br0

  4. #4

    Smile going to check

    I will check sometimes tomorrow about the route . if it is not present what should i do? were do i add that line if it does not exist ? because i formatted and flashed the router twice with no luck. but i will check that asap! thanks for getting back to me...seems no one was responding.

  5. #5
    Join Date
    Dec 2008
    Location
    Netherlands
    Posts
    74
    If the default route is missing, you need to add it:
    Code:
    route add default gw <gateway's IP address>
    when things are working OK, save your changes:
    Code:
    flashfs save && flashfs commit && flashfs enable && reboot
    Last edited by EdP; 06-07-2009 at 19:25.

  6. #6

    my route

    hey, this is what my route states

    "default 76-206-252-1.li 0.0.0.0 UG 0 0 0 eth0 " thanks.

Similar Threads

  1. Full server config: Samba ftp http xmail mysql forum motor
    By KisVuK in forum WL-500gP Tutorials
    Replies: 14
    Last Post: 15-12-2008, 22:34
  2. Cannot install IPKG system
    By brianyu in forum WL-HDD Q&A
    Replies: 2
    Last Post: 28-08-2007, 07:41

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •