Results 1 to 10 of 10

Thread: Установка Perl на роутер Asus

  1. #1

    Question Установка Perl на роутер Asus

    Вот нашел прогу- http://caspian.dotconf.net/menu/Software/SendEmail/

    хотелось бы поставить Perl в этой связи, а как?

    Может кто ставил?

  2. #2

    Perl

    Здравствуйте. Подскажите, как сабж запихнуть на железяку?
    Собрать - нет make, где его достать?

  3. #3
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    ipkg install perl

  4. #4
    уже давно сделал, как такого perl нет. есть perl5.8.8:

    [admin@router bin]$ ls -la | grep perl
    -rwxr-xr-x 1 admin root 24106 Sep 4 2008 find2perl
    -rwxr-xr-x 1 admin root 5077452 Sep 4 2008 perl5.8.8
    -rwxr-xr-x 1 admin root 37273 Sep 4 2008 perlbug
    -rwxr-xr-x 1 admin root 17953 Sep 4 2008 perlcc
    -rwxr-xr-x 1 admin root 224 Sep 4 2008 perldoc
    -rwxr-xr-x 1 admin root 11931 Sep 4 2008 perlivp
    [admin@router bin]$
    [admin@router bin]$ perl5.8.8
    -sh: perl5.8.8: not found
    [admin@router bin]$
    Last edited by gutzeit; 27-10-2008 at 12:26.

  5. #5
    Странно, у меня perl есть - это симлинк на perl5.8.8
    у тебя /opt/bin в переменной PATH прописано?

  6. #6
    Нет, но я запускал прямо из /opt/bin

    Ошибка, по умолчанию прописано:

    PATH='/opt/sbin:/opt/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'

    Что можно сделать, если это так?
    Last edited by Omega; 12-10-2014 at 20:27. Reason: fixed

  7. #7
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    проблема не имеет отношения к путям и к перлу. Похоже на несовместимость библиотек, которая была типична, например, при переходе от старого репозитория (unslung) к новому (optware).

  8. #8
    А подскажите пожалуйста как пользоваться perlcc ?

    Мне он выдаёт вот что:
    Code:
    perlcc -o kaka.cgi kaka.pl
    /opt/bin/perlcc: kaka.pl did not compile, which can't happen:
    Can't locate loadable object for module B::C in @INC (@INC contains: /opt/lib/perl5/5.8.8/mipsel-linux /opt/lib/perl5/5.8.8/mipsel-linux /opt/lib/perl5/5.8.8 /opt/lib/perl5/site_perl/5.8.8/mipsel-linux /opt/lib/perl5/site_perl/5.8.8/mipsel-linux /opt/lib/perl5/site_perl/5.8.8 /opt/lib/perl5/site_perl/5.8.8/mipsel-linux /opt/lib/perl5/site_perl/5.8.8 /opt/lib/perl5/site_perl . /opt/lib/perl5/5.8.8/mipsel-linux /opt/lib/perl5/5.8.8 /opt/lib/perl5/site_perl/5.8.8/mipsel-linux /opt/lib/perl5/site_perl/5.8.8 /opt/lib/perl5/site_perl .) at (eval 1) line 18
     Compilation failed in require at (eval 1) line 18.
     BEGIN failed--compilation aborted at (eval 1) line 18.
     BEGIN failed--compilation aborted.
    Т.е. не хватает ему модуля B::C - а где его взять для wl500g ?

    тема актуальна.

    YESSSSS!!!!! Разобрался!!! "сильное колдунство"

    Шоб не мучаться - вот скрипт compile.pl:
    Code:
    #!/opt/bin/perl
    
    if(@ARGV != 2)
    {
        print "Usage: ./compile.pl source.pl compiled.cgi";
        die;
    }
    
    $src = @ARGV[0];
    $dst = @ARGV[1];
    
    `echo '#!/opt/bin/perl' >> $dst`;
    `echo 'use ByteLoader;' >> $dst`;
    `perl -MO=Bytecode $src >> $dst`;
    `chmod +x $dst`;
    Last edited by Omega; 12-10-2014 at 20:24. Reason: fixed

  9. #9

    Unhappy Perl - Can't locate CGI/Session.pm - в каком .ipk он?

    Всем привет!

    Написал простой скрипт, использующий CGI::Session

    При выполнении ругается на строчку:
    use CGI::Session; # 4-я строка (см. лог ошибки)

    вот так:
    Code:
    Can't locate CGI/Session.pm in @INC (@INC contains: /opt/lib/perl5/5.8.8/mipsel-linux /opt/lib/perl5/5.8.8 /opt/lib/perl5/site_perl/5.8.8/mipsel-linux /opt/lib/perl5/site_perl/5.8.8 /opt/lib/perl5/site_perl .) at ./auth.pl line 4.
    BEGIN failed--compilation aborted at ./auth.pl line 4.
    В каком .ipk для перла сей модуль?

  10. #10
    Quote Originally Posted by sonice View Post
    Вот нашел прогу- http://caspian.dotconf.net/menu/Software/SendEmail/

    хотелось бы поставить Perl в этой связи, а как?

    Может кто ставил?
    Не получается запустить скрипт. При запуске без каких либо параметров должна выводиться справка, вместо этого у меня выдает:

    # ./sendEmail
    Illegal instruction

    Подскажите что за ошибка, в какую сторону смотреть?

    По команде:
    ipkg list_installed |grep perl

    выдает что установлены следующие пакеты:

    microperl - 5.8.8-11 - Microperl.
    perl - 5.8.8-23 - Practical Extraction and Report Language.
    perl-io-socket-ssl - 0.999-1 - IO-Socket-SSL - Nearly transparent SSL encapsulation for IO::Socket::INET
    perl-net-ssleay - 1.30-1 - Net_SSLeay - Perl extension for using OpenSSL

    Возможно каких то пакетов у меня не хватает?

Similar Threads

  1. Установка интернет-радио на роутер
    By Mairone in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 132
    Last Post: 31-05-2016, 03:56
  2. Установка Tor и I2P на роутер Asus
    By MIB in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 55
    Last Post: 10-02-2015, 09:25
  3. Установка Debian на роутер Asus WL-500gP/RT-N10U/N16 (MIPS)
    By Oleg in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 156
    Last Post: 02-10-2014, 13:17
  4. Установка VLC на роутер ?
    By jek8 in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 88
    Last Post: 23-05-2013, 10:18
  5. Установка RRDTool и CRON на роутер
    By dizzy128 in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 173
    Last Post: 16-04-2012, 18:35

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •