Page 4 of 54 FirstFirst ... 2345614 ... LastLast
Results 46 to 60 of 797

Thread: Подключение USB модема 3G/CDMA к роутеру Asus

  1. #46
    Quote Originally Posted by walkera View Post
    Народ подскажите..

    Прошивка олега дает возможность пользоваться usb 3g modemom ?

    сам пользуюсь чешской.. в ней работает..
    но прошивка не самая лучшая...
    Да, у меня работала, ну разве что есть нюансы.

    Единственно что на олеговой прошивке пришлось убрать - maxSize=4096, на Олеговой прошивке (WL500gp-1.9.2.7-10.7.trx) выдает ошибку (insmod: invalid parameter maxsize).
    Нет резервного канала, но в принципе он мне особе не нужен. Достаточно было просто включить модем и перегрузить роутер. Так он при загрузке его не находил и соответственно ничего не подымал.

    Рабочий скрипт для LIFE (Украина), модема ZTE MF620

    И кстати тем на форуме завались, зачем еще одна?

  2. #47
    Quote Originally Posted by AndreyPopov View Post
    ну собственно чешская сделана на основе прошивки Олега, в нее добавлены нужные модули.
    Там, если не ошибаюсь основано на довольно старой Олеговой прошивки.

  3. #48
    Join Date
    Feb 2008
    Location
    Dniepropetrovsk, Ukraine
    Posts
    1,526

    Exclamation

    Quote Originally Posted by leshiy_odessa View Post
    Там, если не ошибаюсь основано на довольно старой Олеговой прошивки.
    ну если вы считатете, что 1.9.2.7-10 это старая, а в новой 1.9.2.7-10а исправлены некоторые ошибки, то мне нечего более добавить.

  4. #49

    iPhone 3G как модем для WL500g

    Доброго времени суток.
    Поскольку тарифы некоторых операторов предлагают безлимитный Интернет для iPhone, а начиная с прошивки 3.0 телефон умеет раздавать Интернет по кабелю, предлагаю специалистам по прошивке написать скрипт для выхода в Интернет через iPhone.
    К компьютеру iPhone подсоединяется сразу же (если установлен iTunes) и раздает Интернет под видом сетевого подключения.

  5. #50
    зачем париться поставь mywi на iphone или pdanet и раздавай по wifi с iphone инет только боюсь скорость покачто не позволяет через точку доступа раздавать я пробовал такую систему работает прекрасно вот скорость только для такой системы смешная

  6. #51

    Распознование модема huawei через раз.

    Все отлично работает.... НО

    иногда бывает что модем не детектится с первого раза..
    приходиться делать повторный ребут, после чего все работает нормально..

    подозреваю что это связано с тем что модем еще распознается как флэшка...

    в этом ли проблема?

    если да то подскажите как это отключить...

    если надо приведу логи какие скажите...
    помогите разобраться..
    спасибо.

  7. #52

    Проблема с реконнектом на usb модеме

    Использую dlink dir-320 в связке со своим модемом anydata adu e100a.
    Хотя думаю модель здесь не важна.
    Настраивал методом копипасты настроек с текущей линукс-тачки и исправлением их под реалии роутера.
    Роутер отлично справляется со своей работой, я наладил автопересоединение, учёт статистики и тд, но вот одна лага сводит все усилия "на нет": при искусственном дисконнекте (ctrl+c, если руками вызываю pppd call; дисконнект со стороны оператора (каждые 480 минут+ в час ночи и в 8 утра)) в "чате" между модемом и chat происходит нечто очень странное (как я понимаю модем шлёт одно и тоже по несколько раз chat'у, пока последний не умрёт по таймауту). Выглядит это так:

    [admin@(none) bwww]$ cat /tmp/chat.log
    ~M-^?}#M-@!}!}!} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"}&M-|~~M-^?}#M-@!}!}"} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"Ln~~M-^?}#M-@!}!}#} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"M-^EM-g~~M-^?}#M-@!}!}$} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"M-IB~~M-^?}#M-@!}!}%} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"} M-K~~M-^?}#M-@!}!}&} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"JY~~M-^?}#M-@!}!}'} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"M-^CM-P~~M-^?}#M-@!}!}(} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"M-C};~~M-^?}#M-@!}!})} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"}*M-^R~~M-^?}#M-@!}!}*} }8}"}&} } } } }#}$M-@#}%}&M-2M-p8H}'}"}(}"@} ~SIGINT

    (ну SIGINT - понятно, я сам прервал коннект по ctrl+c).
    Проэмулировать достаточно просто: делаем pppd call cdma, ждём когда соеденится, жмём ctrl+c и вуаля, новый коннект будет безуспешным (см выше что будет).

    Думал, что проблема в модеме, но подцепил его к своей тачке, сделал тоже самое и...всё отлично. Момент лишь в том что на своей тачке я вызываю коннект так:

    pppd /dev/ttyUSB0 115200 file /etc/ppp/peers/cdma user mobile

    а в роутере прописано устройство /dev/usb/tts/0 . /dev/ttyUSB0 нет в системе, но dmesg при добавлении устройства говорит, что добавляется как ttyUSB0 так и /dev/usb/tts/0 для devfs.


    Собственно мои теущие действия для восстановления коннекта: передёрнуть кабель (из модема/в модем ИЛИ аналогично в роутере) или перезагрузить модем. Естественно такое положение дел мне не очень нравится, пробовал после каждого дисконнекта делать rmmod usbserial и insmod, менял задержки и тд - безрезультатно.

    Повторюсь, что проблема проявляется не всегда, например если я сам перезагружу модем, разорву соединение через некоторое время работы, то коннект мой псевдо-демон нормально восстановит, а вот если мы имеем дело с искусственными дисконнектами или разрывами сразу после коннекта, то тут проблема встаёт в полный рост.

    Как я понимаю, проблема таки где-то в прошивке роутера и сам я понять где не могу, как вариант: может есть какой-то метод "проэмулировать" отключение кабеля (мой метод rmmod+insmod провалился)...?


    Ниже мои настройки коннекта и псевдо-демон...

    [admin@(none) ppp]$ cat peers/cdma
    debug
    /dev/usb/tts/0
    115200
    crtscts
    noipdefault
    defaultroute
    ipcp-accept-local
    lcp-echo-interval 60
    lcp-echo-failure 5
    usepeerdns
    nopcomp
    noaccomp
    nodetach
    novj
    novjccomp
    nobsdcomp
    noccp
    user "mobile"
    password "internet"
    connect "/usr/sbin/chat -s -S -V -t 60 -f /tmp/ppp/cdma.chat 2>/tmp/chat.log"
    [admin@(none) ppp]$ cat cdma.chat
    '' 'AT'
    'OK' 'ATI'
    'OK' 'ATE0V1'
    'OK' 'AT'
    'OK' 'ATDT#777'
    'CONNECT' 'OK'

    [admin@(none) ppp]$ cat cdma_connect_daemon.sh
    #!/bin/sh
    while [ 1 ];do
    echo "test"
    if [ `ps|grep pppd|grep -v 'grep'| wc -l`=0 ]; then
    #echo "connect"
    rmmod usbserial
    sleep 3
    insmod usbserial vendor=0x16d5 product=0x6501
    sleep 4
    echo "`date` Try to connect" >> /tmp/ppp/ppp-stat
    pppd call cdma
    echo "`date` Connect closed" >> /tmp/ppp/ppp-stat

    fi;
    #echo "sleep"
    sleep 20;
    done


    [admin@(none) ppp]$ cat ip-down
    #!/bin/sh


    echo `date` / $CONNECT_TIME / $BYTES_SENT / $BYTES_RCVD >> /tmp/ppp/ppp-stat
    flashfs save && flashfs commit && flashfs enable

    /sbin/rc
    Last edited by rap-kasta; 05-09-2009 at 12:14.

  8. #53
    Я вот думаю...а если перезагружать роутер? ведь в данном случаем между halt и загрузкой будет некоторый период времени, когда кабель будет "отключен"...опять же 3 раза на дню перезагружать роутер...ну как-то не по-божески

  9. #54
    Народ ну что никто не сталкивался с таким?

  10. #55

    Есть решение

    Помогли на лоре, полностью цитирую сообщение оттуда:

    у меня в dd-wrt на DIR-320 выгрузка модуля ehci-hcd отключает питание usb порта - может это поможет. ehci-hcd.o используется не родной от dd-wrt, а собранный из исходников прошивки "олега", usb-ohci и usb-uhci у меня не загружены.
    inoremap (*) (05.09.2009 19:04:39)
    Итоговый скрипт реконнекта теперь выглядит так, надеюсь кому нибудь пригодится.

    Code:
    [admin@(none) root]$ cat /tmp/ppp/cdma_connect_daemon.sh
    #!/bin/sh
    rmmod usbserial
    insmod usbserial vendor=0x16d5 product=0x6501
    
    while  [ 1 ];do
            echo "test"
            if [ `ps|grep pppd|grep -v 'grep'| wc -l`=0 ]; then
                    #echo "connect"
                    #rmmod usbserial
                    #insmod usbserial vendor=0x16d5 product=0x6501
                    #sleep 4
                    rmmod ehci-hcd
                    sleep 1
                    insmod ehci-hcd
                    sleep 2
                    echo "`date` Try to connect" >> /tmp/ppp/ppp-stat
                    pppd call cdma
                    echo "`date` Connect closed" >> /tmp/ppp/ppp-stat
    
            fi;
            #echo "sleep"
            sleep 10;
    done

  11. #56
    приобрел тоже такой роутер
    скажите, роутеру ему до лампочки какой модем, CDMA, GSM или WCDMA (UMTS)?

  12. #57
    на 1.9.2.7-d через веб интерфейс 3G модем не запустить? только танцами по ссш? А на чешской вроде можно..
    ASUS RT-N16 (1.9.2.7-rtn) + multi-wan (2x PPPoE, было на WL-500W)
    Нужно делать так как нужно, а как не нужно - делать не нужно.

  13. #58

    USB-модем Huawei E1550 + WL5хх

    Есть ли готовое решение на роуторах от асуса +данный модем от мегафона со скоростью 3G ?
    Или с другими роутерами

  14. #59
    Вечер добрый. Помогите прикрутить HUAWEI E156G к 320-у. Для начала пытаюсь определить vend/prod, а в логе:
    hub.c: new USB device 00:03.0-1, assigned address 9
    Vendor: HUAWEI Model: Mass Storage Rev: 2.31
    Type: CD-ROM ANSI SCSI revision: 02
    USB device connected to the SCSI subsystem
    usb.c: USB disconnect on device 00:03.0-1 address 9
    USB device disconnected from the SCSI subsystem
    И как быть с кодом откл. CD?

  15. #60

    Huawei E1550+DIR 320

    Сорри за тему, но сил больше нет..
    Прошил модем прошивкой 1,9,2,7,d 627 и сейчас никак не могу завести мопед Huawei e1550 от мегафона Все делал как в инструкции, но вот только не могу перевести его в режим модем онли..я не могу общаться с гипертерминалом..

    Делал вот так
    nvram set wan_usb_standard=1
    nvram set wan_usb_username=
    nvram set wan_usb_passwd=
    nvram set wan_usb_port=0
    nvram set wan_usb_speed=921600
    nvram set wan_usb_apn=internet
    nvram set wan_usb_dialnumber=*99#
    nvram set wan_usb_vend=0x12d1
    nvram set wan_usb_prod=0x1446
    nvram set wan_usb_mtu=1492
    nvram set wan_usb_mru=1492
    nvram commit

    echo "#!/bin/sh" > /usr/local/sbin/post-boot
    echo "modem" >> /usr/local/sbin/post-boot
    chmod +x /usr/local/sbin/post-boot
    echo "/usr/local/sbin/post-boot" > /usr/local/.files
    flashfs save && flashfs commit && flashfs enable
    reboot

    Результата 0! Лампочка мигает, а в инет не входит! Вот некорые команды, и ответы к ним:
    (none) login: admin
    Password:
    [admin@(none) root]$ modem
    Error: Could not find file /etc/usb_modeswitch.conf

    at
    [admin@(none) root]$ at
    -sh: at: not found
    [admin@(none) root]$ pppd: In file /tmp/ppp/peers/dialup: unrecognized option '/
    dev/usb/tts/0'

    Подскажите, что делаю не так? Может ли быть из за того, что в мопеде не выключена CD-rom функция?
    Я уже третий день не сплю и голова пухнет от всего этого..Просто нужно завести мопед, что бы инет был через дирку и все! С yota проблем нет. А вот с мегафоном траблы.
    Прошу помощи, кто знает как победить..
    За ранее спасибо

Page 4 of 54 FirstFirst ... 2345614 ... LastLast

Similar Threads

  1. Подключение USB TV-тюнера к роутеру Asus (DVB-T)
    By Andrey Solovyov in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 33
    Last Post: 29-05-2017, 01:48
  2. Подключение UVC веб-камер к роутеру Asus
    By Сантехник in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 452
    Last Post: 10-07-2016, 10:47
  3. Подключение IP web-камеры к роутеру Asus
    By Asmadei in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 133
    Last Post: 04-07-2014, 16:18
  4. Подключение сканера и МФУ к роутеру Asus
    By Scasius in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 203
    Last Post: 04-06-2013, 10:43
  5. Подключение SAN NetGear SC101 к роутеру
    By Cd_spb in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 12
    Last Post: 28-03-2009, 11:10

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •