Page 4 of 8 FirstFirst ... 23456 ... LastLast
Results 46 to 60 of 119

Thread: Настройка NAT на WL-500gP или проблема с почтой (smtp)

  1. #46

    Exclamation Отправка почты!

    Привет всем!
    Похожие проблемы обсуждались, НО:
    есть The Bat, в нём несколько ящиков - почта отправляется с любых ящиков кроме @mail.ru...
    ответа не дожидается
    Это наблюдается в любых почтовых программах..не только в THE BAT!
    Даже с list.ru и с bk.ru уходит почта.

    Фаерволл ПОЛНОСТЮ отрубался - та же хрень.

    Манипуляции с mtu и размерами писем не катят.

    Роутер wl500w. При переключении на роутер d-link di624 или при подключении прямиком письма с @mail.ru уходят нормально.

    Делаем выводы:
    дело не в mail.ru
    дело не в урезании smtp провайдером
    дело не в фаерволе
    дело не в MTU

    а дело по всей видимости именно в роутере!

    Но я бы ещё понял если б все ящики не работали, но когда не отсылаются только с @mail.ru это колдовство какое-то!

    telnet smtp.mail.ru 25 - соединяет
    ping smtp.mail.ru - пингует ок
    Last edited by Solodoff; 03-03-2009 at 15:58.

  2. #47
    у меня вобще с @mail.ru только не уходят, с остальных норм..даже с list.ru!
    без роутера всё ок

  3. #48
    Думал что решил траблу...
    пробросил порт 25 в роутере и всё заработало, но спустя какое-то время опять перестало...

    Хотя нелогично это всё...я потому и не пробрасывал его раньше что все остальные ящики отсылались...
    Last edited by Solodoff; 03-03-2009 at 17:44.

  4. #49
    Для меня так и осталось загадкой тот факт что
    с одних ящиков уходила почта, а с других нет.

    Проблему решил, вот мои соображения:

    Олег в каких-то ветках этого форума упоминал о том, что происходит некий обмен между роутером и виндой. Но если между ними стоит фаервол то он может резать некоторые запросы-ответы винды и роутера.
    Так вот, при одних и тех же настройках фаервола(у меня outpost) винда может "договориться" с одним роутером и "не договориться" с другим.
    Мешать их нормальному общению может не только фаервол, но и некоторые антивирусы
    (например NOD32 проверяет трафик HTTP и может ​блокировать трафик NAT и тп).

    Я написал что полностью отрубал outpost но ничего не менялось.
    Я не знал что надо было обновить соединение чтоб винда и роутер
    заново "договорились"!
    В аутпосте жму на "Выход" и ещё останавливаю службу аутпоста если она запущена.
    А после этого (ВНИМАНИЕ!)..правой кнопкой-"исправить" на локальном соединении. После этого всё заотправлялось!

    Теперь о том как в итоге всё заработало с фаерволом:
    Не знаю в какой настройке outpost'а крылся подвох, но я сделал так:
    1)ICMP - разрешил всё
    2)Глоб.правила и доступ к rawsocket -> Block incomming RPC(TCP и UDP)
    -снял галки
    3)очистил кэш DNS
    ...и всё заработало!
    Last edited by Solodoff; 03-03-2009 at 20:20.

  5. #50
    Похожая история, почту батом получаю, а отправить немогу, ящики свои, на собственном хостинге, прикол в том, что с теми же настройками, но с айпода и айфона, почта и отправляется и получается, а под виндой, вродь как 25 порт блокирует роутер по LAN соединению.
    А вот почта на gmail работает нормально, там 465 и 995 потрты, отвечают за прием/отправку.
    Что уже только не пробовал делать на роутере, какие только правила для портов не создавал, неработает ничего, режет 25 порт, и хоть ты тресни...

  6. #51
    Вот это стоит в настройках:
    Не забудьте установить в настройках программы: Ящик (Account) — Свойства почтового ящика (Properties) — Транспорт (Transport) — Отправка почты (Send mail) — Аутентификация (Autentication) — Аутентификация SMTP RFC2554 (Perform SMTP Autentication RFC2554).

  7. #52
    Мой провайдер перехватывает 25 порт и перенаправляет на свой SMTP-сервер, чтобы пресечь потоки спама в случае заражения. Временами на сервере бывают сбои, поэтому я отправляю почту с другого порта, который уже не перехватывают - 2525.

    Подробности - http://www.mail.ru/pages/help/108.html

    роутер тут не причем
    WL-500GPremium v.1 default CPU&memory 1.9.2.7-10
    (HP1018, EZ-setup on/off wi-fi, FDD 1Gb Corsair: nginx+phpfcgi, cron+phpNOD32Updater, squid+ADredirector, swapon)

  8. #53
    Помогите пожалуйста. Если не сделаю могут бить возможно ногами, возможно и по лицу. Если можно, то объясните попроще, чайнику. Стоит прошивка от Олега WL500gpv2-1.9.2.7-10 Проблема такая the bat! Почту отправляет, но не принимает. Я так понимаю, что дело в маршрутах. Как обычно через веб все хорошо. Пробовал яндекс и майл.ру.
    яндекс работает только когда я отключаю РРТР, т.е vpn и остаюсь в локалке. Тогда бат и получает и отправляет почту с яндекса. (яндекс у нас локальный).

    WAN Tape: PPTP
    IP-адрес: 10.1.0.245
    Маска подсети: 255.255.255.255
    Основной шлюз: 10.1.0.1
    DNS-сервер: 10.1.0.1 10.1.0.1

    Помогите, плиз.

  9. #54
    Quote Originally Posted by k00zia View Post
    Помогите пожалуйста. Если не сделаю могут бить возможно ногами, возможно и по лицу. Если можно, то объясните попроще, чайнику. Стоит прошивка от Олега WL500gpv2-1.9.2.7-10 Проблема такая the bat! Почту отправляет, но не принимает. Я так понимаю, что дело в маршрутах. Как обычно через веб все хорошо. Пробовал яндекс и майл.ру.
    яндекс работает только когда я отключаю РРТР, т.е vpn и остаюсь в локалке. Тогда бат и получает и отправляет почту с яндекса. (яндекс у нас локальный).

    WAN Tape: PPTP
    IP-адрес: 10.1.0.245
    Маска подсети: 255.255.255.255
    Основной шлюз: 10.1.0.1
    DNS-сервер: 10.1.0.1 10.1.0.1

    Помогите, плиз.
    9 из 10, что проблема именно в маршрутах.
    Попробуйте добавить маршрут типа такого через вебморду:
    <IP сервера > 255.255.255.255 10.1.0.1 1 MAN
    Адрес нужного сервера найдите сами.
    Только не забудьте поставить "Enable static routes?" - Yes

  10. #55
    Спасибо, azhur за помощь, но не прошло.
    Похоже все-таки провайдер, режет или глючит.
    Нужна была корпоративная почта позарез, естественно веб-морды нет. Читал, нашел выход настроил gmail, он оказывается может работать как обычная почтовая программа.
    Есть даже свои плюсы, может кому поможет.

  11. #56
    Join Date
    May 2006
    Location
    Moscow, Russia
    Posts
    1,457
    Если указанное ниже взято со страницы Status & Log - Status
    Quote Originally Posted by k00zia View Post
    WAN Tape: PPTP
    IP-адрес: 10.1.0.245
    Маска подсети: 255.255.255.255
    Основной шлюз: 10.1.0.1
    DNS-сервер: 10.1.0.1 10.1.0.1
    то предложенный маршрут загоняет трафик в непонятном направлении
    Quote Originally Posted by azhur View Post
    <IP сервера > 255.255.255.255 10.1.0.1 1 MAN
    Адрес шлюза следует брать из секции WAN IP Setting со странице IP Config - WAN & LAN. Если адреса присваиваются автоматически, то надо смотреть лог или подключить компьютер напрямую и посмотреть что он получит.

    Пропишите как указано и сделайте:
    tracert <имя/адрес_сервера_входящей_почты>
    Intel 2200BG (v.9.0.4.39) + Asus WL500g Premium (1.9.2.7-10.7) + ONLIME / [Corbina L2TP] / [MGTS + ZTE 831AII]

  12. #57

    Exclamation Настройка NAT на WL-500gP или проблема с почтой (smtp)

    Добрый день всем. У меня стоит WL-500gP на раздаче инета.
    Прошит Олеговской прошивкой, версия 1.9.2.7-10.
    Роутер работает практически с дефолтными настройками, за исключением DHCP, WLAN.
    Около недели назад почтовый клиент перестал соединяться с smtp серверами(любыми), при этом входящая почта приходит нормально. Кроме этого проблем не замечено. Из того что я нашел - говорят что это изза "серого" айпишника, нужно настроить NAT.
    Так вот, подскажите пожалуйста гуру, как настроить NAT для всей внутренней сетки, потому что в настройке роутера я вижу только задание прямо для каких IP использовать трансляцию, но ведь у меня стоит DHCP, не прописывать ведь все возможные адреса, а диапазоны тоже не получается вводить в поле.
    Но может быть NAТ тут ни при чем? Вобщем любые советы приветствуются. Заранее благодарен.

  13. #58
    Join Date
    Mar 2009
    Location
    Moscow
    Posts
    968
    Соединение с SMTP-серверами мог заблокировать интернет-провайдер (в целях борьбы со спамом, например). Это единственное разумное объяснение. IP тут не причем, и ничего настраивать в роутере не нужно.
    D-Link DIR-320 A1/A2, DIR-620 C1, Netgear WNR3500L v1 v2

  14. #59
    Quote Originally Posted by Vampik View Post
    Соединение с SMTP-серверами мог заблокировать интернет-провайдер (в целях борьбы со спамом, например). Это единственное разумное объяснение. IP тут не причем, и ничего настраивать в роутере не нужно.
    И тут вы не совсем правы. Если ip адрес серый ,то возможно, что провайдер блокирует 25 порт, но при наличии белого ip адреса провайдер ничего не блокирует.

  15. #60
    Join Date
    Mar 2009
    Location
    Moscow
    Posts
    968
    Провайдер может делать что хочет, это зависит только от его желания. Он мог заблокировать порт для части клиентов, или для всех, или для одного конкретного. Гадать можно до бесконечности. Не вижу в чем я не прав
    D-Link DIR-320 A1/A2, DIR-620 C1, Netgear WNR3500L v1 v2

Page 4 of 8 FirstFirst ... 23456 ... LastLast

Similar Threads

  1. Настройка PPTP VPN (accel-pppd) на роутере Asus
    By biGdada in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 305
    Last Post: 23-06-2016, 10:36
  2. Настройка IPv6 в WL-500gP
    By icCE in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 146
    Last Post: 28-12-2013, 00:29
  3. Проблема на роутере WL-500gP/W (MIPS R1) с прошивкой -rtn (2.6)
    By staticroute in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 138
    Last Post: 29-10-2013, 19:09
  4. Настройка darkstat на wl-500gp
    By Vorf in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 105
    Last Post: 29-05-2012, 16:01
  5. Настройка HP LaserJet P1006 для Asus WL-500GP
    By ice in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 213
    Last Post: 19-06-2010, 14:00

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •