Results 1 to 4 of 4

Thread: Oleg - IWeb Interface

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    26

    Oleg - IWeb Interface

    Is there a way to -
    1) Change the colours (lilac is sickly)
    2) Add/remove text

  2. #2
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Yes there is actually.

    You need to get the sources of the firmware and recompile them yourself after editing the webpages.

    you probably noticed the folder "/www" on your router.
    that folder contains all the webpages and images.
    With some quick editing you can change colours, text etc.
    but you cannot save them in "/www" since the directory is not writable, therefor you need to recompile the firmware with the modified pages

    Example code:
    PHP Code:
    <html>
    <
    head>
    <
    title>ASUS WL500W Web Manager</title>
    <
    meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
    <
    meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <
    meta http-equiv="Content-Type" content="text/html; charset=gb2312">
    <
    meta http-equiv="Content-Type" content="text/html">
    <
    meta http-equiv="Pragma" content="no-cache">
    <
    link rel="stylesheet" type="text/css" href="style.css" media="screen"></link>
    <
    script language="javascript">
    function 
    redirect() {
     
    setTimeout("redirect1()"25000)
    }
    function 
    redirect1() {
     
    top.location="index.asp"
    }
    </
    script>
    </
    head>
    <
    body bgcolor="#FFFFFF" onLoad="redirect()">
    <
    span class="wounderline"></span>
    <
    table width="666" border="0" cellpadding="2" cellspacing="0" vspace="30" height="1">
      <
    tr bgcolor="#CCCCCC"
        <
    td width="666" height="125"
          <
    table width="660" height="125" cellpadding="2" cellspacing="0" border="0">
            <
    tbody>
            <
    tr
              <
    td bgcolor="#FF0000" height="50" width="652"><b><font size="5" face="Arial" color="#FFFFFF">System Restarting!</font></b></td>
            </
    tr>
            <
    tr>
              <
    td width="652" height="25" bgcolor="#FFFFFF" colspan="2">System is restartingPlease wait until home page of WL500W setting is shown up again.</td>
             </
    tr>
            <
    tr
              <
    td width="652" height="25" bgcolor="#FFFFFF" colspan="2"></td>
            </
    tr>
            <
    tr>
              <
    td width="652" height="25" bgcolor="#FFFFFF" colspan="2"><font face="Arial"
                <
    font color="#FF0000"><b>NoteIt takes about 20 seconds.</b></font></font></td>
            </
    tr>
            </
    tbody>
          </
    table>
        </
    td>
      </
    tr>
    </
    table>
    </
    body>
    </
    html

  3. #3
    Join Date
    Mar 2009
    Location
    Australia
    Posts
    26
    Good stuff. Thanks.

    I've always wondered why Oleg stuck with the look and feel of the Asus firmware. Still do.

    Reading some other posts I get the impression that there may be some changes to the GUI in the future

  4. #4
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    it is very easy to understand as Oleg clearly stated that he doesn't want to invest his time and efforts in changing of the existing web interface. However, he wrote that he is ready to evaluate an alternative web-interface if someone would create it, and possibly include in the future releases. So you should not expect considerable changes in the GUI unless you create it yourself or someone else do this work.

Similar Threads

  1. I cannot connect on pppoe WAN with Oleg firmware
    By kalifro in forum WL-500w Q&A
    Replies: 3
    Last Post: 21-03-2011, 00:39
  2. USB Sound+WL500gP
    By Нихтферштейн in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 35
    Last Post: 06-05-2010, 10:02
  3. Pppoe doesn't work on Oleg fw 1.9.2.7-10
    By mandgeo in forum WL-500gP Firmware Discussion
    Replies: 7
    Last Post: 18-01-2009, 16:04
  4. Replies: 0
    Last Post: 05-05-2005, 21:20

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •