Results 1 to 3 of 3

Thread: cvs server on WL-HDD

  1. #1

    cvs server on WL-HDD

    Hi, all

    I would like to install a CVS server on my WL-HDD (now using HDD as root filesystem), has anybody already done something like this?

    Do you think it is possibile?

  2. #2

    Ok , it is (but statically)

    Well, after a lot of trying I finally got a working cvs binary.

    Here it is in case somebody needs it.

    This is the compilation command:

    #!/bin/sh
    # base directory of the cross development environment
    export PATH=$PATH:/opt/brcm/hndtools-mipsel-uclibc:/opt/brcm/hndtools-mipsel-uclibc/bin/

    # architecture prefix
    arch="mipsel-linux"

    # environment variables
    export CC="${arch}-gcc"
    export LD="${arch}-ld"
    export NM="${arch}-nm -B"
    export AR="${arch}-ar"
    export RANLIB="${arch}-ranlib"
    export LN_S="ln -s"

    export CFLAGS="-O2 -static"
    export CROSS_COMPILE=1


    # configuration

    ./configure --build="i686-pc-linux-gnu" --host="${arch}" \
    --with-headers="/opt/brcm/hndtools-mipsel-uclibc/include/" \
    --disable-server --libdir="/opt/brcm/hndtools-mipsel-uclibc/lib/" \
    --enable-rootcommit
    make clean
    make
    mipsel-linux-strip src/cvs


    Note: I couldn't made it work it with shared libs though.
    Attached Files Attached Files

  3. #3

    Unable to get the server working

    great work, the executable works fine.

    But did you get it working as a server?? I have read many articles about cvs over ssh ( cause there is no cvsd by now ) for the last 3 days but didn't get ich working.
    cvs executable lies in /tmp/harddisk/bin ( added the PATH to /etc/profile ). when login in as admin or cvs-user it works, but with cvs using ssh the executable isnt found. "sh: cvs: not found"

    I am no cvs or linux guru, so a little help would be great

Similar Threads

  1. Replies: 0
    Last Post: 20-05-2004, 17:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •