Results 1 to 15 of 21

Thread: WL-500gP & Wi-Fi 802.11n

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Thumbs up WL-500gP & Wi-Fi 802.11n

    Can someone tell me what minipci adapter must buy to operate in 802.11n?
    10x

  2. #2
    Join Date
    Aug 2008
    Location
    Poland, Biała Podlaska
    Posts
    276
    That works with no problem on kamikaze: http://74.125.43.101/translate_c?hl=...A-84o9bKUnCn0A

    And cost about 20$.

  3. #3
    Join Date
    Nov 2004
    Location
    Sweden
    Posts
    259
    Just in case the link below from Lesiuk gets broken, it makes reference to "Network card miniPCI WLAN TP-Link TL-WN861N"

  4. #4

    throughput? kamikaze build?

    Hello,

    can you post details? what kamikaze build? from trunk? what rev? also what is the max throughput? did you get N speeds? or is caped at 2.7MBps with cpu in full load?

    maybe you can upload your test .bin so we can test. I have the exact Tplink card and WL500GP ver.1

    Thanks!

    BR,
    Invictus
    Last edited by Invictus; 05-03-2009 at 23:19.

  5. #5

    TP-Link TL-WN961N tested to work on Asus WL-500gP ?

    Yes, the above link is broken. Thank you to clearing what it point to.
    But is it tested by someonw this TP-Link PCI adapter is working on Asus WL500gP
    Just plug and Play?

    brgds
    A

  6. I'm interested too. Has anyone tested?

  7. #7
    Quote Originally Posted by antair View Post
    I'm interested too. Has anyone tested?
    Has up to now somebody successfully installed a TL-WN861N to a WL500gp?
    As the WL500gp only lacks N-speed this would be a cheap upgrade path.

  8. #8
    Quote Originally Posted by preacher@wl500g View Post
    Has up to now somebody successfully installed a TL-WN861N to a WL500gp?
    As the WL500gp only lacks N-speed this would be a cheap upgrade path.
    It is look to be a great idea, but it is not.

    I got TL-WN861N on my WL-500gP combined with latest Kamikadze trunk. It was intresting experience, but after all now I am usng stock wifi card and Oleg fw back again.

    You need to anwser to yourself: You want to experiment with n-draft and wl-500gp, or you want fast, stable wireless network maintained via WL500gp router.

    If you like experimenting with your wifi network, you should try to install TL-WN861N card, but - i warn you - it take some time before you get your wifi working (i mean efficiently).

    I gave up because I need a quite sable wifi connection, wich OpenWRT latest trunk can't provide (very buggy ath9k driver).

    I never got pure n-draft connection. It's showed up in connection manager as "n" mode network, but forget about 300mbps speed.

    Probably you never get full n-draft speed because of WL500gp's CPU wich can not provide enough power to handle draft.

  9. #9
    Well, the task would be to find a module with good drivers for 2.4.x kernel.
    I think after loading the appropriate driver it shall work, because authentication and so on are handled by another protocol layer.
    The CPU can handle it for sure, because the WL500W has the same CPU but N WiFi card.
    Which speeds did you reach? I guess the problem on one hand is, that the WL500Gp has only one antenna and possibly you had a notebook with centrino WiFi card? In 2,4GHz band by default the driver has only 20MHz bandwidth enabled, you have to set to "auto" in the driver settings to get more than 150MBit.

  10. #10

    Wireless N on WL-500gP v1

    Hy ,

    I want to know if is possible to replace my default wireless card (G) from WL500GP with this wireless card TP-LINK TL-WN861N !!

    right now i use this firmware : WL500gp-1.9.2.7-rtn-r4667.trx

    someone ??

  11. #11
    Quote Originally Posted by xplay View Post
    Hy ,

    I want to know if is possible to replace my default wireless card (G) from WL500GP with this wireless card TP-LINK TL-WN861N !!

    right now i use this firmware : WL500gp-1.9.2.7-rtn-r4667.trx

    someone ??
    Don't think you can do it with this card.

    It doesn't provide AP mode from what I've read.

    You need to look into BCM43222 or WL500W wireless card.

    There is a thread in Russian only (unfortunately) about this upgrade I'd suggest simply instead of upgrading Wireless card buying new router completely instead, because there are many problems with recent -rtn firmware on ASUS wl-500gP v1.

    1) memory allocation when there is large network activity going on - router might reboot itself or just hang or if you're using pptp/l2tp connection mode - disconnect (link and another link happens when you're actively using WAN resourcers link2)

    2) dnsmasq unaligned instruction - sometime it just happens randomly and dnsmasq killed (link)

    3) I've been using BCM43222 wireless card with wl500gP v1 - on recent firmware you can experience slowdown happening over wireless connection (link)

    I'm using myself custom build of r3323 it doesn't have reboots issue and dnsmasq issue, but it has some bugs too, related to the wireless driver / memory allocation:

    Code:
    Mem-info:
    Normal per-cpu:
    CPU    0: Hot: hi:    0, btch:   1 usd:   0   Cold: hi:    0, btch:   1 usd:   0
    Active:2244 inactive:479 dirty:8 writeback:0 unstable:0
     free:235 slab:3139 mapped:347 pagetables:84 bounce:0
    Normal free:940kB min:2500kB low:3124kB high:3748kB active:8976kB inactive:1916kB present:32512kB pages_scanned:0 all_unreclaimable? no
    lowmem_reserve[]: 0
    Normal: 1*4kB 1*8kB 0*16kB 1*32kB 0*64kB 1*128kB 1*256kB 1*512kB 0*1024kB 0*2048kB 0*4096kB = 940kB
    Swap cache: add 0, delete 0, find 0/0, race 0+0
    Free swap  = 0kB
    Total swap = 0kB
    Free swap:            0kB
    8192 pages of RAM
    0 pages of HIGHMEM
    927 reserved pages
    794 pages shared
    0 pages swap cached
    swapper: page allocation failure. order:0, mode:0x20
    Call Trace:
    [<c01376c0>] init_module+0x2e6c0/0x30148 [et]
    [<c037fd78>] wlc_send_q+0x180/0x330 [wl]
    [<c041dc14>] wlc_hdr_proc+0x78/0x27e8 [wl]
    [<c0422100>] wlc_sendpkt+0x148/0x52c [wl]
    [<c04224c8>] wlc_sendpkt+0x510/0x52c [wl]
    [<c04226d8>] wlc_recvdata_sendup+0x1f4/0x5e0 [wl]
    [<c0422a10>] wlc_recvdata_sendup+0x52c/0x5e0 [wl]
    [<80004da0>] memcpy+0x0/0x4
    [<c0423284>] wlc_recvdata_ordered+0x7c0/0xb6c [wl]
    [<c0429904>] wlc_ampdu_recvdata+0x40c/0x64c [wl]
    [<c0421d10>] wlc_prep_sdu+0x1468/0x1710 [wl]
    [<c0425290>] wlc_recvdata+0xbc0/0xd64 [wl]
    [<c0425790>] wlc_recv+0x208/0x2ba8 [wl]
    [<c0425588>] wlc_recv+0x0/0x2ba8 [wl]
    [<c0429ee4>] wlc_dpc+0x388/0x94c [wl]
    [<c03b12e0>] wlc_bmac_retrylimit_upd+0x108/0x1d8 [wl]
    [<c041cfdc>] wl_intrson+0x20c/0x37c [wl]
    [<c0183e38>] usb_hcd_irq+0x5c/0x18c [usbcore]
    [<80001524>] ret_from_irq+0x0/0x4
    [<80332c84>] start_kernel+0x378/0x4d8
    [<8033256c>] unknown_bootoption+0x0/0x324
    [<8034ce50>] _einittext+0x0/0x0
    
    Mem-info:
    Normal per-cpu:
    CPU    0: Hot: hi:    0, btch:   1 usd:   0   Cold: hi:    0, btch:   1 usd:   0
    Active:2244 inactive:479 dirty:8 writeback:0 unstable:0
     free:235 slab:3139 mapped:347 pagetables:84 bounce:0
    Normal free:940kB min:2500kB low:3124kB high:3748kB active:8976kB inactive:1916kB present:32512kB pages_scanned:0 all_unreclaimable? no
    lowmem_reserve[]: 0
    Normal: 1*4kB 1*8kB 0*16kB 1*32kB 0*64kB 1*128kB 1*256kB 1*512kB 0*1024kB 0*2048kB 0*4096kB = 940kB
    Swap cache: add 0, delete 0, find 0/0, race 0+0
    Free swap  = 0kB
    Total swap = 0kB
    Free swap:            0kB
    8192 pages of RAM
    0 pages of HIGHMEM
    927 reserved pages
    794 pages shared
    0 pages swap cached
    I never experienced such issues on 2.4.20 kernel (original Oleg's firmware 1.9.2.7-10), so it's most likely issues with current kernel used in rtn line.

    And if you still want to buy a replacement card I'd suggest buy some Atheros one which is supported in 2.4.20 kernel (not sure need to check) or card from WL500W (it's very hard to find tho).

  12. #12
    staticroute thx for your suggestion i will apreciate your advice and answer for my question !

    the true is yestarday i upgrade my WL-500gP v1 firmware to WL500gp-1.9.2.7-rtn-r4667.trx ,
    untill now i use oleg firmware 1.9.2.7-10 for over 3 years .. absolute no problem with them!

    maybe i should stay on them and not upgrade to rtn-r4667

    WL-500gP v1 is a very good router, but you right i have to look further to buy a new router maybe RT-N56U or RT-N65U

  13. #13
    Quote Originally Posted by xplay View Post
    staticroute thx for your suggestion i will apreciate your advice and answer for my question !

    the true is yestarday i upgrade my WL-500gP v1 firmware to WL500gp-1.9.2.7-rtn-r4667.trx ,
    untill now i use oleg firmware 1.9.2.7-10 for over 3 years .. absolute no problem with them!

    maybe i should stay on them and not upgrade to rtn-r4667

    WL-500gP v1 is a very good router, but you right i have to look further to buy a new router maybe RT-N56U or RT-N65U
    I strongly suggest staying on Oleg's firmware because it's the most stable there available for this router.

    I'd use it myself but unfortunately I have to stick around to rtn-r3323 due upgrade 802.11n module.

    Take a look at RT-N66U as well, it might be good, not sure. Personally I'm wanting Ubiquiti RSPro but it's not available anymore

  14. #14
    Quote Originally Posted by staticroute View Post
    I strongly suggest staying on Oleg's firmware because it's the most stable there available for this router.

    I'd use it myself but unfortunately I have to stick around to rtn-r3323 due upgrade 802.11n module.
    Hi staticroute,

    can I assume your -N experience with WL500GP v1 is successful ?

    I have both TP-Link WN861N and BCM43222 cards. Which one to try out with ?

    1. If Yes, am I right, in assuming that the correct Oleg's FW for the purpose is 1.9.2.7-9 ?
    2. If No, could you point me to the right FW for stable -N performance on the router ?
    3. Is the USB HDD connection ability and DL use is kept in this FW ?
    4. Does the 3G USB stick ability been kept too ?

    TNX for your time, indeed !
    Last edited by AlexPPC; 20-03-2014 at 04:04. Reason: typo

  15. #15
    There is no need to go back to old old old old old oleg Fimware.

    The Enthusiast-Fimware features both kernels 2.4 and 2.6. Just use WL500gp-1.9.2.7-d-r2624 (d-Branch is kernel 2.4) if you have issues with the rtn-Branch (kernel 2.6).

    lly and theMiron did a great job enhancing the last oleg. They fixed many security issues and improved stability.
    RT-N66U TomatoUSB 1.28.0000 MIPSR2-135 K26AC USB AIO-64K running Entware-NG
    pyload 0.4.9
    minidlna 1.1.2
    samba 3.6.5
    openvpn 2.3.10
    ̶W̶L̶5̶0̶0̶g̶P̶ ̶1̶.̶9̶.̶2̶.̶7̶-̶r̶t̶n̶-̶r̶4̶7̶5̶0 retired

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •