Results 1 to 4 of 4

Thread: Help with Oleg firmware (shell command are denied)

  1. #1

    Help with Oleg firmware (shell command are denied)

    I've tried to install the ntorrent and rtorrent on the router but at a point i was getting numerous: Permision denied errors. For example, when i try to do:

    ipkg update

    i get this error message:

    [admin@WL-xxx root]$ ipkg update
    sh: wget: Permission denied
    An error ocurred, return value: 1.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 127: `wget -q -P /opt/ipkg-gP5xyd'

    I've tried to reinstall the firmware but it kept the settings. I've put the asus firmware back and then the oleg firmware hoping that the old settings are reseted... no luck.

    Can somebody please help me get this permission denied errors ?

    PS: i've google this error and i found that it is generated but files not having executable permissions. I've tried chmod +x /usr/sbin but i get:

    changing permissions of `/usr/sbin/snmpd': Read-only file system
    changing permissions of `/usr/sbin/statd': Read-only file system

    However, when i do a mount command i get:

    [admin@WL-xxx root]$ mount
    /dev/root on / type squashfs (ro)
    none on /dev type devfs (rw)
    proc on /proc type proc (rw)
    ramfs on /tmp type ramfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/discs/disc0/part2 on /opt type ext3 (rw,noatime)
    /dev/discs/disc0/part3 on /tmp/mnt/disc0_3 type ext3 (rw,noatime)

    Seems like the partitions are in RW mode.

    Can anybody please help.


  2. Is ur hard disk NTFS formatted?

  3. #3
    No, it is formatted according to Wengi's guide (3 partitions , 1 swap , the others ext2/3)

  4. #4
    Join Date
    Feb 2005
    Germany - Frankfurt

    unmount your hdd and do an e2fsck on both partitions.

    Übersicht aller HowTos --- HowTo Overview (mostly german)
    WL-HDD mit diesem Setup. --- WL-HDD with this setup.
    Kein Support per PM - Frage im jeweiligen Thread! --- No support via pm - ask in the according thread!
    Eine wirklich gute Idee erkennt man daran, dass ihre Verwirklichung von vorne herein ausgeschlossen erscheint. (Albert Einstein)

Similar Threads

  1. I cannot connect on pppoe WAN with Oleg firmware
    By kalifro in forum WL-500w Q&A
    Replies: 3
    Last Post: 21-03-2011, 00:39
  2. Oleg firmware ftp help
    By trxtrx in forum WL-500gP Q&A
    Replies: 8
    Last Post: 16-04-2009, 18:43
  3. Oleg firmware ftp help
    By trxtrx in forum WL-500gP Q&A
    Replies: 2
    Last Post: 24-11-2008, 12:16
  4. New Oleg firmware problems?
    By wpte in forum WL-500gP Firmware Discussion
    Replies: 11
    Last Post: 18-04-2008, 00:34
  5. twonky media server, network drive with oleg firmware
    By black_bottom in forum WL-HDD Q&A
    Replies: 3
    Last Post: 22-03-2006, 08:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts