Page 1 of 2 12 LastLast
Results 1 to 15 of 19

Thread: Having trouble to compile Olegs Firmware...

  1. #1
    Join Date
    May 2004
    Location
    France...
    Posts
    159

    Having trouble to compile Olegs Firmware...

    I tried to compile Olegs firmware, but i stuck on an error... What am i doing wrong? I followed the instructions he gives here.

    Everything went fine until kernel patching.... After that doing a make in the wl500g-1.9.2.7-3c directory fails with Error 77.

    Here is what the screen outputs gives me

    Code:
    [root@localhost wl500g-1.9.2.7-3c]# make
    tar xjf busybox-1.00.tar.bz2 -C /root/broadcom/src/gateway
    patch -d /root/broadcom/src/gateway/busybox-1.00 -p1 < busybox-1.00.patch
    patching file include/applets.h
    patching file include/usage.h
    patching file shell/ash.c
    patching file sysklogd/syslogd.c
    cp busybox-1.00.config /root/broadcom/src/gateway/busybox-1.00/sysdeps/linux/defconfig
    mv /root/broadcom/src/gateway/busybox-1.00 /root/broadcom/src/gateway/busybox
    tar xjf dropbear-0.44test4.tar.bz2 -C /root/broadcom/src/gateway
    patch -d /root/broadcom/src/gateway/dropbear-0.44test4 -p1 < dropbear-0.44test4.patch
    patching file options.h
    cd /root/broadcom/src/gateway/dropbear-0.44test4 && \
            CC=mipsel-uclibc-gcc ./configure --host=mipsel-linux --disable-zlib --disable-shadow \
            --disable-lastlog --disable-utmp --disable-utmpx --disable-wtmp --disable-wtmpx \
            --disable-libutil --disable-loginfunc --disable-pututline --disable-pututxline
    configure: WARNING: If you wanted to set the --build type, don't use --host.
        If a cross compiler is detected then cross compile mode will be used.
    checking for mipsel-linux-gcc... mipsel-uclibc-gcc
    checking for C compiler default output... configure: error: C compiler cannot create executables
    See `config.log' for more details.
    make: *** [/root/broadcom/src/gateway/dropbear/config.h] Erreur 77
    And here is the log file
    Code:
    This file contains any messages produced by compilers while
    running configure, to aid debugging if configure makes a mistake.
    
    It was created by configure, which was
    generated by GNU Autoconf 2.57.  Invocation command line was
    
      $ ./configure --host=mipsel-linux --disable-zlib --disable-shadow --disable-lastlog --disable-utmp --disable-utmpx --disable-wtmp --disable-wtmpx --disable-libutil --disable-loginfunc --disable-pututline --disable-pututxline
    
    ## --------- ##
    ## Platform. ##
    ## --------- ##
    
    hostname = localhost
    uname -m = i686
    uname -r = 2.6.8.1-10mdksmp
    uname -s = Linux
    uname -v = #1 SMP Wed Sep 8 16:41:52 CEST 2004
    
    /usr/bin/uname -p = unknown
    /bin/uname -X     = unknown
    
    /bin/arch              = i686
    /usr/bin/arch -k       = unknown
    /usr/convex/getsysinfo = unknown
    hostinfo               = unknown
    /bin/machine           = unknown
    /usr/bin/oslevel       = unknown
    /bin/universe          = unknown
    
    PATH: /sbin
    PATH: /usr/sbin
    PATH: /bin
    PATH: /usr/bin
    PATH: /usr/X11R6/bin
    PATH: /usr/local/bin
    PATH: /usr/local/sbin
    PATH: /root/broadcom/opt/brcm/hndtools-mipsel-linux/bin
    PATH: /root/broadcom/opt/brcm/hndtools-mipsel-uclibc/bin
    
    
    ## ----------- ##
    ## Core tests. ##
    ## ----------- ##
    
    configure:1293: checking for mipsel-linux-gcc
    configure:1319: result: mipsel-uclibc-gcc
    configure:1601: checking for C compiler version
    configure:1604: mipsel-uclibc-gcc --version </dev/null >&5
    configure:1607: $? = 255
    configure:1609: mipsel-uclibc-gcc -v </dev/null >&5
    Invoked as mipsel-uclibc-gcc
    arg[ 0] = /opt/brcm/hndtools-mipsel-linux-3.2.3/bin/mipsel-linux-gcc
    arg[ 1] = -v
    configure:1612: $? = 255
    configure:1614: mipsel-uclibc-gcc -V </dev/null >&5
    configure:1617: $? = 255
    configure:1641: checking for C compiler default output
    configure:1644: mipsel-uclibc-gcc    conftest.c  >&5
    configure:1647: $? = 255
    configure: failed program was:
    | #line 1620 "configure"
    | /* confdefs.h.  */
    | 
    | #define PACKAGE_NAME ""
    | #define PACKAGE_TARNAME ""
    | #define PACKAGE_VERSION ""
    | #define PACKAGE_STRING ""
    | #define PACKAGE_BUGREPORT ""
    | /* end confdefs.h.  */
    | 
    | int
    | main ()
    | {
    | 
    |   ;
    |   return 0;
    | }
    configure:1686: error: C compiler cannot create executables
    See `config.log' for more details.
    
    ## ---------------- ##
    ## Cache variables. ##
    ## ---------------- ##
    
    ac_cv_env_CC_set=set
    ac_cv_env_CC_value=mipsel-uclibc-gcc
    ac_cv_env_CFLAGS_set=
    ac_cv_env_CFLAGS_value=
    ac_cv_env_CPPFLAGS_set=
    ac_cv_env_CPPFLAGS_value=
    ac_cv_env_CPP_set=
    ac_cv_env_CPP_value=
    ac_cv_env_LDFLAGS_set=
    ac_cv_env_LDFLAGS_value=
    ac_cv_env_build_alias_set=
    ac_cv_env_build_alias_value=
    ac_cv_env_host_alias_set=set
    ac_cv_env_host_alias_value=mipsel-linux
    ac_cv_env_target_alias_set=
    ac_cv_env_target_alias_value=
    ac_cv_prog_CC=mipsel-uclibc-gcc
    
    ## ----------------- ##
    ## Output variables. ##
    ## ----------------- ##
    
    AR=''
    CC='mipsel-uclibc-gcc'
    CFLAGS=''
    CPP=''
    CPPFLAGS=''
    DEFS=''
    ECHO_C=''
    ECHO_N='-n'
    ECHO_T=''
    EGREP=''
    EXEEXT=''
    INSTALL=''
    LD=''
    LDFLAGS=''
    LIBOBJS=''
    LIBS=''
    LTLIBOBJS=''
    OBJEXT=''
    PACKAGE_BUGREPORT=''
    PACKAGE_NAME=''
    PACKAGE_STRING=''
    PACKAGE_TARNAME=''
    PACKAGE_VERSION=''
    PATH_SEPARATOR=':'
    RANLIB=''
    SET_MAKE=''
    SHELL='/bin/sh'
    STRIP=''
    ac_ct_AR=''
    ac_ct_CC=''
    ac_ct_INSTALL=''
    ac_ct_RANLIB=''
    ac_ct_STRIP=''
    bindir='${exec_prefix}/bin'
    build=''
    build_alias=''
    build_cpu=''
    build_os=''
    build_vendor=''
    datadir='${prefix}/share'
    exec_prefix='NONE'
    host='mipsel-linux'
    host_alias='mipsel-linux'
    host_cpu=''
    host_os=''
    host_vendor=''
    includedir='${prefix}/include'
    infodir='${prefix}/info'
    libdir='${exec_prefix}/lib'
    libexecdir='${exec_prefix}/libexec'
    localstatedir='${prefix}/var'
    mandir='${prefix}/man'
    oldincludedir='/usr/include'
    prefix='NONE'
    program_transform_name='s,x,x,'
    sbindir='${exec_prefix}/sbin'
    sharedstatedir='${prefix}/com'
    sysconfdir='${prefix}/etc'
    target_alias=''
    
    ## ----------- ##
    ## confdefs.h. ##
    ## ----------- ##
    
    #define PACKAGE_BUGREPORT ""
    #define PACKAGE_NAME ""
    #define PACKAGE_STRING ""
    #define PACKAGE_TARNAME ""
    #define PACKAGE_VERSION ""
    
    configure: exit 77
    So what's wrong?
    The Struggle Continues...
    Asus WL500g #1 with fw 1.9.2.7-7f running as main home gateway, with Philipps PWC730k
    Asus WL500g #2 with fw 1.9.2.7-7f running as Wireless Client, running palantir 2.6 with SPCA5xx camera on 128MB generic USB key

  2. #2
    Join Date
    Dec 2004
    Location
    The Netherlands
    Posts
    29
    Quote Originally Posted by max2950
    I tried to compile Olegs firmware, but i stuck on an error... What am i doing wrong? I followed the instructions he gives here.

    Everything went fine until kernel patching.... After that doing a make in the wl500g-1.9.2.7-3c directory fails with Error 77.
    Maybe a bit trivial but, do you have sufficient free space on your disk? On my environment I'm currently using 1.2 out of 2 GB (and that is only the broadcom stuff, not the OS/distro).

    I also noticed the 'erreur 77', are you compiling on a French language system? Should not make a difference but maybe the locale "C" will be more safe.

  3. #3
    Join Date
    May 2004
    Location
    France...
    Posts
    159
    Quote Originally Posted by Feico de Boer
    Maybe a bit trivial but, do you have sufficient free space on your disk? On my environment I'm currently using 1.2 out of 2 GB (and that is only the broadcom stuff, not the OS/distro).

    I also noticed the 'erreur 77', are you compiling on a French language system? Should not make a difference but maybe the locale "C" will be more safe.

    Thanks for the tips.... I googled and did not find what "erreur 77" (error 77 in plain english ) is....

    I have 2.9GB free on my disk.... I'm running Mandrake 10.1 in a vmware.... I think i should reinstall it in english.....
    The Struggle Continues...
    Asus WL500g #1 with fw 1.9.2.7-7f running as main home gateway, with Philipps PWC730k
    Asus WL500g #2 with fw 1.9.2.7-7f running as Wireless Client, running palantir 2.6 with SPCA5xx camera on 128MB generic USB key

  4. #4
    Join Date
    Dec 2004
    Location
    The Netherlands
    Posts
    29
    Quote Originally Posted by max2950
    Thanks for the tips.... I googled and did not find what "erreur 77" (error 77 in plain english ) is....

    I have 2.9GB free on my disk.... I'm running Mandrake 10.1 in a vmware.... I think i should reinstall it in english.....
    For error 77 all I can find is 'file handle in bad state'. I really have no clue why that would happen. The message and log you show doesn't tell a lot.

  5. #5
    Join Date
    May 2004
    Location
    France...
    Posts
    159
    Quote Originally Posted by Feico de Boer
    For error 77 all I can find is 'file handle in bad state'. I really have no clue why that would happen. The message and log you show doesn't tell a lot.
    I forgot to mention that i'm compiling under a console window under KDE... Could this have some influence?
    The Struggle Continues...
    Asus WL500g #1 with fw 1.9.2.7-7f running as main home gateway, with Philipps PWC730k
    Asus WL500g #2 with fw 1.9.2.7-7f running as Wireless Client, running palantir 2.6 with SPCA5xx camera on 128MB generic USB key

  6. #6
    Join Date
    Dec 2004
    Location
    The Netherlands
    Posts
    29
    Quote Originally Posted by max2950
    I forgot to mention that i'm compiling under a console window under KDE... Could this have some influence?
    Don't think so, I do the same. I'm using Debian unstable (that is 3.1 I believe) with recent KDE from this distro. Because I run this Debian inside coLinux I don't have a graphics adapter but I use VNC server for that and it works like a charm.

    The only issue I really had was figuring out what packages where missing before I got a clean install.

  7. #7
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Have you read toolchain installation README? It should be installed in the /opt, not in the /root/broadcom/opt/. Just move it to the right place...

  8. #8
    My trouble was that of a newbie (I had the same problem). I didn't completely know how to "permanently" change environment variables. I created /etc/profile.local and put the right stuff in it, but it wasn't having any effect. When I executed what I put in it myself, it worked. Probably simple and obvious.

  9. #9
    Join Date
    May 2004
    Location
    France...
    Posts
    159
    Quote Originally Posted by Oleg
    Have you read toolchain installation README? It should be installed in the /opt, not in the /root/broadcom/opt/. Just move it to the right place...
    I have read this readme, but i must be dumb or this is not obvious....

    However it works now !!!! Thanks !
    The Struggle Continues...
    Asus WL500g #1 with fw 1.9.2.7-7f running as main home gateway, with Philipps PWC730k
    Asus WL500g #2 with fw 1.9.2.7-7f running as Wireless Client, running palantir 2.6 with SPCA5xx camera on 128MB generic USB key

  10. #10
    Another issue I know now

    You HAVE to have GLIBC_2.3.
    It WILL NOT compile with GLIBC_2.2

  11. #11
    Join Date
    May 2004
    Location
    France...
    Posts
    159
    Quote Originally Posted by Kitsok
    Another issue I know now

    You HAVE to have GLIBC_2.3.
    It WILL NOT compile with GLIBC_2.2
    This seems to be ok for me, for now i'm struggling with lzma !
    The Struggle Continues...
    Asus WL500g #1 with fw 1.9.2.7-7f running as main home gateway, with Philipps PWC730k
    Asus WL500g #2 with fw 1.9.2.7-7f running as Wireless Client, running palantir 2.6 with SPCA5xx camera on 128MB generic USB key

  12. #12
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Just type make lzma in the firmware dir. It was already indicated several times, that this step is missing in my sources...

  13. #13
    Join Date
    May 2004
    Location
    France...
    Posts
    159
    Quote Originally Posted by Oleg
    Just type make lzma in the firmware dir. It was already indicated several times, that this step is missing in my sources...
    Thanks again for the info !
    I think that once i have managed to compile the firmware completely i'm gonna write a "Howto compile for dummies and newbies"
    The Struggle Continues...
    Asus WL500g #1 with fw 1.9.2.7-7f running as main home gateway, with Philipps PWC730k
    Asus WL500g #2 with fw 1.9.2.7-7f running as Wireless Client, running palantir 2.6 with SPCA5xx camera on 128MB generic USB key

  14. #14
    Thank you. We certainly need one.

  15. #15
    Join Date
    May 2004
    Location
    France...
    Posts
    159
    Quote Originally Posted by tomilius
    Thank you. We certainly need one.

    I'm still struggling with lzma, i'm so dumb when it comes to linux developpment !
    The Struggle Continues...
    Asus WL500g #1 with fw 1.9.2.7-7f running as main home gateway, with Philipps PWC730k
    Asus WL500g #2 with fw 1.9.2.7-7f running as Wireless Client, running palantir 2.6 with SPCA5xx camera on 128MB generic USB key

Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 07-09-2005, 11:35
  2. NFS/ftp with Olegs custom firmware
    By gerd in forum WL-HDD Custom Development
    Replies: 6
    Last Post: 25-04-2005, 12:16
  3. OpenWrt Firmware or Olegs 1.7.5.9-5
    By rdk in forum WL-500g Q&A
    Replies: 3
    Last Post: 16-09-2004, 19:28

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •