Results 1 to 8 of 8

Thread: Windows could not connect to this network

  1. #1

    Windows could not connect to this network

    Thanks to everyone (Oleg) who took the time to review this information. The futility of continued posting in this thread has been realized in any case.

    I had thought the problem was router-related because the device would work better or worse depending on the firmware installed. Still, the other wireless device (WL-138g) works fine with everything, aside from a horribly poor signal strength.

    BIGGEST UPDATE: I don't really know what the problem is, but I'm staying away from current 1.9.2.7-based firmware and all ASUS firmware.

    UPDATE: The cause of this problem has been traced to random WPA-PSK problems, as described elsewhere. Read the later posts in this thread for possible solutions (1.8.1.x, WEP, possibly others...).

    [EDIT: Tried to add some more detailed information and organize it a little better. More will be posted in replies.]

    Hello - I'm new to the forums and admire the work done on these custom firmwares (a lot more than ASUS has done to solve problems, perhaps). I'd definitely like to thank you all for that, so thanks Oleg, Antiloop, and everyone and anyone else who worked on them.

    Having said that, there's an issue I've had, and I haven't actually done much troubleshooting on it due to the great amount of time it takes, but I can state the circumstances in which it occurs. To start off, I wouldn't consider myself a newbie, and I have the latest firmware and drivers on everything.

    Firmware: 1.9.2.7-3c
    WMM: Off
    Encryption: WPA-PSK, TKIP
    Hide SSID: On
    Wireless Channel: 11
    Wireless Mode: Auto [54g Protection checked] (I've the checkbox both ways)
    Number of connections to track: 5120 (I raised it from 4096 hoping it would solve the problem after reading about the P2P issues--it didn't)

    Affected Computer: The one running P2P, it appears. It uses Wireless G.
    Adapter: MN-710 (Microsoft USB 2.0 Wireless G Adapter)
    Devices Connected: One 100mbps LAN computer, two Wireless G computers, one Wireless B Pocket PC (may or may not be running while problems occur)

    Symptoms-
    Occurs: Randomly
    What: The connection "drops"
    How:


    Description: When this happens, Windows WILL NOT reconnect automatically or solve the problem without user intervention.

    Possible hand-in-hand symptoms-
    Pocket PC Streaming from Affected Computer Loses Buffer and Stops
    Windows Announces that I have Connected Though I've Been Connected
    (The reason these are only "possible" symptoms is that they seem to be unrelated to the main symptom.)

    I've tried-
    Switched to 1.8.1.7-3. Connection, with P2P, lasted over 13 hours before I ended the trial. The "Pocket PC Streaming" issue did occur, but the stream lasted a lot longer than ever before (2 hours, 2 minutes). I'm disregarding this.

    Now, I think it does have something to do with BitTorrent. When I loaded it during the day, the connection died after a while in this familiar way.

    I had reinstalled Windows hoping to solve the problem, and it, in fact, did SEEM to solve the problem at first. I was able to stream music to my Pocket PC just fine at night without any interruptions (that I noticed before falling asleep).

    But again, the main problem is that it randomly, as it was working fine, would state that it couldn't connect. Windows said it would keep trying but would not, halting my connection for hours on end and therefore interrupting downloads.

    I mean, it would work great, with high signal strengths and speeds of 54mbps, and then suddenly it would STOP in the way I described.
    Last edited by tomilius; 27-03-2005 at 03:37.

  2. #2
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Well, looks like 1.9.2.7 problems or WPA-PSK problems. Have you tried using just WEP?

  3. #3
    Problem seemed to be solved with WEP. How about 1.9.2.7-3b?

    1.9.2.7-3b does NOT resolve the "WPA-PSK issue" for me.
    Last edited by tomilius; 25-02-2005 at 23:10.

  4. #4
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Did you use vendor supplied utility for WPA? If so, try removing it and use Windows to configure your card.

  5. #5
    Thanks once more for the reply, Oleg. Nope, not using any vendor software for the configuration. There are only issues with the later firmwares... except maybe...

    TOTALLY EXTREME UPDATE:
    Uh. Well. Here's an overview of everything I know about solving this problem:


    Yep. Nothing.
    I got a new, unquestionably more powerful antenna and the connection still drops. The signal strength is always excellent, too...
    Last edited by tomilius; 11-03-2005 at 15:28.

  6. #6
    My connection problem seems to have been solved--that is, it's been up for almost 3 full days without causing me any trouble (actually, it hasn't caused me any trouble for a week or two with these settings, I just had to reboot it to configure something). The only concrete item on the list that helped was using firmware 1.8.1.7-3, as any 1.9.2.7-based firmware would cause the problem in a short amount of time. Here's my current configuration:

    Firmware: 1.8.1.7-3. This firmware was essential for stability (as opposed to 1.9.2.7).
    Wireless Encryption: WPA-PSK TKIP+AES. My wireless devices which support AES (both wireless computers do) use it, and my Pocket PC uses TKIP. None have experienced connectivity problems.
    Wireless Channel: 1. I had been against using channel 1 from of the start due to cordless phone interference--we have a cordless phone. I'd always used channel 11. However, with channel 1 there have been no issues at all.
    Network Key Rotation Interval: 1800. My Pocket PC used to, but I'm not sure if it does now, go through a quick re-authentication process every 30 minutes which would cause streaming music to stop picking up the stream for a few seconds, but it would start back up again. It has never affected any of the PCs.
    Access Control: Accept. I only allow certain devices to connect.
    Hide SSID: Off. This one is off because I have a WL-138g in one of the computers and I had read having the SSID hidden screwed it up.
    DHCP Server: Off. It's NOT REALLY OFF. I just have it configured my own way (a year for lease time), and it is therefore launched through post-boot.
    UPnP: On. I never had it off.
    Virtual Servers: On. However, I have them configured with post-firewall only.
    Firewall: On. I'd never turn that off either. However, all firewall settings, including Web Access, are configured manually with post-firewall.
    Number of connections to track: 4096. I experimented with changing that before, but that apparently didn't help.

    I think that's about all that needs to be told...

    Click here to visit the directory listing for my wl-500g flash configuration. If you choose to use these files, you MUST modify the following to suit your needs (they won't work out-of-the-box):
    /tmp/local/etc/ethers
    /tmp/local/etc/dnsmasq.conf
    /tmp/local/sbin/post-firewall

    In dnsmasq.conf, 192.168.1.200 and 192.168.1.220 are the DHCP assignment bounds, and 31536000 is the lease time in seconds (1 year). It should be simple enough to understand how ethers works, and after taking a look at post-firewall, you should be able to easily (and you will NEED to) adjust it to your needs as well.

    UPDATE: Actually, I've been using 1.9.3.7-4 with all of these settings. At first, I had the problem occur a mere 3 minutes after upgrading. However, when I remembered that I needed to do "flashfs enable" and reboot to get my own special settings, I did that and I haven't had this issue since... though that's not saying much. It hasn't been that long.

    SCRATCH THAT UPDATE! 1.9.3.7-4 has this WiFi issue as well.
    Last edited by tomilius; 21-03-2005 at 02:01.

  7. #7
    If someone could kindly review this information and share his/her knowledge it would be so awesome I would have to give him/her money... or a smiley instead. ^_^ Thanks in advance for taking a look at this.

    OK... um... 1.8.1.7-3 is a lot more stable but the problem still officially occurs for me in it. This time it was within about 12 hours?

    I had thought the problem was gone since it hadn't happened for a while.

    My event viewer gives some interesting information:
    Last night (very early hours of the day the problem occured), my computer started getting familiar and annoying event log entries:
    Code:
    Event Type:	Error
    Event Source:	NetBT
    Event Category:	None
    Event ID:	4321
    Date:		3/25/2005
    Time:		3:40:51 AM
    User:		N/A
    Computer:	THOMAS
    Description:
    The name "HOME           :1d" could not be registered on the Interface with IP address 192.168.1.10. The machine with the IP address 192.168.1.10 did not allow the name to be claimed by this machine.
    Every 5 minutes this continued to happen. Please don't assume I'm stupid enough to have two IP addresses assigned to 192.168.1.10. I swear, I have not set this network up that way.

    Now, when I turned on another computer (it happens to be, though it probably doesn't matter, the one connected to the router by ethernet) and the entries appear to have stopped when that occured. There were a couple Browser information notices in the log after this about forced elections and there was some information which involved the name of that just-turned-on computer. During the night (early hours from 3), there had been Browser messages every 30 minutes, only they were Errors and not informational.

    At 11:41:14, for whatever reason, my computer became disconnected. 25 seconds later, it was connected again. A minute and 5 seconds passed before the log began to show entries in which it was stated that the adapter had connected to the network every 3 minutes precisely three times. The fourth time was an extra 5 seconds upon which it said that the network was disconnected rather than connected, and it stayed like that for hours until I came home and reconnected it manually as I always have to do. It was the typical "Unable to connect to network" situation I've complained so much about in this thread.

    To clear this up ahead of time, I've searched this forum and Google and have found nothing to help me with this problem. Google is my best friend, so there's no reason to attempt to teach me about it. In a nutshell, I've reinstalled Windows, switched firmwares on the router countless times, and customized my own firewall rules. Nada. The problem only occurs wirelessly. I suppose it could be my MN-710 Microsoft Wireless G USB 2.0 adapter, so I'll be testing another adapter over the weekend.

    Here's my lovely event log:


    I think the NetBT stuff is actually related to my other "LAN devices lose connectivity" problem which I isolated to my wireless adapter (for whatever reason) not receiving ethernet broadcasts after a certain amount of time, and looking up the 4321 Event ID...
    Code:
       1. The network is down.
       2. The firewall on your computer is blocking out network broadcast traffic.
       3. Your computer's network interface card or driver is not functioning correctly.
    ... that fits number 2, except for the firewall part, because it still happened with the firewall off (unless there's something about ZoneAlarm I don't know, like maybe it runs even when I close it and it says it will shut down monitoring and the firewall and such, maybe it still keeps a driver resident or ... you know). In any case, off I go to try the other adapter.
    Last edited by tomilius; 26-03-2005 at 22:12.

  8. #8
    See first post. I'm going to assume the problem was also MN-710-related, because come to think of it, the other wireless device hasn't had such problems. Either way, I won't be posting about it anymore since nobody has had any suggestions. Thread done.

Similar Threads

  1. Windows network in LAN and WAN
    By dejay in forum WL-500g Q&A
    Replies: 6
    Last Post: 27-08-2005, 00:08
  2. Connect to Windows Share behind WL-500g deluxe
    By Peter Schmidt in forum WL-500g Q&A
    Replies: 12
    Last Post: 01-07-2005, 17:00
  3. How can i connect two network with asus?
    By cutor in forum WL-500g Q&A
    Replies: 10
    Last Post: 06-01-2005, 16:09
  4. Replies: 2
    Last Post: 10-09-2004, 17:46
  5. Can't connect to network
    By john37 in forum WL-500g Q&A
    Replies: 2
    Last Post: 04-06-2004, 21:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •