Results 1 to 9 of 9

Thread: WL-500W with HDD Mac OSX connection failed

  1. #1

    WL-500W with HDD Mac OSX connection failed

    Searched the whole forum but couldnt find the answer to this issue...

    I have WD Mybook HDD connected to my Asus WL-500W. I am using latest Olegs firmware.

    When I try to access the HDD wirelessly using my MacBook with latest OSX it says connection failed. Router is visible under "SHARED" however it can not be accessed. You can also try connecting using password (could not find any setting on my router to set it in Samba section) but I have no idea what it should be. I have also tried the one I use to connect to the router but without any success.

    Everything else is working fine. I can use the shared printer on USB normally as well. Disk is also normally accessible using any other PC with Windows.

    If it was already discussed somewhere, please let me know. I have no knowledge in scripts so please make it simple

    Thanks guys!
    Last edited by Zviti; 16-11-2008 at 21:05.

  2. #2
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    how do you share it?
    via the build in samba?

  3. #3
    Yes, that was the plan. I really don't know much about these things. I can post some screenshots of my settings though. But there is not many things one can set up. Now it appears to me that OSX needs user and pass account to let you through. Oleg does not offer that option...

    Thank you for reply!

  4. #4

    same problem

    I have the exact same problem and would very much like to know how to solve this. :/

  5. #5
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    if you need login things, you should install samba 2 according to wengi's howto I think (look in the WL-500gP part of these forums).

    I'm not known with apple things, since I dont like them
    so I can't help you mutch out I'm afraid

    there are some other guys who had this problem and managed to fix it... searching the forums might give some good results

  6. #6
    to fix the login issue with the Mac, in /etc/smb.conf change "encrypt password = no" to "yes".

    My problem is changes to smb.conf are not surviving the reboot of the router. I added smb.conf to /usr/local/.files as oleg explains on his homepage, but I continue to lose the change to encrypt password. Must be something unique in my setup such that .files is not working... any ideas?

  7. #7
    Join Date
    Mar 2007
    Location
    Milano - Italy
    Posts
    164
    Quote Originally Posted by cMcd01 View Post
    My problem is changes to smb.conf are not surviving the reboot of the router.
    Did you save it in the internal flash ?

    Code:
    flashfs save && flashfs commit && flashfs enable && reboot
    With Samba2 installed, no problems accessing USB storage from Win/Mac/Linux machines.

    Max

  8. #8
    Quote Originally Posted by QMax View Post
    Did you save it in the internal flash ?

    Code:
    flashfs save && flashfs commit && flashfs enable && reboot
    Max
    Yes. I've executed that series of commands to save to flash. And I believe I've followed Oleg's instructions (http://oleg.wl500g.info/#tips) correctly for saving smb.conf locally - .files shows:
    Code:
    cat /usr/local/.files
    /etc/fstab
    /etc/smb.conf
    It seems like smb.conf is being re-written after reboot after load of flashfs (assuming flashfs is being loaded).

  9. #9
    I think that what is happening is that you have the smb enabled via the web and thus it is rewriting the smb.conf based on the web configured options and the unwanted default for encrypt passwords.

    1 - disable the samba on the web gui (USB application->samba->disabled)
    2 - login to wl and create the desired smb.conf under /usr/local/etc/smb.conf (you may just cp /etc/smb.conf /usr/local/etc/smb.conf and fix the "encrypt passwords = yes"
    3 - edit the file /usr/local/sbin/post-boot and add the two smbd/nmbd lines, it may look like:

    Code:
    #!/bin/sh
    /usr/sbin/smbd -D -s /usr/local/etc/smb.conf
    /usr/sbin/nmbd -D -s /usr/local/etc/smb.conf
    4 - flashfs save && flashfs commit && flashfs enable
    5 - reboot the router

    Note that if you want to customize the shares you can't use the web anymore, just go and edit the /usr/local/etc/smb.conf as needed

Similar Threads

  1. Custom 1.0.7.8 firmware is ready to download
    By kfurge in forum WL-700g Firmware Discussion
    Replies: 173
    Last Post: 26-04-2008, 17:08
  2. Transmission Log Files löschen ?
    By Simond in forum German Discussion - Deutsch (DE)
    Replies: 3
    Last Post: 12-09-2007, 13:16
  3. connection guard on an WL500g-XXXXX
    By rj.2001 in forum WL-500g/WL-500gx Tutorials
    Replies: 0
    Last Post: 03-05-2007, 11:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •