Page 3 of 7 FirstFirst 12345 ... LastLast
Results 31 to 45 of 102

Thread: XMail & MTA POP3 - почтовый сервер на роутере

  1. #31
    Join Date
    Feb 2008
    Location
    Украина Запорожье
    Posts
    351

    Cool

    Quote Originally Posted by diesel7 View Post
    8. запускаем MkUsers -a 1 -d domainname -u UserName -r ./ -s 10000 -m
    ( MkUser создает пользователя и почтовый ящик)
    при создании так - пользователь получается UserName1
    пробовал переименовывать UserName папку и в mailusers.tab
    при отправке письма на этот адрес - пишет что пользователь не создан!
    как создать пользователя без этой 1?

    уже 2е сутки с mailusers.tab парюсь!
    не работает все что прописываю...
    только 1 ящик...логин которому портит цифра 1 при создании
    т.е. создавал логин maxya а получился maxya1

    помогите пожалуйста с созданием пользователей и желательно на разные домены!

    Чтобы присоединится к серверу и нормально создать аккаунты

    правим ctrlaccouts.tab
    в этот файл вносим логин админа и пароль который получаем по команде XMCrypt ,
    например $ XMCrypt parolik
    1504170a090c0e

    и вносим пароль_админа<tab>1504170a090c0e(это наш хэш)<newline>

    перегружаем сервак Xmail

    подключаемся phpxmail используя наш логин и пароль
    Last edited by Omega; 20-04-2011 at 18:27. Reason: 2 post merged
    устройство должно решать проблема - а не создавать их!
    WL-500W, WRT610N v2 + WD 250Gb 2.5" Отправка смс + шаринг на openbox x730
    TwonkyMedia + dbhub_0.450 + lighttpd+ssl+auth + dlengine + NOD32 update server
    Огромный респект Олегу и vectorm

  2. #32
    Люди!!! На коленях сейчас стою! прошу, помогите кто нибудь настроить xmail или senmail .

  3. #33
    Join Date
    Jan 2009
    Location
    Kazan, Russia
    Posts
    1,162
    Quote Originally Posted by autoelektrik View Post
    Люди!!! На коленях сейчас стою! прошу, помогите кто нибудь настроить xmail или senmail .
    Я написал тебе в твоей теме.
    Asus RT-AC66U, Xerox Phaser 3160B, on the shelf RT-N16 (Killed by lightning)
    WL-500gPv1 128MB, WL-500W 300MHz/128M, LCD 40x4, DIR-320 8Mb/64MB
    WL-700g 128MB, MNV25E2+ and more and more devices. provod.beeline.ru

    -------------------------------------------
    Computers. Since 1984. First one - "МИР-1"

  4. #34
    Join Date
    Apr 2009
    Location
    г. Ангарск, Иркутская обл.
    Posts
    267
    Quote Originally Posted by autoelektrik View Post
    Люди!!! На коленях сейчас стою! прошу, помогите кто нибудь настроить xmail или senmail .
    я вот так делал:

    ipkg install esmtp

    esmtprc
    # это файл конфигурации положить в /opt/etc
    identity = name@mail.ru # адрес отправителя
    hostname = smtp.mail.ru:25 # smtp сервер : порт
    username = "username" # имя пользователя
    password = "password" # пароль


    Пример:
    echo "Test Message" | sendmail Petr@mail.ru
    DIR-320 / WL-500gPv2 / O'Play R1

  5. #35
    Join Date
    Jul 2008
    Location
    Kyiv, Ukraine
    Posts
    123
    Может быть кто-нибудь сталкивался с такой проблемой?
    1. Есть внешний IP
    2. На внешний IP припаркован домен xxxxxxxxx.net. Провайдеры, которые поддерживают домен и IP, разные.
    3. Установлены Xmail 1.25 и phpxmail.
    4. Почта внутри локальной сети ходит без проблем.
    5. Почта на внешние адреса тоже доходит.
    6. по команде telnet xxxxxxxxx.net 110 сервер POP3 отвечает, и пускает юзера по логину "v" и паролю, показывает наличие почты.
    Проблема: Не доходит внешняя почта на v@xxxxxxxxx.net.

    Quote Originally Posted by колбаскин View Post
    уже 2е сутки с mailusers.tab парюсь!
    не работает все что прописываю...
    только 1 ящик...логин которому портит цифра 1 при создании
    т.е. создавал логин maxya а получился maxya1

    помогите пожалуйста с созданием пользователей и желательно на разные домены!
    У меня так тоже получалось. Если логин, который Вы хотите создать, совпадает с логином администратора почтового сервера, Xmail дописывает "1".

    Похоже проблема с получением почты в firewallе. В логе нашел строку:
    Jan 26 22:33:43 kernel: DROP IN=vlan1 OUT= MAC=00:1e:8c:d9:e6:d4:00:e0:81:79:dc:c0:08:00:45:0 0:00:3c SRC=94.100.176.59 DST=91.195.ххх.ххх LEN=60 TOS=0x00 PREC=0x00 TTL=52 ID=26776 DF PROTO=TCP SPT=43003 DPT=25 SEQ=3048447340 ACK=0 WINDOW=5840 RES=0x00
    94.100.176.59 - адрес почтовика mail.ru, с которого отправлялась почта. Кто-нибудь знает, как решить эту проблему?
    iotables -I INPUT -p tcp --drop 110 -j ACCEPT не помогает.
    Last edited by Omega; 20-04-2011 at 18:29. Reason: 2 post merged
    RT-N16, SSD-60, lighttpd, Mysql, Squid 2.7, Xmail, Openvpn, bind, Dreambox 500 + WL500gpV2 (OpenWRT) IPsec

  6. #36
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    Quote Originally Posted by YVM View Post
    iotables -I INPUT -p tcp --drop 110 -j ACCEPT не помогает.
    Как бы ээээээ ????
    Киньте свой IP в личку - скажу, открыт порт или нет.
    И если сами себе снаружи письмо шлете - какой ответ получаете?

  7. #37
    может ктонить помочь разобраться с проблемой?
    Я установил и вроде бы как правильно настроил xmail,и вроде даже отправляет почту,но почему-то не хочет принимать почту(отвечает сообщениями о нехватке места на сервере(552)),хотя место есть,разрешения на папки стоят и в файлике настройки прописано ограничение на гигабайт.Еще есть проблема с тем что phpxmail отказывается создавать новых пользователей с сообщением что не может создать папку.

  8. #38
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    Quote Originally Posted by rfxDarth View Post
    может ктонить помочь разобраться с проблемой?
    Я установил и вроде бы как правильно настроил xmail,и вроде даже отправляет почту,но почему-то не хочет принимать почту(отвечает сообщениями о нехватке места на сервере(552)),хотя место есть,разрешения на папки стоят и в файлике настройки прописано ограничение на гигабайт.Еще есть проблема с тем что phpxmail отказывается создавать новых пользователей с сообщением что не может создать папку.
    Прав ему не хватает на папки.

  9. #39
    Quote Originally Posted by vectorm View Post
    Прав ему не хватает на папки.
    а можно по конкретнее?я уже все что мог перепробовал,гуглил пару часов,пробовал chmod мучать,пробовал все переставлять,создавать юзеров при помощи MkUsers....не помогает

  10. #40
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    Quote Originally Posted by rfxDarth View Post
    а можно по конкретнее?я уже все что мог перепробовал,гуглил пару часов,пробовал chmod мучать,пробовал все переставлять,создавать юзеров при помощи MkUsers....не помогает
    Вообще не вижу сложностей в настройке.
    По своей же инструкции несколько раз настраивал - никто не жаловался, и проблем не видел.

  11. #41
    Join Date
    Jul 2008
    Location
    Kyiv, Ukraine
    Posts
    123
    Quote Originally Posted by vectorm View Post
    Как бы ээээээ ????
    Киньте свой IP в личку - скажу, открыт порт или нет.
    И если сами себе снаружи письмо шлете - какой ответ получаете?
    Спасибо за помощь. Дело в моей небрежности. --drop не совсем --dport
    RT-N16, SSD-60, lighttpd, Mysql, Squid 2.7, Xmail, Openvpn, bind, Dreambox 500 + WL500gpV2 (OpenWRT) IPsec

  12. #42
    Join Date
    Mar 2011
    Location
    Moscow
    Posts
    2

    Question Не работает веб-морда phpXmail! 404

    Люди, не ругайте сильно, с никсами еще на ВЫ, так что разбираюсь по ходу...
    Поставил phpXmail, сам сервак поднялся, проверял PortQry.

    PHP Code:
    Querying target system called:
    *
    * ***.
    dyndns.org
    *
    Attempting to resolve name to IP address...
    *
    Name resolved to ххх.ххх.ххх.ххх
    *
    querying...
    *
    TCP port 25 (smtp service): LISTENING
    *
    Data returned from port:
    220 xmailserver.test <1299865451.15373@xmailserver.test> [XMail 1.25 ESMTP Serverservice readyFri11 Mar 2011 20:44
    :11 +0300


    Querying target system called
    :
    *
    * ***.
    dyndns.org
    *
    Attempting to resolve name to IP address...
    *
    Name resolved to ххх.ххх.ххх.ххх
    *
    querying...
    *
    TCP port 110 (pop3 service): LISTENING
    *
    Data returned from port:
    +
    OK <1299865493.18445@xmailserver.test> [XMail 1.25 POP3 Serverservice readyFri11 Mar 2011 20:44:53 +0300 
    Делал по этому ману... запоролся на 5 шаге, где заходим на веб-рожу... выдает в ответ 404 и все ((((((
    Нашел обсуждение по неработающему PHP-fcgi... но вроде пашет (как точно проверить?)
    lighttpd точно пашет, веб страничка тестовая работает на 80 порту )
    Права на папку /opt/share/www/lighttpd/phpxmail 755, ставил и 777, в бестолку...
    Выложу все необходимые логи и конфиги
    ЗЫ Если что не так, сильно не бейте, особенно ногами и по лицу ))))))))
    ЗЫЫ Роутер ASUS WL-500gP V2, прошива последняя... подмонтирован хард по USB как /opt ввиде папки (ФТП и сетевой доступ)
    Last edited by SysF; 11-03-2011 at 19:28.
    SysF aka SystemFailure

  13. #43
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    Quote Originally Posted by SysF View Post
    Делал по этому ману... запоролся на 5 шаге, где заходим на веб-рожу... выдает в ответ 404 и все ((((((
    Нашел обсуждение по неработающему PHP-fcgi... но вроде пашет (как точно проверить?)
    lighttpd точно пашет, веб страничка тестовая работает на 80 порту )
    Права на папку /opt/share/www/lighttpd/phpxmail 755, ставил и 777, в бестолку...
    Покажите свой lighttpd.conf
    У меня подозрение, что как обычно, не смотрите соответствие конфигов и папок.
    Переложите файлы в /opt/share/www/phpxmail/
    И заходите на http://my.router/phpxmail/

  14. #44
    Join Date
    Mar 2011
    Location
    Moscow
    Posts
    2
    Quote Originally Posted by vectorm View Post
    Покажите свой lighttpd.conf
    У меня подозрение, что как обычно, не смотрите соответствие конфигов и папок.
    Переложите файлы в /opt/share/www/phpxmail/
    И заходите на http://my.router/phpxmail/
    Переложил в www директорию и сразу запахало! Но как так то??? index.html страничка то пашет из дериктории \opt\share\www\lighttpd , прям не пойму...
    Да, поменял на
    PHP Code:
    server.document-root        "/opt/share/www/lighttpd/" 
    и сразу заработало, но потом поменял назад и перенес в www, чтобы все остальное не переносить! СПАСИБО!!!

    Хех ) Задал имя серва localhost, IP роутера, логин и пасс указал тот, что делал при установке...
    В итоге создало, пытаюсь войти, страница обновляется и опять по новой... где-то про это уже писали, что на какие-то папки не хватает прав доступа... теперь найти не могу... На какие папки и какой доступ давать? HELP )))
    ЗЫ mail.log пустой...
    Attached Files Attached Files
    Last edited by Omega; 20-04-2011 at 18:19. Reason: 2 post merged
    SysF aka SystemFailure

  15. Quote Originally Posted by SysF View Post
    Хех ) Задал имя серва localhost, IP роутера, логин и пасс указал тот, что делал при установке...
    В итоге создало, пытаюсь войти, страница обновляется и опять по новой... где-то про это уже писали, что на какие-то папки не хватает прав доступа... теперь найти не могу... На какие папки и какой доступ давать? HELP )))
    ЗЫ mail.log пустой...
    Столкнулся с такой же проблемой, думал дело в пароле что создал, перепробовал все возможные варианты, но так и не решил!
    Подскажите кто справился с данной бедой?

Page 3 of 7 FirstFirst 12345 ... LastLast

Similar Threads

  1. MySQL-сервер на роутере
    By Boiler in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 138
    Last Post: 19-06-2014, 19:25
  2. Quake2, CS, Minecraft и PvPGN (battle.net) сервер на роутере?
    By GearST in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 47
    Last Post: 04-03-2014, 15:54
  3. Можно ли поднять на роутере сервер FireBird ?
    By Kuzav in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 17
    Last Post: 19-02-2013, 06:20
  4. VPN сервер на WL-500gP
    By Coolty in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 154
    Last Post: 22-01-2013, 02:41
  5. IRC или другой чат сервер на роутере WL-500gP
    By gaaronk in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 36
    Last Post: 29-12-2012, 11:38

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •