Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 54

Thread: Периодические задержки на ping-e

  1. #31
    Join Date
    Jan 2008
    Location
    Russia, Moscow
    Posts
    17

    Возникающие задержки.

    Используется WL-500g.Premium в качестве Home-gateway.
    Подключено 2 компа, один по Wi-Fi второй по шнурку.
    WAN Connection Type:PPTP
    Ну вообщем ВПН-канал и Локальная сеть провайдера открыта для доступа с обоих компов. Включена опция Assign IP Address Manually. Прописал МАК-ам соответствующие адреса.

    Происходит следующее. При игре в любые он-лайн игры, ping ведет себя как подобает (как вел и до подключения роутера вообще), но иногда (примерно раз в 10-15 секунд) бывают моментальные скачки. То есть даже показатель пинга прыгает совсем ненамного, но явно чувствуется задержка (лаг). Через полсекунды все снова работает как часы.

    Что так может влиять на задержку? Проверял - без роутера все в порядке. Даже если второй компьютер выключен - проблема остается.
    Какие процессы могут давать такие постоянные моментальные задержки?
    Может быть нужно изменить какие-то параметры?

    Извеняюсь, если вопрос неправильно сформулирован, обьяснил как только смог. Надеюсь на вашу помощь!

  2. #32
    Join Date
    Jan 2008
    Location
    Russia, Moscow
    Posts
    17
    А еще в логе после коннекта происходит следующее:
    Code:
    Jan  1 03:00:10 PPTP: connect to ISP
    Mar  5 21:54:17 ntp client: Synchronizing time with time.nist.gov ...
    Mar  5 21:54:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Request received.
    Mar  5 21:54:58 pptp[121]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply' 
    Mar  5 21:55:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Request received.
    Mar  5 21:55:58 pptp[121]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply' 
    Mar  5 21:55:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    Mar  5 21:56:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    Mar  5 21:57:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Request received.
    Mar  5 21:57:58 pptp[121]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply' 
    Mar  5 21:57:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    Mar  5 21:58:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Request received.
    Mar  5 21:58:58 pptp[121]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply' 
    Mar  5 21:58:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    Mar  5 21:59:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Request received.
    Mar  5 21:59:58 pptp[121]: anon log[ctrlp_rep:pptp_ctrl.c:251]: Sent control packet type is 6 'Echo-Reply' 
    Mar  5 21:59:58 pptp[121]: anon log[logecho:pptp_ctrl.c:670]: Echo Reply received.
    Mar  5 21:59:58 pptp[121]: anon log[logecho:pptp_ctrl.c:672]: no more Echo Reply/Request packets will be reported.
    Так и должно быть?

  3. #33
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    В логе обычная диагностика.

    Подключение проводное?

  4. #34
    Join Date
    Jan 2008
    Location
    Russia, Moscow
    Posts
    17
    Да, такие проблемы возникают и при Wi-Fi соединении, и при соединении по Ethernet..

    Первый шлюз провайдера, после роутера пингуется так..

    Code:
    C:\Documents and Settings\de Mont de Rique>ping 192.168.13.4 -t
    
    Pinging 192.168.13.4 with 32 bytes of data:
    
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=8ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=17ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=12ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=13ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=15ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=15ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=21ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=19ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=2ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=17ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=9ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=22ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=18ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=3ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time<1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=2ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time<1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=137ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=141ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=3ms TTL=254
    Reply from 192.168.13.4: bytes=32 time=1ms TTL=254
    Роутер пингуется без потрерь с time<1ms.

    Может все-таки что-то с провайдером не то? Сейчас пытаюсь выяснить.

  5. #35
    Join Date
    Jan 2008
    Location
    Russia, Moscow
    Posts
    17
    Все- таки проблема не у провайдера. При выключении второго компьютера фишка остается, но куда меньше. Почти все нормально становится.

    Так что видимо проблема именно в одновременной работе 2 компов.

    Возможно как либо 1 компьютер сделать преобладающим, что бы второй не достовлял таких помех? Я ставил NetLimiter и просто урезал канал на 2ом компе, но это не помогает. Проблема с пингом остается.

  6. #36

    Задержки при форвардинге больших пингов

    Роутер Asus WL500g Premium v1 соединён с провайдером напрямую без использования различных vpn...

    Решил протестировать данную железку на предмет задержек при прохождении больших пакетов.

    В результате оказалось, что большие пакеты почему-то задерживаются в роутере на время ~8мс.
    Т.е. большой пакет проходит такой маршрут LAN -> роутер(задержка 8мс) -> шлюз провайдера.

    Как тестировал:

    1) Ping LAN (PC) -> WAN (шлюз провайдера):

    ping 84.47.161.129 -l 25000
    Обмен пакетами с 84.47.161.129 по 25000 байт:
    Ответ от 84.47.161.129: число байт=25000 время=14мс TTL=63
    Ответ от 84.47.161.129: число байт=25000 время=15мс TTL=63
    Ответ от 84.47.161.129: число байт=25000 время=14мс TTL=63
    Ответ от 84.47.161.129: число байт=25000 время=14мс TTL=63

    2) Ping LAN (PC) -> Asus WL500g Premium:

    ping 192.168.100.1 -l 25000
    Обмен пакетами с 192.168.100.1 по 25000 байт:
    Ответ от 192.168.100.1: число байт=25000 время=7мс TTL=64
    Ответ от 192.168.100.1: число байт=25000 время=7мс TTL=64
    Ответ от 192.168.100.1: число байт=25000 время=7мс TTL=64
    Ответ от 192.168.100.1: число байт=25000 время=7мс TTL=64

    3) WAN (шлюз провайдера) -> Asus WL500g Premium:

    PING 84.47.161.xx (84.47.161.xx): 25000 data bytes
    25028 bytes from 84.47.161.xx: icmp_seq=0 ttl=64 time=9.6 ms
    25028 bytes from 84.47.161.xx: icmp_seq=1 ttl=64 time=10.3 ms
    25028 bytes from 84.47.161.xx: icmp_seq=3 ttl=64 time=10.9 ms
    25028 bytes from 84.47.161.xx: icmp_seq=4 ttl=64 time=11.1 ms

    4) Asus WL500g Premium -> WAN (шлюз провайдера):
    PING 84.47.161.129 (84.47.161.129): 25000 data bytes
    25028 bytes from 84.47.161.129: icmp_seq=0 ttl=64 time=10.6 ms
    25028 bytes from 84.47.161.129: icmp_seq=1 ttl=64 time=10.9 ms
    25028 bytes from 84.47.161.129: icmp_seq=3 ttl=64 time=10.7 ms
    25028 bytes from 84.47.161.129: icmp_seq=4 ttl=64 time=11.8 ms

    Тесты на разогнанном процессоре и памяти аналогичные.

    При подключении к WAN интерфейсу ноутбука с IP шлюза провайдера пинги были практически аналогичны.

    Пробывал разные прошивки: от Асуса, от Олега и даже OpenWRT.

    Какие будут предложения по оптимизации?


    Для сравнения: в моём предыдущем роутере Dlink DI-624 подобных задержек при прохождении больших пингов не было.
    Т.е. было так LAN -> роутер(задержка ~1-2мс) -> шлюз провайдера.

    Ping LAN (PC) -> WAN (шлюз провайдера):

    ping 84.47.161.129 -l 25000
    Обмен пакетами с 84.47.161.129 по 25000 байт:
    Ответ от 84.47.161.129: число байт=25000 время=8мс TTL=63
    Ответ от 84.47.161.129: число байт=25000 время=9мс TTL=63
    Ответ от 84.47.161.129: число байт=25000 время=9мс TTL=63
    Ответ от 84.47.161.129: число байт=25000 время=9мс TTL=63

    И это не смотря на то, что длинк гораздо слабее Асуса...

  7. #37
    Уважаемые форумчане, тут задавался вопрос про "живучесть" интернета, вот случайно нашел эту тему форума, проблемы вроде схожие.
    Вопрос остается в силе: кто силен в командном интерпретаторе, подскажите живой пример проверки пингом интернета. Очень надо! Спасибо.

  8. #38

    Exclamation Периодические задержки на ping-e

    Роутер Premium V1.
    10-я прошивка от Олега.

    Настройки особо не ковырял, так, закрыл порты, пробросил нужные (Firewall), поставил dropbear, USB подмонтировал.
    Ничего заковыристого.

    Обратил внимание, что когда я со свего компа, подключенного по WiFi (карточка PCI Eusso) пингую устройство, подключенное проводом к самому роутеру (Teac NAS 400Gb, винт), то, примерно, каждую минуту задержки при пинге могут составлять до 1800ms.

    В промежутках между этими моментами пингуется хорошо - 5-8ms

    Такая же картина и при пинге другого WiFi компа.
    Роутер и комп находятся в другой комнате через 2 стенки.

    Кажется, какие-то намеки я видел здесь,

    http://wl500g.info/showthread.php?t=14753

    но хотелось бы как-то понять в чем дело.
    Какие идеи?

    Заранее - спасибо!

  9. #39
    Quote Originally Posted by Dimedrol View Post
    Роутер Premium V1.
    10-я прошивка от Олега.

    Настройки особо не ковырял, так, закрыл порты, пробросил нужные (Firewall), поставил dropbear, USB подмонтировал.
    Ничего заковыристого.

    Обратил внимание, что когда я со свего компа, подключенного по WiFi (карточка PCI Eusso) пингую устройство, подключенное проводом к самому роутеру (Teac NAS 400Gb, винт), то, примерно, каждую минуту задержки при пинге могут составлять до 1800ms.

    В промежутках между этими моментами пингуется хорошо - 5-8ms

    Такая же картина и при пинге другого WiFi компа.
    Роутер и комп находятся в другой комнате через 2 стенки.

    Кажется, какие-то намеки я видел здесь,

    http://wl500g.info/showthread.php?t=14753

    но хотелось бы как-то понять в чем дело.
    Какие идеи?

    Заранее - спасибо!
    А просто если ping 192.168.1.1?
    У меня <1ms а иногда =1ms

  10. #40
    Хммм.... в общем-то такая же картина:

    Code:
    ...
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=1640ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=12ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64
    Reply from 192.168.1.1: bytes=4096 time=4ms TTL=64 
    ...

  11. #41
    Join Date
    Feb 2008
    Location
    Moscow, Tver
    Posts
    3,962
    У вас скрипты не выполняются каждую минуту? (/opt/etc/cron/1.min)

  12. #42
    У меня даже каталога такого нет - "/opt/etc/cron"

  13. #43
    Какие-то еще идеи?

  14. #44
    Quote Originally Posted by Dimedrol View Post
    Какие-то еще идеи?
    У тебя нормальный пинг при размере пакета 4096, у меня тоже самое бывает, не забывай что это wi-fi, и те 1640мс может быть результатом отражённого сигнала, и последующего перезапроса пакета. у меня такое даже было когда я поднимал WDS на 2 точках 320gE, так и то клиент периодически вылетал из 1с пришлось ему витуху тянуть через этаж.

  15. #45

    PING больше секунды

    Здравствуйте.
    Примерно пол года использую последнюю прошивку от Олега на 500GP.
    Очень доволен.
    Сегодня поставил дома новый комп - KraftWay Urban, который изначально ориентировал на торенты. Вирант достаточно хороший - Core2 + 2Gb RAM WIFI.
    Вот только с ним начались проблемы в сети. При запускке uTorrent - пинг по WiFi становится больше секунды. В сети в этот момоент только Крафт и ноутбук, который ничего не делает....
    uptime - показывает практически ноль использования процессора.

    Подскажите куда копать..

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Vlan configuration with Kamikaze 7.09
    By asle_500g in forum WL-500gP Q&A
    Replies: 0
    Last Post: 07-12-2007, 10:56

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •