Results 1 to 3 of 3

Thread: wget problem - content-length is garbage - cannot install packages

  1. #1

    Unhappy wget problem - content-length is garbage - cannot install packages

    Hi everybody,

    I've got a problem that is making me nuts:

    I cannot use wget because it produces a content-length error. It is used from ipkg so I cannot install any package.

    Code:
    [admin@WL-0022152250A5 root]$ ipkg install samba2
    Installing samba2 (2.2.12-1) on root...
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/samba2_2.2.12-1_mipsel.ipk
    wget: content-length 437       is garbage
    Nothing to be done
    An error ocurred, return value: 22.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-yTplGG http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/samba2_2.2.12-1_mipsel.ipk'
    Failed to download samba2. Perhaps you need to run 'ipkg update'?
    [admin@WL-0022152250A5 root]$
    Of course I did ipkg update already before trying to install samba2. I also tried to use a clean oleg installation with factory defaults and only UMTS-modem configuration.

    I'm using 1.9.2-10-170a from oleg and a E220 Huawei. I tried to fix the problem the whole day. Twice it worked, but I forgot to save to flash so I need to reinstall. Oleg's Samba in "USB Application" does not work so that I could copy the installation files or a new wget to the stick.

    I searched in the forum and found one thread where it was said that reinstalling wget could help. Once ipkg install wget worked but it didn't fix the problem.

    Pleeeeease help me!

  2. #2
    Hello,

    I have the same Problem here - Googeling found someething like reinstall wget..
    Don't know how..
    Did you solve it?

  3. #3
    Quote Originally Posted by Transalpler View Post
    Hello,

    I have the same Problem here - Googeling found someething like reinstall wget..
    Don't know how..
    Did you solve it?
    ipkg update
    ipkg remove wget
    ipkg install wget

Similar Threads

  1. problem while trying to install lighttpd
    By ovidiupys in forum WL-500gP Q&A
    Replies: 8
    Last Post: 13-02-2008, 11:19
  2. problem with installing optware packages
    By pico in forum WL-700g Q&A
    Replies: 7
    Last Post: 02-12-2007, 10:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •