Page 7 of 8 FirstFirst ... 5678 LastLast
Results 91 to 105 of 107

Thread: Не работает php-fcgi

  1. #91
    Join Date
    Jul 2008
    Location
    Spb
    Posts
    26
    rtfm http://redmine.lighttpd.net/wiki/lig...cs:ModAuth#id3 конфиг SSL ?

    When completed, enable the authentication configuration module. The way to enable the module varies from different distributions.

    Limitations
    The implementation of digest method is currently not completely compliant with the standard as it still allows a replay attack. (i.e. not secure)
    LDAP authentication only allows alphanumeric uid's that do not contain punctuations. i.e.) john.doe will come up as "ldap: invalid character
    (a-zA-Z0-9 allowed) in username: john.doe" There seems to be no reasonable logging of failed login attempts yet
    As of 1.4.19 the group field inside the require directive is not yet implemented. So auth.backend.plain.groupfile is of no use at this moment.
    When loaded together with mod_fastcgi, mod_auth must be loaded before mod_fastcgi. Or else users will experience
    long delays when login in and sysadmins will probably not find out the source of the problem due to the lack of meaningful error messages.
    Last edited by Omega; 25-07-2012 at 18:14. Reason: fixed

  2. #92

    \_ [php-fcgi] <defunct>

    Может кому-то поможет.

    Если вы получаете в списке процессов \_ [php-fcgi] <defunct>, то это могут быть результаты экспериментов с MySQL, надо убрать mysql.ini с папки /opt/etc/php.d или исправить ошибки.

  3. #93
    Была такая проблема. php-fcgi -v показал, что не хватает двух пакетов. Установил php-curl и php-mbstring. Все заработало.

  4. #94

    Как включить mbstring и curl в связке lighttpd+php-fcgi?

    Привет, ребят. Я пишу всякие скрипты для php, и в этот раз мне понадобились curl и mbstring, но в стандартной связке lighttpd и php-fcgi их нету. Скажите, как их поставить?

  5. #95
    Join Date
    Mar 2011
    Location
    Moscow
    Posts
    243
    Quote Originally Posted by Astrden View Post
    Привет, ребят. Я пишу всякие скрипты для php, и в этот раз мне понадобились curl и mbstring, но в стандартной связке lighttpd и php-fcgi их нету. Скажите, как их поставить?
    Code:
    ipkg install php-curl
    ipkg install php-mbstring
    не?

  6. #96
    Quote Originally Posted by don-pedro View Post
    Code:
    ipkg install php-curl
    ipkg install php-mbstring
    не?
    В том то и дело, что не работает так.

  7. #97
    Join Date
    Jan 2010
    Location
    Kharkov, Ukraine
    Posts
    60
    а если перед этими командами сначала выполнить:
    Code:
    ipkg update
    ?

    Ну, и, конечно же, лог ошибок в студию. Без него Вам никто не сможет помочь.
    WL-500gP v2 (1.9.2.7-rtn-r4772) / rTorrent 0.9.3 / ruTorrent 3.4
    ImageVue r16 (patched) / lighttpd + ssl + auth
    WDTV Gen1 / WDLXTV 0.5.8.1 / D-Link DWA-110 WiFi
    WDTV Live / WDLXTV 0.4.7.3 / WDTV Live Hub

  8. #98
    Поставил вебCMC Sawanna 3.4.0 все работает кроме вставки изображений
    в тех поддержка саваны говорят что PHP должен быть не ниже 5.4
    У меня все установлено валериным скриптом в нем PHP Version 5.2.17
    Как установить более новую и где ее взять?
    WL500W-1.9.2.7-d-r2624

  9. #99
    Quote Originally Posted by _Alexander_ View Post
    Поставил вебCMC Sawanna 3.4.0 все работает кроме вставки изображений
    в тех поддержка саваны говорят что PHP должен быть не ниже 5.4
    У меня все установлено валериным скриптом в нем PHP Version 5.2.17
    Как установить более новую и где ее взять?
    "не ниже 5.4" - это весело. Из 5.4 ветки зарелизился только 5.4.0, довольно сырая и глючноватая версия.
    Софт, требующий наиновейших версий другого софта - это плохой показатель.

  10. #100
    Quote Originally Posted by dimez View Post
    "не ниже 5.4" - это весело. Из 5.4 ветки зарелизился только 5.4.0, довольно сырая и глючноватая версия.
    Софт, требующий наиновейших версий другого софта - это плохой показатель.
    Я перепутал 5.3...
    У производителя все в порядке, скорее это в скрипте ошибки. Такая ошибка только у тех кто устанавливал скриптом. Еще сайт через PHP не шлет письма...
    Last edited by _Alexander_; 18-04-2012 at 15:06.
    WL500W-1.9.2.7-d-r2624

  11. #101
    Так что, не кто не собрал пакет выше чем PHP Version 5.2.17 для наших машинок?
    WL500W-1.9.2.7-d-r2624

  12. #102
    У кого-нибудь получилось завести nginx совместно с php?

    Наверное, уже все перепробовал, всегда получаю "No input file specified."

  13. #103
    Join Date
    Oct 2009
    Posts
    529
    Blog Entries
    1
    Quote Originally Posted by desper View Post
    У кого-нибудь получилось завести nginx совместно с php?

    Наверное, уже все перепробовал, всегда получаю "No input file specified."
    У меня получилось.
    Last edited by MercuryV; 25-07-2012 at 23:19. Reason: prooflink

  14. #104
    Quote Originally Posted by _Alexander_ View Post
    Так что, не кто не собрал пакет выше чем PHP Version 5.2.17 для наших машинок?
    В транке OpenWRT сегодня обновили php до 5.4.5, поэтому появление его в нашем репозитории в начале следующего месяца просто неизбежно

  15. #105
    Quote Originally Posted by MercuryV View Post
    Спасибо!
    я не закомментировал строку

    Code:
    fastcgi_param  SCRIPT_NAME        $fastcgi_script_name;
    вот и не взлетало...

Page 7 of 8 FirstFirst ... 5678 LastLast

Similar Threads

  1. Установка и настройка vnStat + vnStat PHP frontend
    By VoVuX in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 219
    Last Post: 16-10-2015, 14:37
  2. How to execute php scripts ?
    By simistef in forum WL-500gP Q&A
    Replies: 13
    Last Post: 11-03-2008, 10:35
  3. PHP on ASUSWL500-G Premium
    By simistef in forum WL-500gP Q&A
    Replies: 1
    Last Post: 20-02-2008, 19:44
  4. WL-500gP vs WPA не работает.
    By neo in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 2
    Last Post: 03-02-2008, 14:36

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •