Results 1 to 3 of 3

Thread: HDD Spindown problem

  1. #1

    HDD Spindown problem

    Ive upgraded the kc firmware and im very happy with it. MLdonkey works great with sancho and im very satisfied with it. But now im not sure if hdd spindown works properly.

    As i said, i upgraded to the latest (2) firmware. But now i think the hdd spindown doesnt work anymore. If nothing is attached to the router (pc or anyting) i hear a tick coming from the wl. But if i put my ear to the wl, is still hear the hdd spinning.
    To disable HDD spindown feature (version 02 and later)

    I tried this:

    Telnet or ssh to the router
    Gain root access
    Type "nvram set kc_spin_down_hdd=Yes". This is case sensitive; "no" will not work.
    Type "nvram commit"
    Restart the router

    But i didnt work. I still hear a zooming noise and two times an hour i hear the ticking sound. Ive killed the ml donkey core.
    Who can help?
    Im not not great in (linux) linux commands. So please keep the awnsers a little easy for me.
    tnx in advance.
    Woffels

    "The tonights course "How to deal with disappointment" will ,unfortunately, not take place!!!!"

  2. #2

    rc.local

    This is how my.rc local looks like. It is in opt/etc

    #!/opt/bin/bash

    export PATH=/opt/bin:/opt/sbin:/bin:/sbin:/usr/bin:/usr/sbin
    export LD_LIBRARY_PATH=/opt/lib:/apps/lib:/apps/usr/gift-nasoc/lib
    export KCSHELL=/opt/bin/bash

    #############
    # Get nvram variables
    #############
    pool=`nvram get apps_pool`
    share=`nvram get apps_share`
    kc_spin_down_hdd=`nvram get kc_spin_down_hdd`

    #############
    # Misc defines
    #############
    internal_hdd=/dev/ide/host2/bus0/target0/lun0/disc

    #############
    # These items only run once at power up
    #############
    if [ ! -f /tmp/rc.local.done ]; then

    - rc.local 1/65 1%

  3. #3
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    35
    Hi,
    the problem is: your "rc.local" doesn't boot. I have the same Problem. I solve it so:
    • you use a correct rc.local with this option: http://wl700g.homelinux.net/portal/content/view/22/28/
    • you make "chmod 755 /opt/etc/rc.local"
    • then start it with "/opt/etc/rc.local"
    • then everytime the router boot you start telnet or ssh and start this "/opt/etc/rc.local", so you start it manual


    I hope it helps you!

    Joe

Similar Threads

  1. Problems with hdd spindown og rc.local
    By ashansen in forum WL-700g Q&A
    Replies: 27
    Last Post: 29-01-2009, 23:01
  2. ASUS WL-500gP + USB HDD problem
    By nsec in forum WL-500gP Tutorials
    Replies: 4
    Last Post: 21-04-2008, 08:04
  3. WL700gE_kc_1078_02.nas spindown problem
    By altime in forum WL-700g Firmware Discussion
    Replies: 2
    Last Post: 05-03-2008, 21:39
  4. wl-500w festplatte hdd problem
    By underdog-ma in forum WL-500w Q&A
    Replies: 0
    Last Post: 12-12-2007, 21:36
  5. USB HDD - problem
    By m-roman in forum WL-500gP Q&A
    Replies: 1
    Last Post: 28-09-2006, 11:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •