Results 1 to 7 of 7

Thread: Printing from OSX?

  1. #1

    Printing from OSX?

    I have a hard time trying to get the asus connected HP 3600 to work through Mac OSX. In XP everything works smooth.

    When I look at I look at the XP config; looks like http://ip.ip.ip.ip:9100/ is the proper address to the printer.

    OSX runs CUPS, but I can't get the RAW format to the printer, option flags are not accepted, locally, the HP3600 works like a charm (Uses HP 3000 colorJet driver). When I print, the output is some misformed postscript...

    How can I address the WL500gP with RAW printing from OSX CUPS?

    Thanks in advance,


  2. #2
    CUPS correct uri must be: socket://ip.ip.ip.ip:9100
    and you have to set correct driver's for HP 3600 on OS X computer, neither RAW.
    Last edited by mavka; 21-08-2008 at 14:13.

  3. #3
    Thanks for the reply Mavka,

    well, the socket:// works, but now I get the text print instead of graphics. The printer spits out text starting with:

    %language level: 1
    %documentData: Clean7Bit

    etc etc

    I had the impression RAW would fix this since it's a setting on XP but now I'm stuck.


  4. #4
    Yes, you need to setup printer driver [like in WinXP]:

    I haven't seen Mac, but can you connect to CUPS like: http://localhost:631/?
    Then goto Administration > Add printer > Device = AppSocket > socket://x.x.x.x:9100 > and select correct driver.

    Also, you can try connect printer via LPR:
    queue name used by ASUS - "LPRServer"
    Last edited by mavka; 21-08-2008 at 16:17.

  5. #5
    I can connect to CUPS with localhost, tried different settings. The socket:// initiates printing, but text only.

    I use the oleg firmware, I think the LPRServer is not used anymore. Printer does not react to LPD:// uri

  6. #6
    What driver are you select?
    Last edited by mavka; 22-08-2008 at 08:01.

  7. #7
    Hi Mavka,

    I'm glad to say it worked! I had the Apple pre-installed drivers from HP, but installed the hpijs / ghostscript and foomatic drivers from this link:

    I now use the 3600 ghostscript driver with this url:


    And no problems anymore.

    Thanks a lot for your help! I wouldn't install those OpenPrinting drivers if you hadn't pushed me (because the Apple driver worked perfectly on local USB conection I did not want to swap it at first)


Similar Threads

  1. Replies: 0
    Last Post: 19-12-2007, 17:06
  2. connect to USB drive using OSX
    By gamerhk in forum WL-500gP Q&A
    Replies: 14
    Last Post: 30-10-2007, 09:08
  3. Error Printing (repeated) for LaserJet 6L
    By laughton in forum WL-500g Q&A
    Replies: 1
    Last Post: 29-01-2006, 09:11
  4. Printing from Mac OSX? (HP Deskjet)
    By Maxven in forum WL-500g Q&A
    Replies: 2
    Last Post: 14-08-2005, 09:49

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts