Results 1 to 7 of 7

Thread: Problem: WL500gpV2, twonky, xbox360 and oleg.

  1. #1

    Problem: WL500gpV2, twonky, xbox360 and oleg.

    I have just moved to new flat and i want to make system like that:

    My 250gb Western Digital HDD connected to WL500gpv2, working as media server, streaming media from hdd to wired xbox360 (connected to lcd tv and audio system) and wireless to hacked philips was700 music media player in my bathroom and laptop in my bedroom. I need also to have my hdd visible in windows to upload music and stuff. In theory and asus advertisement - piece of cake

    1st try: original asus firmware with media server turned on, usb sharing on. Hdd visible in Network Neighbourhood, philips plays music almost perfect (almost because it disconnects when i go into folder with subdirectories, but no problem at all when i copy all files to main folder, so doesn't matter), but problem with xbox360 - i can see WL500gpv2 device with only default 4 folders and only in Music folder there are mp3's but only from main folder, not subdirectories. When it comes to photos or videos it says to check connection, and of course checking says everything's ok. Tryin' to make virtual servers (upnp ports 1900udp and 5000tcp), port trigerring, firewall disabling and nothing. Ok, i googled, so found - TwonkyMediaServer. At first i installed it on laptop, done virtual server (tcp9000) and... great! Philips plays everything (even those subdirectories), xbox also have everything, but its still stuff from laptop. I tried to install it on asus, but version WL-HDD didn't work on original firmware. Because i have no linux knowledge at all - i decided to update original firmware.
    2nd try: i found cute asus firmware - looks great, i turned media server on, but xbox still didn't want to see anything else. Hdd visible in Neighourhood, ftp works well, philips does exactly what in previous firmware. But now i wanted Twonky - WLHDD version still didn't want to cooperate but i tried to do that by telnet and with another twonky linux version. Unfortunately, im total newbie in linux, so i passed on first trap - tryin to "mkdir twonkyvision" in /usr/local finished in "Read-only file system". Let it be, Oleg's comin...

    3rd try: i installed olegs firmware. No media server option in menu, but i did it for twonky! Menu looks worse than in previous, but WLHDD version of twonky installed in a moment! Few thinkings with content directories (still dunno why i had every video twice on the list, but doesnt matter), but at last - works! laptop plays everything, philips plays even those folders with subdirectories without any scratches, but xbox - can't see any server. I tried virtual servers, port triggerin, firewall on/off, even lan2wan filters, but - no way. Also no hdd visible in windows network neighbourhood, just ftp. I decided to try another media server, i found wizd v24 - but there's only one file "wizd" with no extension (elf header, i found:P) and readme with clue - "do the binary executable". Great, but linux-idiot like me doesn't know what to do, and google can't give me easy answer to that. I found somewhere opinion that this version of olegs firmware is buggy, but didn't find any other for WL500gpV2.

    I think that problem maybe in fact, that my disk is FAT32, but it's 150gb full, and i use it once a week as backup in work, so i don't want to make it ext2/3.
    Is there any solution? Is it possible maybe to install somehow the twonkymediaserver on original software? Is someone so patient to read it all, so wise to make easy solution for linux-idiot and so kind to write it here? Hope so :P

  2. #2
    I've tried several media servers (ushare, wizd, fuppes..) and twonky is the only solution that worked for me in the 360. And it worked right out of the box. Are yout trying to access the wl500 from lan or from wan?

    As far as the HDD not showing in Network Neighborhood, do you have samba enabled? Is the daemon running?

  3. #3
    From the LAN, and xbox360 is wired to the router, cause i have no wifi modem in x. It's turned on of course, but i read there's some need to specially install samba in, but dunno yet how.

  4. #4
    AFAIK you don't need to do anything about samba. If its enabled on the web interface that should work. Check the permissions of the folders you're sharing and check de smbd and nmdb are running. Or check for inted, if you're using it for samba. If those are running check the firewall configuration. Have you edited iptables?

    Maybe is a firewall problem, its odd that neither samba nor twonky are working.

  5. #5
    samba started working after i have changed samba mode from login to first partition to manual share and pointed /tmp/harddisk/ subfolders now samba and twonky are working on computer, but still no on the connected by ethernet wire xbox360. i tried to setup iptables to forward everything from (my x360 address) to (wl-500gpv2 address) and tried to do that by:
    iptables -a FORWARD --proto tcp -source -j DNAT --to but i get invalid argument :/ do u know maybe how should it be written?

  6. #6
    Ok, you don't need to forward trafic from your X360, what you should do is allow trafic from br0 to the router, like this:

    iptables -A INPUT -s -i br0 -j ACCEPT

    in order to de 360 or any other pc or laptop in br0 to have full acces to the router. (If you need extra security measurements for br0, then you should close some ports or open the needed ports one by one). But, as i really don't know the ports twonky uses, for testing, let's open all traffic from br0. Try that, and see if the 360 get access, to rule out possible firewall issues.

  7. #7
    I tried to install Twonky 4.4.11 Linux MIPS little endian glibc 2.2.3 on WL-500GP and failed.

    The following steps done:

    Firware: Tomato Teddy Bear 8643 build

    1) unpack the gzip to /jffs/twonky
    2) chmod 700 twonkym* cgi-bin/* plugins/*
    3) change the path in ./ to /jffs/twonky/twonkymedia
    4) created shell
    route add -net netmask dev br0
    cd /jffs/twonky/
    tmp/jffs/twonky/twonkymedia &
    5) added the in init script and reboot.

    the system returns "sh: /jffs/twonky/twonkymedia: not found", what's the reason that twonkymedia cannot be executed? the execution bit has been set.
    does it mean that I need to install optware? If yes, where can I dl it?

Similar Threads

  1. Asus WL500gp & xbox360
    By spannow in forum Dutch Discussion - Nederlands
    Replies: 2
    Last Post: 24-09-2007, 09:19

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts