Page 3 of 8 FirstFirst 12345 ... LastLast
Results 31 to 45 of 110

Thread: Transmission 1.31

  1. #31
    @shouriken
    Remove package transmission and install package transmissiond

    EDIT: Sorry, shouriken i thougt your message was the last :-/ This "show last message first" configuration is killing me
    Last edited by dclagoa; 18-08-2008 at 10:11.

  2. #32
    I think, that I've found solution for all my problems with Transmission 1.32

    1. Install 1.32
    2. Put into post-mount
    Code:
    nano /usr/local/sbin/post-mount
    line

    Code:
    /opt/bin/transmission-daemon -p 8008 -g /tmp/harddisk/torrent/.config -w /tmp/harddisk/torrent -t --auth   -u USER   -v PASSWORD
    3. Move all folders and files from /tmp/local/root/.config/transmission-daemon to /tmp/harddisk/torrent/.config/

    4. I've got corrupted downloads afer reboot. To close transmission nicely chanve pre-shutdown:

    Code:
    nano /usr/local/sbin/pre-shutdown
    Add lines (correct me, if there is better way).

    Code:
    killall transmission-daemon
    
    sleep 30s
    5. Save this all
    Code:
    flashfs save && flashfs commit && flashfs enable && reboot
    Open http://YOURIP:8008/transmission/web

    Change preferences (bottom left corner), save them. To make sure everything warks - restart the router and check, if changes in preferencess was saved.

    And one note - change port number to old one or edit post-firewall to accept connections on this port.
    Last edited by kaizen; 19-08-2008 at 08:51.

  3. #33
    Quote Originally Posted by oleo View Post
    Transmission was splitted into two packages with changeset 8882.

    Clutch package now depends on 1.22 transmisisond package until next upgrade.
    Hy

    Is there a way to put also the 1.22-2 transmissiond on the server?
    It was, for me, the best working transmission, with 1.22-1 I have an issue regarding the SEEDING of torrents: It doesn'work, and I had the same issue when the available transmission was the 1.22-1, that untill it was upgraded by the 1.22-2 and everything worked.

    Thank you
    Last edited by bogd_A; 20-08-2008 at 11:13.

  4. #34
    Im using 1.32, and no matter how many seeders there are i cant connect to more than afew, 12-14 at the max.
    How is it with other using 1.32?

    Edit: Is there a way to make the web interface prompt for a password if you want to be able to access it from outside your local net?
    Last edited by glenn; 20-08-2008 at 13:13.

  5. Please build 1.33 because it support UTF-8
    http://forum.transmissionbt.com/view...php?f=1&t=5697

  6. #36
    Join Date
    Jun 2005
    Location
    Slovenia
    Posts
    736
    done with r8927

  7. #37
    Join Date
    Aug 2008
    Location
    ::1
    Posts
    11
    Quote Originally Posted by shouriken View Post
    1.32 is out and is accepted by some private trackers.

    I managed to resume seeding torrents by moving the files existing in

    /tmp/harddisk/torrent/.config/transmission/resume
    and
    /tmp/harddisk/torrent/.config/transmission/torrents

    to
    /tmp/local/root/.config/transmission-daemon/resume
    and
    /tmp/local/root/.config/transmission-daemon/torrents

    and restarting transmission-daemon.

    I did not have currently downloading torrents, but I think it should work in the same way.
    Hi,
    If I did this, and after that when I type to command line
    Code:
    flashfs save && flashfs commit && flashfs enable
    I get this error >
    Code:
    tar: Names longer than 100 chars not supported.
    And after restart torrent-deamon is in default state with no torrent added.

    How can I correct this ?

  8. Quote Originally Posted by oleo View Post
    done with r8927
    Awesome! It works much better, simultaneously fix another leaks. Really thanks for fast build!

  9. #39
    Join Date
    Aug 2008
    Location
    ::1
    Posts
    11
    Quote Originally Posted by iGz View Post
    Hi,
    If I did this, and after that when I type to command line
    Code:
    flashfs save && flashfs commit && flashfs enable
    I get this error >
    Code:
    tar: Names longer than 100 chars not supported.
    And after restart torrent-deamon is in default state with no torrent added.

    How can I correct this ?
    I solved this. Just changed path for config files by adding --config-dir option for transmission to startup script, and now transmission works great
    I`m just starting with linux, so i`m newbie
    Last edited by iGz; 21-08-2008 at 00:42.

  10. #40

    Post #30

    I followed Kaisen's advice and now it works great! The only thing I did different is I put it in /opt/torrent which is where my 1.x transmission was. Works like a charm. Thanks for the help!

  11. #41
    Using the idea of wpte presented here

    http://wl500g.info/showpost.php?p=107759&postcount=8

    I created /opt/etc/init.d/S99trans with the following content:

    Code:
    #! /bin/sh
    
    case $1 in
            start)
                    /opt/bin/transmission-daemon  -w /tmp/harddisk/torrent/target -g /tmp/harddisk/torrent/config
                    ;;
            stop)
                    if [ -n "`pidof transmission-daemon`" ] ; then
                            echo "stopping transmission-daemon"
                            killall transmission-daemon
                    fi
                    ;;
            restart)
                    $0 stop
                    sleep 5
                    $0 start
                    ;;
            *)
                    echo "usage: $0 (start|stop)"
                    exit 1
    esac
    where -w and -g options define the download and the configuration directories.

    This way rc.unslung can start/stop the transmission-daemon auto-magically.

    Don't forget to

    chmod 755 /opt/etc/init.d/S99trans

  12. #42

    Removing files

    Any idea on how to deselect unwanted files in torrent, in order that transmission won't download them? Because i have a torrent with about 10 Imax movies of 45 GB, but I want to download only one movie form them, and I couldn't find how to unselect the other movies.

  13. #43
    Join Date
    Dec 2007
    Location
    The Netherlands - Eindhoven
    Posts
    1,767
    Quote Originally Posted by shouriken View Post
    Using the idea of wpte presented here

    http://wl500g.info/showpost.php?p=107759&postcount=8

    I created /opt/etc/init.d/S99trans with the following content:

    Code:
    #! /bin/sh
    
    case $1 in
            start)
                    /opt/bin/transmission-daemon  -w /tmp/harddisk/torrent/target -g /tmp/harddisk/torrent/config
                    ;;
            stop)
                    if [ -n "`pidof transmission-daemon`" ] ; then
                            echo "stopping transmission-daemon"
                            killall transmission-daemon
                    fi
                    ;;
            restart)
                    $0 stop
                    sleep 5
                    $0 start
                    ;;
            *)
                    echo "usage: $0 (start|stop)"
                    exit 1
    esac
    where -w and -g options define the download and the configuration directories.

    This way rc.unslung can start/stop the transmission-daemon auto-magically.

    Don't forget to

    chmod 755 /opt/etc/init.d/S99trans
    ah that is fantastic
    I'm not really good at writing those scripts
    I had some problems starting the stuff, but I think that was because of the "start" parameter? because it did work when I ran it manually
    thanks

  14. #44
    Quote Originally Posted by wpte View Post
    ah that is fantastic
    I'm not really good at writing those scripts
    I had some problems starting the stuff, but I think that was because of the "start" parameter? because it did work when I ran it manually
    thanks
    I've only tried to write something that is similar to the other scripts in /opt/etc/init.d.

    The thanks must go to wengi and the others that contributed the "how to" threads.

  15. #45
    Join Date
    Aug 2008
    Location
    ::1
    Posts
    11
    Hi, I just want to ask you. How much Transmission loads your CPU on WL500gp v2 with private and public torrents ? When i was downloading 1.2 GB torrent from private tracker, transmission ate approx. 40 % of CPU. I know, this isn`t serious test, but I`m just curious
    Thanks...

Page 3 of 8 FirstFirst 12345 ... LastLast

Similar Threads

  1. WL-500gp and Transmission
    By happymeal in forum WL-500gP Q&A
    Replies: 55
    Last Post: 27-08-2008, 19:46
  2. Understanding and debugging Transmission [oleo?]
    By wengi in forum WL-500gP Q&A
    Replies: 66
    Last Post: 05-08-2007, 10:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •