Results 1 to 4 of 4

Thread: How to reset password settings?

  1. #1

    How to reset password settings?

    Hi all,

    After installing dd-wrt and seeing that 24 sp1 still needs more work I decided to install Oleg's firmware.
    Since direct upgrade failed I used nvram-clear and nvram-recover and the installed Oleg's firmware.
    Now the router boots fine , but I can't access it either from telnet or via web interface because it won't accept my password.
    I tried admin/admin , admin/"" and the password settings I used with dd-wrt before reformat.
    Neither work.
    One thing I forgot to mention is that wireless SSID is visible as dd-wrt even though I have run nvram-clear and nvram-recover many times.
    Last edited by matrix200; 02-08-2008 at 22:42.

  2. #2

    Ok I was able to solve the problem.

    I will post the solution in case someone needs it in the future.
    First of all i would like to say that nvram-clear and nvram recover didn't work for me even though I tried numerous times.
    Now in recover mode I was able to telnet and inspect the nvram.
    Sure enough all dd-wrt stuff was there (including encrypted username and password).
    I tried resetting them to be blank , but that didn't help either.
    Then I decided to try and install the stock firmware.
    Strangely this one worked and I was able to login using default username and password.
    Just in case I used reset to factory defaults and then reinstalled Oleg's firmware 1-9-27-10 and now I am able to login.

  3. #3
    thank god that i found this thread.

    I have tried to flash the original firmware, but the usernam abd the password were still there and I couldn't access the web interface neither telnet access.

    Actually the solution to this problem is the next one:
    1.Flash the DD-WRT firmware responsible for the data in the NVRAM
    2.connect to the router using telnet
    3.inside the console change the username and the password to admin/admin by using the next comands:
    nvram set http_passwd=newpassword commit nvram (for password)
    nvram set http_username=newusername commit nvram (for username)

    after those steps being completed reflash your router with the desired firmware and everything should work properly.

    Break a leg!

  4. #4
    I've found another solution based on your experience without flashing firmware.
    My problem was that after changing password I was not able to login again to router neither via www interface nor telnet and had to factory reset to get access to www or telnet again.
    After factory reset you should be able to login with admin/admin - if not press the button on back of the router for few seconds until it flashes quickly, then reboot.
    Login to console via telnet, then
    nvram show | grep pass
    Look for variables related to http_password or something.
    Erase each of them
    nvram unset <variable name>
    nvram commit

    I hope it works - it worked for me at least.

Similar Threads

  1. cannot reset my wlhdd
    By ignazioc in forum WL-HDD Q&A
    Replies: 1
    Last Post: 02-11-2008, 02:38
  2. reset
    By alex.bumbacea in forum WL-500gP Q&A
    Replies: 2
    Last Post: 13-02-2008, 22:29
  3. mldonkey does not store settings on power on/off ?
    By csg0078 in forum WL-700g Firmware Discussion
    Replies: 1
    Last Post: 13-02-2008, 02:22
  4. Replies: 1
    Last Post: 20-06-2007, 10:38
  5. Password problem - need help
    By neos2k1 in forum WL-500g Q&A
    Replies: 2
    Last Post: 20-03-2007, 22:37

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts