Page 4 of 12 FirstFirst ... 23456 ... LastLast
Results 46 to 60 of 167

Thread: WL-500g Premium died After Upgrading Firmware

  1. #46
    Join Date
    Aug 2004

    Connect up a Serial Converter to it and look what the bootloader says, or maybe send it back for Service to Asus ?

    If it flashes the firmware completely and then dont work even after a manual nvram reset via button, i dont have a clue...

    My Stuff: WL-500g, Mapower H31x 10GB HD, Philips Webcam Vesta PRO, TerraTec Webcam PRO, USB Hub

  2. #47
    Hi Oleg!

    I think i have a similar problem... - but my eth0 is initialized! But I still cant ping the box or put a new image on it... i wrote my problems description here:

    I know thats another board - but if you have any hint for me i would be really glad!

    Thx, dude

  3. #48

    wl500 bricked

    Hi there,

    It seems in order to enable 32 Mb Ram, I bricked my wl500g deluxe entering wrong memory values
    It seems that I should have entered :

    nvram set sdram_init=0x2008
    nvram set sdram_ncdl=0x0000
    nvram commit

    But I entered values for wl500g premium and the router no longer boot.

    So. Now that I bricked my router what are my options ( if any ) to get it back working ?

  4. #49

  5. #50
    Hi! Thx for the info, but shortening Pin 9 doesnt change a thing...
    Please check this thread here and give me hints if anyone has an idea...

  6. #51
    Tried this:

    CFE> flash -offset=65536 flash0.os flash0.os
    Reading flash0.os: Done. 8062791 bytes read
    Download of 0x7b0747 bytes completed
    Write kernel and filesystem binary to FLASH (0xbfc40000)
    flash device 'flash0.os'
    ERROR!! copysize is 8062791, amtcopy is 8028132
    Failed.: Unknown error
    Any hints?

  7. #52
    Quote Originally Posted by Oleg View Post
    Type these lines in the cfe prompt:
    nvram erase
    flash -offset=65536 flash0.os flash0.os

    DONT try this... after that my device doesnt boot into cfe anymore....

  8. #53

    How can a wl500gp brick ?


    There's one thing I was wondering: it was how can one brick a router ? You can always come to either the recovery mode (started before the firmware is even loaded) or the bootloader (serial line+tftp) because the bootloader can't be overwritten in an upgrade ?

    If no, can you explain me.



  9. #54

    Weird brick - anyone with a solution?

    I've two pieces of Wl500gP - A couple of times before they went uresponsible changing som nvram settings and then I had success debricking grounding pin9. This time I upgraded the firmware (dd-wrt), restored factory defaults and tried to restore some backup'ed settings.
    Both routers went dead and the one I got back in business using pin9 trick.
    The other one is still troubling me, descriped below.

    The router is able to enter recoverymode holding down restore button. Then the router is pingable at, but uploading firmware with the restoraion tool or TFTP is really slow and always times out before ever finishing.

    Then I've tried grounding pin 10, 12 16 and 17. The last two makes the router enter recovery mode and then speeds are great and the router accepts a new firmware. Tried several different builds, both dd-wrt and olegs firmware and so on.
    When TFTPing the new image the router never gets back in business, but using restoration tool the router always boot, but only until poweroff or reboot. So until changing settings etc. the router is accessible trough http/telnet and wireless is working.

    Is my bootloader broken? - Anyone ever experienced something like this? - I've also tried olegs files
    wl500g-clear-nvram.trx and wl500g-recover.trx and from telnet "mtd erase nvram" (after grounding pin16) - But always the is router only is accessible right after flashing from restoration tool and only until it's rebooted.

    Really weird. Anyone knows how to solve this. I have tried attaching a serial cable (old phone usb2serial cable with pl2303) for further diagnosing, but I can't get this to work. Only crappy output in hyperterminal.

    Any help would be appreciated. Also posted a similar thread at the dd-wrt forum, but no answers.

  10. #55
    I've managed to get my router back... And still I got no serial console. But I'll definetly have to get myself a working one. - did not help
    wl500g-clear-nvram.trx - did not help
    wl500g-recover.trx - did not help

    Flashing from recovery mode always timed out, and never made the router work.
    Flashing from recovery mode after shorting pin 16/17 with gnd always was a success with every firmware, but only until reboot. Tried to clean nvram with "mtd erase nvram" or "" before rebooting without success. Ended up doing like this

    1) power off
    2) short pin 16 with GND and power on until power-LED started flashing
    3) removed the shorting of pin 16
    4) flashed with dd-wrt
    5) after router alive, telnet and logged in
    6) ran "mtd erase nvram"
    7) ran "mtd erase linux"
    8) reboot
    9) router started up in recovery mode
    10) flashed with olegs firmware (or other firmware), and wasn't slow anymore - after reboot the router was alive and kicking, also after poweroff.

    Dunno if the above mentioned method will help someone out there, but maybe someday.
    Last edited by avalanche; 05-07-2007 at 20:07.

  11. #56

    Question Bricked wl500gP?

    A couple of days ago i tryed to install dd-wrt on my wl500gP. It was successfull and I was able to log on to webif and all. When changing some pppoe settings from webif it all suddently stopped working.
    I managed to reflash to asus official firmware but I think the router is bricked now. When I power on, the power led is just blinking. I am able to ping but Im not able to connect to a webif or telnet.
    If I set up a ping -t I notice that when I try to use Firmware Restoration tool the ping stops and the tool says "No wireless device in recovery mode is found".

    Does anyone know any solutions to this or is it just to be thrown away?

  12. #57
    I've bricked my wl500gp numerous times and I have yet to find one that wasn't fixable.
    Usually recovering from any bad flash involves:
    * Setting up your own addresses manually. In windows you can navigate to TCP/IP under network connections in your control panel and set your own IP and default gateway.
    * Now that you have your connection set up, stick the router into recovery mode and the asus firmware utility should be able to find it and upload wl500g-clear-nvram.trx to it.
    * After that you can stick in whatever firmware you want and it's as good as new.

  13. #58

    Unhappy SOS! SOs!sos! Bricked new wl500gp. Help\advice needed

    Based on discussions and abilities bought WL500gP with the idea to have small always running linux box.

    Via standard ASUS firmware interface flashed
    later on, via recovery mode I upload (flash)

    After this, router stopped responding(no ping).

    I put him in recovery mode by reset button again and start upload standard firmware.
    Via usage of Firmware restoration tool ((c) by ASUS)
    I start uploading WL500gp_1.9.7.2_TW.trx/
    Upload stops near 30% and breaks up, router does not respond to ping or web requests.
    I read about pin9 hack and break all warranty seals.
    pin9 hack. Recovery mode again, flash image transfer
    vVia usage of Firmware restoration tool ((c) by ASUS) breaks up midway.
    We, together with Mr.Evtushenko soilder in com port on the router board. Using FT232B ( we get router console with CFE prompt by pressing Ctrl-c on boot
    We read
    nvram erase, Waiting 10 minutes. No output/
    We reboot with reset pushed down and watch console --

    tftp server: Failed.: Timeout occured
    Reading :: TFTP Server.

    We give him standard asus flash image
    tftp -i WL500gp_1.9.7.2_TW.trx
    Failed.: Timeout occured
    Reading :: TFTP Server.
    Failed.: Timeout occured
    Reading :: TFTP Server.
    Failed.: Timeout occured
    Reading :: TFTP Server.
    Failed.: Timeout occured
    Reading :: TFTP Server.
    Failed.: Timeout occured
    Reading :: TFTP Server.
    Failed.: Timeout occured
    Reading :: TFTP Server.
    Failed.: Timeout occured
    Reading :: TFTP Server.
    Done. 7974912 bytes read
    Download of 0x79b000 bytes completed
    Write kernel and filesystem binary to FLASH (0xbfc40000)
    flash device 'flash1.trx'
    parseflag = 0, the copysize is 7974912
    after cfe_writeblk, the copysize is 7974912, amtcopy=7974912
    done. 7974912 bytes written

    Waited 10 minutes, tea\coffee\smoke. router does nothing.
    We reboot him and -- BRICKED -- no output on console, no ping, no web interface.

    Is it possible to revive this router?

    Thanks for reading on, will be grateful on any info on the subject//


  14. #59

    Pin 9

    It happened to me some times ago, and I found some kind of tutorial on this forum about how to hardware reset the brick

    Search the forum about how to open the router and short-circuit the pin 9 on the hynix EEPROM to the ground

    for me it worked, but read carefully and study your board with a magnifier against those instruction because it is risky.

    Good luck !

    read this
    Last edited by vuk; 28-08-2007 at 09:41.

  15. #60
    yes it is possible by the the wl500g-clear-nvram.trx and the wl500g-recover.trx. available on this side after this you have to flash your wl500gp with the firmware you need. all by the recover mode. i can also email you these firmwares. Good luck
    Op zoek naar pretparken:


Page 4 of 12 FirstFirst ... 23456 ... LastLast

Similar Threads

  1. port forwarding Wl 500g premium
    By fanta in forum Dutch Discussion - Nederlands
    Replies: 1
    Last Post: 09-03-2008, 19:15
  2. Azureus + WL 500g Premium слабая скорость
    By pertsev in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 1
    Last Post: 02-03-2008, 15:15
  3. WL 500g Premium
    By airbrush999 in forum German Discussion - Deutsch (DE)
    Replies: 1
    Last Post: 27-11-2007, 23:17

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts