Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: Run Xlink Kai on the Wl500g

  1. #1

    Run Xlink Kai on the Wl500g

    Didn't know if anyone is interested in this but the xlink kai engine seems to run fine on the wl500g.

    For those puzzled about what kai actually is wonder over to
    I recommend you try the WinXP client/server before attempting this, and you will need to register your xtag.

    Seemed quite simple to get running, I copied over the files to my usb hdd, entered the directory and ran
    I already have kaid installed and the win xp install includes the java client, just run the kai config tool, and select the options listed in the screen shot below.

    Then select from your start menu; start kai, when the java ui pops up select file --> settings

    Enter your router ip as the engine address, and the port (usually 34522), as well as your xtag details

    Then you can hit attach engine and login to see the arena, please note I have not tested this with a console yet as it is in bits at the moment! :-)
    Attached Images Attached Images  

  2. #2
    Join Date
    Dec 2003
    Oslo, Norway
    Thanks! I got it working "out of the box". (At least I could connect, didn't try any games). I did it without downloading the Windows application. I used the latest version of XBox MediaCenter to connect.
    MrMagu, Oslo, Norway

  3. #3
    Good to hear it!, I have actually managed to play a few games last night using the kai engine.

    There are some things that need to be noted however, afaik this engine is still a work in progress; sometimes it segfaults when looking for orbital mesh, restarting the client and engine is normally enougth to cure this however.

    The kaid.conf included already seems to be setup correctly, with br0 as the interface listed, you should include the mac address of your console in this file in the usual colon seperated format. If you are using an xbox ensure that you use the correct one, some programs available seem to give a dummy mac address. If in doubt check the dhcp lease in the router pages.

    Also it might be an idea to turn wondershaper off/adjust it to take into account this service, as upload ping is all important, and too much lag will kill (you, in halo2 etc!) your gaming experience.

    If you have any questions please make sure that you got the engine/client working on the pc with your xbox wired to you're network before attempting anything more advanced.

    Happy Gaming!

  4. #4
    Join Date
    Aug 2004
    Very Nice
    My Stuff: WL-500g, Mapower H31x 10GB HD, Philips Webcam Vesta PRO, TerraTec Webcam PRO, USB Hub

  5. #5
    this is great news - what firmware do I need to be running on my WL500g and which files from teamxlink did you use?

  6. #6


    Do you know if there is any chance to get this working on a wl300g? I saw this link on the yesterday and it got my hops up! Do any of you know?
    My ASUS setup
    [xbox] <-crossovercabel-> <[ASUSWL300G]> ((((wifi)))) <[BelkinPRE-N]> <-networkcabel-> {internet ADSL2+}

  7. #7
    Join Date
    Apr 2004
    Quote Originally Posted by miraculix
    Do you know if there is any chance to get this working on a wl300g? I saw this link on the yesterday and it got my hops up! Do any of you know?
    Well, you can always try and find out...and report back here.

  8. #8
    Well I gave it a try. First i tried to fit it onto my flashram but it did not work so I did this workaround.
    First I copied the files to my xbox.
    Then I made this post-boot script.
    wget ftp://<username>:<pass>@<xboxip>/e/kaid -O /usr/local/sbin/kaid;
    wget ftp://<username>:<pass>@<xboxip>/e/kaid.conf -O /usr/local/sbin/kaid.conf;
    chmod +X /usr/local/sbin/kaid;
    /usr/local/sbin/kaid -d -c /usr/local/sbin/kaid.conf;
    now it works as long as I have my xbox running when rebooting the router .

    The other link seemed to need to be compiled into the firmware. I don't realy feel sure how to do this maybe something for Oleg to include....
    My ASUS setup
    [xbox] <-crossovercabel-> <[ASUSWL300G]> ((((wifi)))) <[BelkinPRE-N]> <-networkcabel-> {internet ADSL2+}

  9. #9
    Join Date
    Dec 2003
    Russian Federation
    Could you please post a link to kaid source and binary?

  10. #10
    Quote Originally Posted by Oleg
    Could you please post a link to kaid source and binary?
    macsat - Tutorials and information on using ASUS WL-500G and family.

  11. #11
    Join Date
    Dec 2003
    Russian Federation
    yes, already found it. no sources, just big binary.
    well, adding it to firmware is not a big deal (without config UI), but it would eat much space from flash, so this needs to be an option.
    Probably we need online firmware builder.

  12. #12
    Can't get it working

    Downloaded the binaries and unpacked them to my usb harddisk ( i changed nothing in the kaid.conf), started with ./kaid. Everything seemed to work, but every time my xbox tried to connect, kaid stopped with segmentation fault error. Tried it some time, in a forum I found that this shouldn't happen with

     $FULLPATH/kaid -c $FULLPATH/kaid.conf
    but that didn't work either. So downloaded the binaries once more and since then I always get:

    KAID: Kai Engine for KaiStation is initialising...
    KAID: No orbitals servers are available...
    KAID: Abnormal Kai Engine Termination...
    Anyone an idea whats wrong?

  13. #13
    The source I was refering to was
    I do not realy know if this is what you need but it looked to me like it was a description on what to do.

    The kaid & kaid.conf I'm using i found on and but there is also a download availible on if you klick download and choose linux mips
    Last edited by miraculix; 18-05-2005 at 14:17.
    My ASUS setup
    [xbox] <-crossovercabel-> <[ASUSWL300G]> ((((wifi)))) <[BelkinPRE-N]> <-networkcabel-> {internet ADSL2+}

  14. #14
    Join Date
    Mar 2005
    The Netherlands
    Is there a way to make a custom firmware for this? Like they did for the Linksys routers.

    I think you guys mean this source package for all platforms, posted at Xlink Kai homepage as news

    It would make us n00bs a lot easier to run kai on our WL-500g, I have no idea how to load those config files, only experience I have with Linux is logging on my psyBNC and eggdrop configs with SSH that’s all.

    The commands looks like familiar but not clear enough for me if it’s not possible to make a firmware, maybe someone is kindly to make a step by step tutorial for us.

    I would love to run kai without my PC right from my router, I think more guys would use it here once its explained or made a firmware for it so you can put the info on the config page.
    Last edited by SpAwN; 23-05-2005 at 06:25.

  15. #15
    @Oleg - For me it would be ok to handle the files the way I do with post-boot script but I would love the Config UI

    @Pastor - To make it work U need to edit the kaid.conf so that kaid knows youre xbox mac-address.

    # ConsoleMacs	: You can and should specify your console(s) mac address(es)
    #                   here. They'll be used as pcap filters reducing CPU loading
    #                   processing each packet. It will also avoid sniffing 
    #                   incoming/injected packets to be caught. Format must be
    #                   standard tcpdump format:  Ex.: 00:ff:dd:5b:31:ac
    #                   You can specify more than a mac address in a ; separated 
    #                   list. Will be parsed and "OR'ed" in filter. List should end
    #                   with ";" or last element will be discarded.
    ConsoleMacs = 00:50:f2:d4:f2:03;
    @spawn - Everything you need is in this thread.
    Download the two files kaid and kaid.conf.
    Edit kaid.conf to fit your needs.
    Make the files avalible on your rtr. On usb drive or in memory.
    Start kaid in post-boot script.
    Last edited by miraculix; 23-05-2005 at 07:45.
    My ASUS setup
    [xbox] <-crossovercabel-> <[ASUSWL300G]> ((((wifi)))) <[BelkinPRE-N]> <-networkcabel-> {internet ADSL2+}

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts