Page 3 of 9 FirstFirst 12345 ... LastLast
Results 31 to 45 of 124

Thread: Кросскомпиляция пакетов

  1. #31
    Quote Originally Posted by pppppppo_98 View Post
    Эта процедура меня совсем ставит в тупик.
    Ну тут то как раз все понятно. Файлы патчей рассчитаны на stable версию. А у Вас скачался daily snapshot. Он, видимо, другой совсем, к нему имеющиеся патчи неприменимы.

  2. #32
    Вся безнадежность ситуации что, я вообще не могу дотянуться до пункта выбора версии гдшис
    ибо dв конфигурации где-то прописано автоматический выбор snapshot а не стабильной версии

    uClibc C library Version
    1. uClibc 0.9.28 (BR2_UCLIBC_VERSION_0_9_28)
    > 2. daily snapshot (BR2_UCLIBC_VERSION_SNAPSHOT)
    choice[1-2?]: 2

    Может все-таки кто-нить выложит рабочий главный Makefile

    Ну и совсем уж вопрос из области фантастики может кто-нить из уважаемых гуру кросс-компиляции
    поможет бедному новичку и компильнет этот самый злосчастный пакет с сайта httrack.com.

    Готов оказать посильную помощь
    Last edited by Omega; 04-07-2011 at 18:09. Reason: fixed

  3. #33
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    вот ~/optware/Makefile хотя не думаю, что дело в нем. Скорее всего что-то не так в самой системе для кроссa...

    Насчет httrack я посмотрю. Если проскочит в лоб, то и ладно, а если надо будет разбираться... то не уверен..., что горю желанием.
    Attached Files Attached Files

  4. #34
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805
    Далеко мы не уехали --- отваливается в самом начале после configure...

    PHP Code:
    make -/home/al/optware/oleg/builds/httrack
    make
    [1]: Entering directory `/home/al/optware/oleg/builds/httrack'
    make  all-recursive
    make[2]: Entering directory 
    `/home/al/optware/oleg/builds/httrack'
    Making all in src
    make[3]: Entering directory `/home/al/optware/oleg/builds/httrack/src'
    if /bin/sh ../libtool --mode=compile /home/al/optware/oleg/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I. -I.. --g3 -Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wnested-externs -D_REENTRANT -DINET6 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DPREFIX=\""/opt"\" -DSYSCONFDIR=\""/opt/etc"\" -DDATADIR=\""/opt/share"\" -DLIBDIR=\""/opt/lib"\"  -O2   -pipe  -I/home/al/optware/oleg/staging/opt/include  -I/usr/include  -g -O2 -MT htscore.lo -MD -MP -MF ".deps/htscore.Tpo" \
              -c -o htscore.lo `test -f 'htscore.c' || echo './'`htscore.c; \
            then mv -f "
    .deps/htscore.Tpo" ".deps/htscore.Plo"; \
            else rm -f "
    .deps/htscore.Tpo"; exit 1; \
            fi
    mkdir .libs
     /home/al/optware/oleg/toolchain/mipsel-linux-uclibc/gcc-4.1.1-uclibc-0.9.28/bin/mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I. -I.. -O -g3 -Wall -Wcast-align -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wpointer-arith -Wnested-externs -D_REENTRANT -DINET6 -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -DPREFIX=\"/opt\" -DSYSCONFDIR=\"/opt/etc\" -DDATADIR=\"/opt/share\" -DLIBDIR=\"/opt/lib\" -O2 -pipe -I/home/al/optware/oleg/staging/opt/include -I/usr/include -g -O2 -MT htscore.lo -MD -MP -MF .deps/htscore.Tpo -c htscore.c  -fPIC -DPIC -o .libs/htscore.o
    In file included from /usr/include/linux/errno.h:4,
                     from /usr/include/bits/errno.h:25,
                     from /usr/include/errno.h:36,
                     from htsbase.h:64,
                     from htscore.h:44,
                     from htscore.c:46:
    /usr/include/asm/errno.h:9:4: warning: #warning This machine appears to be neither x86_64 nor i386.
    In file included from /usr/include/sys/socket.h:35,
                     from /usr/include/netinet/in.h:24,
                     from /usr/include/netdb.h:28,
                     from htsnet.h:57,
                     from htslib.h:62,
                     from htscore.h:93,
                     from htscore.c:46:
    /usr/include/bits/socket.h: In function '__cmsg_nxthdr':
    /usr/include/bits/socket.h:278: warning: cast increases required alignment of target type
    In file included from /usr/include/bits/socket.h:311,
                     from /usr/include/sys/socket.h:35,
                     from /usr/include/netinet/in.h:24,
                     from /usr/include/netdb.h:28,
                     from htsnet.h:57,
                     from htslib.h:62,
                     from htscore.h:93,
                     from htscore.c:46:
    /usr/include/asm/socket.h:9:4: warning: #warning This machine appears to be neither x86_64 nor i386.
    In file included from /usr/include/bits/ioctls.h:24,
                     from /usr/include/sys/ioctl.h:27,
                     from htsnet.h:66,
                     from htslib.h:62,
                     from htscore.h:93,
                     from htscore.c:46:
    /usr/include/asm/ioctls.h:9:4: warning: #warning This machine appears to be neither x86_64 nor i386.
    In file included from htsthread.h:42,
                     from htsftp.h:43,
                     from htscore.h:116,
                     from htscore.c:46:
    /usr/include/pthread.h: At top level:
    /usr/include/pthread.h:650: warning: '__regparm__' attribute directive ignored
    /usr/include/pthread.h:661: warning: '__regparm__' attribute directive ignored
    /usr/include/pthread.h:705: warning: '__regparm__' attribute directive ignored
    htscore.c: In function 'dir_exists':
    htscore.c:2313: error: 'EINVAL' undeclared (first use in this function)
    htscore.c:2313: error: (Each undeclared identifier is reported only once
    htscore.c:2313: error: for each function it appears in.)
    htscore.c: In function 'structcheck':
    htscore.c:2355: error: 'EINVAL' undeclared (first use in this function)
    make[3]: *** [htscore.lo] Ошибка 1
    make[3]: Leaving directory `/home/al/optware/oleg/builds/httrack/src'
    make[2]: *** [all-recursive] Ошибка 1
    make[2]: Leaving directory `/home/al/optware/oleg/builds/httrack'
    make[1]: *** [all] Ошибка 2
    make[1]: Leaving directory `/home/al/optware/oleg/builds/httrack'
    make: *** [/home/al/optware/oleg/builds/httrack/.built] Ошибка 2 

  5. #35
    Quote Originally Posted by pppppppo_98 View Post
    2 al37919

    Makefile точно такой же

    Мандрива и gcc несколько с запашком gcc -v дает

    4.0.1-5mdk for Mandriva Linux release 2006.0

    Ща еще попробую сделать тоже самое на Mandrive 2008
    Могу лишь сказать, что на блюдп. на своей машине точно такое поведение.
    после make rtorrent кучка вопросов и потом ошибка
    --
    WL500gP / wl500g-1.9.2.7-10

  6. #36

    У меня таже проблема

    приведенный ниже рецепт не работает, точнее при
    make toolchain

    вываливает
    Code:
    *
    * Buildroot Configuration
    *
    Target Architecture
      1. alpha (BR2_alpha)
      2. arm (BR2_arm)
      3. armeb (BR2_armeb)
      4. cris (BR2_cris)
      5. i386 (BR2_i386)
      6. m68k (BR2_m68k)
      7. mips (BR2_mips)
    > 8. mipsel (BR2_mipsel)
      9. nios2 (BR2_nios2)
      10. powerpc (BR2_powerpc)
      11. superh (BR2_sh)
      12. superh64 (BR2_sh64)
      13. sparc (BR2_sparc)
      14. x86_64 (BR2_x86_64)
    choice[1-14?]: 8
    *
    * Build options
    *
    Wget command (BR2_WGET) [wget --passive-ftp -nd] (NEW)
    далее жму <enter>
    Code:
    Subversion (svn) checkout command (BR2_SVN) [svn co] (NEW)
    далее жму <enter>
    Code:
    zcat command (BR2_ZCAT) [zcat] zcat
    bzcat command (BR2_BZCAT) [bzcat] bzcat
    Tar options (BR2_TAR_OPTIONS) [] (NEW)
    далее жму <enter>
    ...
    Проверял только что !!
    что делать ?

    Quote Originally Posted by Novik View Post
    cd /
    svn co http://svn.nslu2-linux.org/svnroot/optware/trunk optware
    export OPTWARE_TARGET="oleg"
    cd /optware
    make directories
    make toolchain
    [тут ждать пару часов]
    make rtorrent [или что там Вам собрать надо]

    Замечания по ходу дела.
    1) Компилировать тулчейн под рутом нельзя, будет ругаться.
    2) Чтобы было щастье, нужно иметь предустановленными довольно много пакетов.
    На память для компиляции rtorrent - gcc,g++,autoconf,automake,make,m4,bizon,flex,pkg-config,libwww-perl (наверняка чего-нибудь забыл).
    3) Так - работает. Проверял час тому назад.

  7. #37

    make install

    почему может не работать make?

    [root@begemot_router testquickcam]$ ls
    CVS Makefile testquickcam.c testquickcam.h
    [root@begemot_router testquickcam]$ make
    -sh: make: not found
    [root@begemot_router qc-usb]$ make install
    -sh: make: not found
    [root@begemot_router qc-usb]$

    спасибо

  8. #38
    Join Date
    Jun 2008
    Location
    Russia, Perm
    Posts
    476
    А вы его поставить не забыли? По умолчанию его в прошивке нет...

  9. #39
    Товарищи, можно советом помочь?..
    Скомпилировал toolchain, и сделал make nginx, отработало, ошибок нет. А теперь вопрос - что дальше?.. Суть - хочу собрать пакет nginx с поддержкой метода select или poll а не epoll с которым собран пакет в репазитории (отдельный момент - что он там вообще делает, если не поддерживается ядром ) , вообщем, вопрос прост - в какую папку переходить, чтобы набрать заветную команду ./configure ... а затем и make.
    Ну и плюс хочется полноценный ipk пакет сделать.

    Форум читал, понимание того, что ipk простой архив с нужной структурой файлов - просветления не дает, впрочем это следующий шаг, сейчас бы разобраться с configure...

  10. #40
    Quote Originally Posted by Nebulosa View Post
    Товарищи, можно советом помочь?..
    Скомпилировал toolchain, и сделал make nginx, отработало, ошибок нет.
    Масса вариантов.
    1) править файлы внутри optware/builds/nqinx (или как он там называется, наверное, в названии номер версии еще есть).
    Оттель же и make запускать. Но таки могут быть подводные камни в виде выставленных не туда путей к инклудам.
    2) "через задницу" - стереть optware/builds/nqinx, и подготовить пакет непосредственно в optware/downloads.
    Т.е. взять его оттуда, развернуть, произвести нужные настройки в умолчательной конфигурации, завернуть взад, положить, сказать make nqinx из /optware.
    3) Можно пойти культурным путем, т.е. настрогать патч для nqinx configure и положить его по месту. Не помню уже куда точно, посмотрите внутри optware/sources.
    Насчет ipk не помогу, не делал никогда.

  11. #41

    Arrow

    Quote Originally Posted by Novik View Post
    Масса вариантов.
    ....
    Вообщем, я наверное пошел 3-им вариантом ) - в optware/make отредактировал файл nginx.mk добавив нужную опцию, затем в папке optware/oleg выполнил:
    Code:
    make nginx-ipk
    затем забрал полученный ipk-пакет из optware/oleg/builds.
    Всем спасибо за подробные комментарии.

    P.s. пользователям Debian и Ubuntu - учтите этот пост при компиляции toolchain - http://wl500g.info/showpost.php?p=102836&postcount=2
    Пойду обрадую любителей сервера nginx рабочим пакетом...

  12. #42
    Join Date
    Feb 2009
    Location
    Kyiv, Ukraine
    Posts
    10

    Question Кросс-компиляция ipk пакета sane-backends

    Предыстория такова: Попытался подключить к WL-500gP сканер на МФУ Canon I-Sensys MF4010
    Прошивка Олега 1.9.2.7-10

    Коротко проблема следующая: не могу кросс-компилировать ipk пакет sane-backends c последними обновлениями из CVS. В Linux'е плавать только учусь воТ

    Теперь детальней.

    В репозитории http://ipkg.nslu2-linux.org/feeds/op...g/cross/stable имеется пакет sane-backends - 1.0.19+cvs20080315-3, в нем pixma версии 0.14.3. Автор этого backend'а посоветовал перекомпилировать sane-backends, чтобы включить последнюю версию backend'a для Canon'а - pixma 0.15.

    Помучавшись пару дней с настройкой среды для кросс-компиляции, с помощью HOWTO на немецком и еще одной полезной ссылки настроил http://svn.nslu2-linux.org/svnroot/optware/trunk под Ubuntu Hardy x86 в виртуальной машине VMWare. Вроде работает, пакеты компилит, пакеты на роутере инсталятся нормально... Также получилось скомпилировать sane-backends с настройками по умолчанию (SANE_BACKENDS_CVS_DATE=20080315 в sane-backends.mk). Который получился с той же версией pixma, что и в репозитории - 0.14.3.

    Чтобы получить пакет с последней версией pixma, поменял SANE_BACKENDS_CVS_DATE на самую свежую дату: 20090303. В результате - не скомпилилось
    Вот что получил:

    Code:
    if test -n "/opt/optware/oleg/sources/sane-backends/Makefile.in.patch /opt/optware/oleg/sources/sane-backends/tools-Makefile.in.patch" ; \
                    then cat /opt/optware/oleg/sources/sane-backends/Makefile.in.patch /opt/optware/oleg/sources/sane-backends/tools-Makefile.in.patch | \
                    patch -d /opt/optware/oleg/builds/sane-backends -p1 ; \
            fi
    patching file Makefile.in
    Hunk #1 FAILED at 33.
    1 out of 1 hunk FAILED -- saving rejects to file Makefile.in.rej
    patching file tools/Makefile.in
    Hunk #1 FAILED at 108.
    1 out of 1 hunk FAILED -- saving rejects to file tools/Makefile.in.rej
    make: *** [/opt/optware/oleg/builds/sane-backends/.configured] Error 1
    на всякий случай привожу этот самый Makefile.in.rej:
    Code:
    ***************
    *** 33,39 ****
    
      @SET_MAKE@
    
    - SUBDIRS       = include lib sanei backend frontend tools doc po
    
      DISTFILES = AUTHORS COPYING ChangeLog ChangeLog-1.0.0 ChangeLog-1.0.1 \
        ChangeLog-1.0.2 ChangeLog-1.0.3 ChangeLog-1.0.4 ChangeLog-1.0.5 \
    --- 33,39 ----
    
      @SET_MAKE@
    
    + SUBDIRS       = include lib sanei backend frontend tools po
    
      DISTFILES = AUTHORS COPYING ChangeLog ChangeLog-1.0.0 ChangeLog-1.0.1 \
        ChangeLog-1.0.2 ChangeLog-1.0.3 ChangeLog-1.0.4 ChangeLog-1.0.5 \
    И что с этим всем делать? В чем проблема?
    Подскажите пожалуйста! Уже сколько времени сканер не работает!
    Если нужны какие-то логи, скажите лишь, какие и где взять
    Last edited by hooke; 05-03-2009 at 11:22.
    WL500gP(Oleg's firmware v.1.9.2.7-10) + USB Flash 1024Mb. 3-4 wifi users. Printer Canon i-SENSYS MF4010 via USB - printing OK (WAN&LAN). SANE installed, and pixma backend does work! FTP server - OK (WAN&LAN, vsftpd v.2.0.7)

  13. #43
    Варианты.
    1) Удалить файл /opt/optware/oleg/sources/sane-backends/Makefile.in.patch
    и отредактировать Makefile.in руками согласно файлу патча. В частности убрать doc из SUBDIRS. Может там еще чего есть.
    2) Привести файл /opt/optware/oleg/sources/sane-backends/Makefile.in.patch в соответствие с Makefile.in.

  14. #44
    Join Date
    Feb 2009
    Location
    Kyiv, Ukraine
    Posts
    10

    Smile Получилось!

    Quote Originally Posted by Novik View Post
    Варианты.
    1) Удалить файл /opt/optware/oleg/sources/sane-backends/Makefile.in.patch
    и отредактировать Makefile.in руками согласно файлу патча. В частности убрать doc из SUBDIRS. Может там еще чего есть.
    2) Привести файл /opt/optware/oleg/sources/sane-backends/Makefile.in.patch в соответствие с Makefile.in.
    Спасибо большое, Novik!
    Благодаря вашему ответу, посмотрел на эту задачу с меньшим страхом.
    Пришлось еще поковыряться, конечно, но получилось.

    Резюмирую. (Прошу прощения, если слишком детально говорю очевидные кому-то вещи, или же где-то говорю глупости. В линуксе не шибко силен, но, вспоминая, как мне тяжело собиралась нужная информация, надеюсь, что то, что я пишу, будет полезно такому же чайнику на его тернистом пути... )
    1. патчи для sane-backends, о которых шла речь, были установлены вместе с NSLU2 SVN, и они оказались постарше, чем свежайшие исходники sane-backends из CVS. Если оставить версию CVS 20080315, то они проходят, если ставить самую свежую дату, то они уже не соответствуют. Поэтому я просто закоментил эти патчи в sane-backends.mk:
      Code:
      #SANE_BACKENDS_PATCHES=$(SANE_BACKENDS_SOURCE_DIR)/Makefile.in.patch \
      #       $(SANE_BACKENDS_SOURCE_DIR)/tools-Makefile.in.patch
      Ну и конечно же, проставляем самую свежую дату CVS:
      Code:
      SANE_BACKENDS_CVS_DATE=20090313
      (да! дело было в пятницу, тринадцатого!! )
    2. Однако скомпилировать sane-backends после этого все равно не получалось . на сей раз ругань была такая:
      Code:
      ./.libs/libhpljm1005.a(libhpljm1005_la-hpljm1005.o): In function `send_conf':
      /opt/optware/oleg/builds/sane-backends/backend/hpljm1005.c:771: undefined reference to `round'
      /opt/optware/oleg/builds/sane-backends/backend/hpljm1005.c:772: undefined reference to `round'
      /opt/optware/oleg/builds/sane-backends/backend/hpljm1005.c:773: undefined reference to `round'
      /opt/optware/oleg/builds/sane-backends/backend/hpljm1005.c:774: undefined reference to `round'
      ./.libs/libhpljm1005.a(libhpljm1005_la-hpljm1005.o): In function `update_img_size':
      /opt/optware/oleg/builds/sane-backends/backend/hpljm1005.c:203: undefined reference to `round'
      ./.libs/libhpljm1005.a(libhpljm1005_la-hpljm1005.o):/opt/optware/oleg/builds/sane-backends/backend/hpljm1005.c:204: more undefined references to `round' follow
      collect2: ld returned 1 exit status
      make[3]: *** [libsane-hpljm1005.la] Error 1
      make[3]: Leaving directory `/opt/optware/oleg/builds/sane-backends/backend'
      make[2]: *** [all] Error 2
      make[2]: Leaving directory `/opt/optware/oleg/builds/sane-backends/backend'
      make[1]: *** [all-recursive] Error 1
      make[1]: Leaving directory `/opt/optware/oleg/builds/sane-backends'
      make: *** [/opt/optware/oleg/builds/sane-backends/.built] Error 2
      - т.е., что-то не так с backend'ом hpljm1005. В англоязычной теме по sane упоминалось что-то похожее с этим же backend'ом:
      Code:
      scanimage: can't resolve symbol 'round
      Видно, что-то не так с библиотеками? Почему не находится определение функции 'round'??
      Но если у karlson911 из вышеупомянутого поста эта ошибка вылезла на роутере при использовании уже скомпилированного пакета, то у меня вылезла на этапе компиляции.
      Тем не менее, этот backend мне ведь не нужен. А можно скомпилировать sane-backends только с нужными backend'ами? Немного погуглив, нашел очень полезную статью - sane-faq с ответом на нужный вопрос.
    3. Сразу воспользоваться простой командой
      Code:
      export BACKENDS="pixma"
      у меня не получилось по той простой причине, что я компилил под Убунту Харди, в которой суперюзер по умолчанию отключен, но можно запускать команды, требующие прав рута, через sudo. Cоответственно, если я сделал
      Code:
      export BACKENDS="pixma"
      sudo make sane-backends
      , то у меня ничего не получилось опять, ибо под рутом глобальной переменной BACKENDS не было... А так:
      Code:
      sudo export BACKENDS="pixma"
      sudo: export: command not found
      - не получается. (ну чайник я в линуксе!). Но как-то догадался запустить оболочку с правами рута:
      Code:
      sudo bash
      export BACKENDS="pixma"
      make sane-backends
      и... ПОЛУЧИЛОСЬ! Скомпилилось!!!
      Дальше - просто: компилим ipk пакет, проверяем:
      Code:
      make sane-backends-ipk
      make sane-backends-check
      заливаем пакет по фтп на роутер, на роутере смотрим размер
      Code:
      ls -l sane-backends_1.0.19+cvs20090313-3_mipsel.ipk
      и считаем md5 сумму пакета
      Code:
      md5sum sane-backends_1.0.19+cvs20090313-3_mipsel.ipk
      в файле /opt/lib/ipkg/lists/optware меняем название, размер и md5sum пакета на новые, (пере)устанавливаем пакет
      Code:
      ipkg -force-reinstall install sane-backends_1.0.19+cvs20090313-3_mipsel.ipk
      и - ГОП-ГОП УРА - pixma у нас версии 0.15 и сканер нашелся!!!!!!
      Code:
      $ SANE_DEBUG_PIXMA=21 scanimage -L
      [sanei_debug] Setting debug level of pixma to 21.
      [pixma] pixma version 0.15.0
      [pixma] pixma_collect_devices() found Canon imageCLASS MF4010 at libusb:001:008
      [pixma] sanei_bjnp_find_devices:
      [pixma] scanner discovery finished...
      [pixma] pixma_find_scanners() found 1 devices
      device `pixma:04A926B4_SDF790317793Q' is a CANON Canon imageCLASS MF4010 multi-function peripheral
      Браво! Фанфары! Я безумно рад!


    P.S. Всех поздравляю со славянским Новым Годом (1 марта, 14 марта - по новому стилю...)
    Last edited by hooke; 15-03-2009 at 00:35.
    WL500gP(Oleg's firmware v.1.9.2.7-10) + USB Flash 1024Mb. 3-4 wifi users. Printer Canon i-SENSYS MF4010 via USB - printing OK (WAN&LAN). SANE installed, and pixma backend does work! FTP server - OK (WAN&LAN, vsftpd v.2.0.7)

  15. #45
    Join Date
    Feb 2009
    Location
    Kyiv, Ukraine
    Posts
    10

    Red face Не все так просто. Протестировал лишь раз..

    Поскольку инсталил и проверял пакет я удаленно, сканирование "вживую" проверю в понедельник. Пока могу сказать, что один раз тестирование scanimage -T прошло хорошо, зашел через час - не получилось
    Code:
    $ scanimage -T
    scanimage: scanning image of size 640x877 pixels at 24 bits/pixel
    scanimage: acquiring RGB frame, 8 bits/sample
    scanimage: reading one scanline, 1920 bytes...  FAIL Error: Error during device I/O
    Ребут не помог. Хотя сканер по прежнему определяется. Хз, может он завис от того первого тестирования Надеюсь, ему не поплохело...
    Как бы перегрузить сканер удаленно?
    WL500gP(Oleg's firmware v.1.9.2.7-10) + USB Flash 1024Mb. 3-4 wifi users. Printer Canon i-SENSYS MF4010 via USB - printing OK (WAN&LAN). SANE installed, and pixma backend does work! FTP server - OK (WAN&LAN, vsftpd v.2.0.7)

Page 3 of 9 FirstFirst 12345 ... LastLast

Similar Threads

  1. Вопрос по ip_conntrack
    By fxsound in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 109
    Last Post: 10-01-2017, 18:20
  2. Вопросы по перепрошивке dir-320
    By gweri in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 344
    Last Post: 29-10-2011, 11:36
  3. Задержка пакетов на роутере
    By GooG1e in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 4
    Last Post: 15-11-2009, 19:13
  4. Как организовать подхват и пересылку udp пакетов?
    By Kosmonavt in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 2
    Last Post: 17-03-2008, 16:47

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •