Page 1 of 4 123 ... LastLast
Results 1 to 15 of 54

Thread: [HowTo] Setup MediaTomb (mediaserver) on WL-500gP and WL-500W

  1. #1

    Lightbulb [HowTo] Setup MediaTomb (mediaserver) on WL-500gP and WL-500W

    I have a WL-500W and a PS3 and the challenge was setting up a media server (as the Asus firmware one did not work with the PS3) without paying for TwonkyVision. Twonky have limited their support for NAT devices to hardware vendors - I found an ASUS package after digging the developers area however they no longer release on the general downloads area and stated they no longer sell to NAT users (only vendors).

    I installed uShare via ipkg and got it to run on the WL-500W without any issues (latest ipkg release) but it does not support the PS3 at the moment (backed up in some other PS3 forums). So uShare uninstalled.

    I installed fuppes via ipkg and again got it to run without too many issues but only with the default config file. For some reason (and I am quite experienced in xml structure) when I added the PS3 required xml tags and values to the config file I got parser errors when restarting fuppes. Tried basic device settings and more advanced ones and also ones from the forums that folks confirmed worked, no go still parsing errors whenever I added the PS3 specific entries so I can only assume that the opto release is not the current one? I'm happy to be proven wrong here as ultimately I would like to use fuppes - but is has to work with the PS3 config settings.

    Now - onto the tutorial for MediaTomb which (after some massaging) did work! Note all was done on Olegs firmware (1.x-10) via telnet.

    First off install it from ipkg (ipkg install mediatomb). This installs all pre requisites. Go here for more info re installatin: but DO NOT set MT_ENABLE to true as autostart does not work on the wl-500X series.

    Second recreate the database it sets up which is broken on the wl-500x installs (known issue). Use this process (pulled form one of our forum threads):
    - cd /opt/share/mediatomb
    - cat sqlite3.sql | sqlite3 mediatomb.db
    - mv mediatomb.db /usr/local/root/.mediatomb

    Third - setup the config.xml file using vi (vi /opt/etc/mediatomb/config.xml). I specified port, interface, restore and database backup settings. Port was specified due to a conflict with another service, interface to ensure mediatomb started on the ip (so the PS3 could see it), restore ensures that when the sqlite database corrupts (and it will re a known bug on the wl-500x series) that when mediatomb starts up it restores the backup and finally the backup setting ensures the backup database file is periodically updated. Note when you start mediatomb it is always updates the backup file to the latest current database version. All these settings can be found here (along with where to place them in the xml file) - go to section 6. Configuration File

    When you have saved your config.xml file start mediatomb (type mediatomb to run) and test on your media client, in my case the PS3. This should then create a backup file of the sqlite database. Press Ctrl+C to shutdown mediatomb and then run the following to ensure the configuration is remembered after rebooting the router:
    flashfs save && flashfs commit && flashfs enable && reboot

    I've attached my config.xml file to help you get going (I've uncommented the settings that need to be enabled for the PS3 to work).

    Finally I want mediatomb to start when router starts. You can run mediatomb in daemon mode so I'm going to add the following command to my startup routine: mediatomb -d (I'll update this post when I've worked out the best way to do this).

    I hope this helps - mediatomb works great on the PS3!
    Attached Files Attached Files
    Last edited by rathalian; 14-04-2008 at 09:35.

  2. #2
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    Hi, I have a conceptronic media player workin with ushare.
    well... it plays movies, after some updates from ushare it is quite limited to playing
    anyway, you have the option for PS3 in ushare, it supports DLNA.
    I'll try this out for my conceptronic, maybe I can fast forward the movies now

  3. #3
    I can see the ushare media server on my PS3 (and have DLNA enabled in the config file) however all of the avi's show up as unsupported data types, whereas these work in mediatomb, nero and WM11.

    Can you confirm divx/xvid work in ushare and could you share your configuration.

  4. #4
    Something for PS3 users - I (and others) have had many issues (across multiple uPnP servers) with firmware 2.20 on the PS3, I too experienced this in the form of slow startups to play/bad to non existent fast forward/reverse functionality and consistent dropouts or failures.

    Firmware 2.30 for the PS3 came out tonight and my mediatomb functionality has gone back to 100% - fast forward/reverse through to 120x works fine, playing is instant and connections are rock solid.

    I tried uShare again in -d mode (DLNA) to ensure the right profile loaded but still getting errors:

    Looking for files in content directory : /mnt/torrent/target
    [mp3 @ 0x2ac344c8]Could not find codec parameters (Audio: mp2, 48 kb/s)

  5. #5
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    Quote Originally Posted by rathalian View Post
    I can see the ushare media server on my PS3 (and have DLNA enabled in the config file) however all of the avi's show up as unsupported data types, whereas these work in mediatomb, nero and WM11.

    Can you confirm divx/xvid work in ushare and could you share your configuration.
    yeh, they just work perfectly, however, I have to reload the movie to get the subs I also put the unsupported file types on so the client has to check if it can play the video.
    gonna give media tomb a try tonight.

    about loading time... on the server I have on a dvd with the conceptronic, it's just a few seconds, but with wl-500w it can take up till half a min. quite long, but I guess that's the max speed of the asus

  6. #6
    Would appreciate you posting your ushare config, as I said I am getting unsupported data types (where they work fine on other upnp servers)

    Re playback - after going to 2.30 firmware on the PS3 wireless playback is not all but instant.

  7. #7
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    here you go

    still getting some errors on the media tomb starting up it just stops working... need to look it all over a bit
    Attached Files Attached Files

  8. #8
    What errors are you getting?

  9. #9
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    well... I get this atm:
    [root@wpte root]$ /opt/etc/init.d/S90mediatomb start
    Starting mediatomb: ok
    but no mediatomb
    at least... I cant see anything on nero home...

  10. #10
    I'm assuming you created that mediatomb script (as the ipkg installer does not).

    I can't get mediatomb to run at startup either - process fires up in defunct state regardless of start method (-d and & tried)....

    BTW - no joy ushare - same config as yours still get data types unsupported, using the ipkg optware package.

  11. #11
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    how did you fire it up then?
    do you get a "start ok" when you use the init.d script?
    otherwise you just put the line in the bottom of the post-boot file, that will probably work

  12. #12

    Who wants to test a static MediaTomb package?

    Hi everyone,

    from what I know there were some C++ library related problems: the version on the WL500g does not support exceptions. MediaTomb uses the exception mechanism a lot, so if the C++ did not support them MT would crash.

    I heard that Oleg firmware was updated with exception support, but I also had reports that the problem still exists on other firmwares.

    As a solution I compiled a static version of the server that can be used as an addon with any firmware. So far it has been tested by two WL500g users who reported success, so I will probably be releasing the package soon.

    The package is very easy to install, it does not have any external dependencies.

    If someone else would also like to test it - please drop me a mail to jin at mediatomb dot cc or post in this thread:

    Kind regards,

  13. #13
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    so... I tried your package jin, I tried to build it but I get an error:
    PHP Code:
    checking for a BSD-compatible install... configure_aux/install-sh -c
    checking whether build environment is sane
    ... yes
    for a thread-safe mkdir -p... configure_aux/install-sh --d
    for gawk... no
    for mawk... no
    for nawk... no
    for awk... awk
    checking whether make sets 
    $(MAKE)... no
    checking build system type
    ... Warningcreating insecure temp directory
    /config.guessunable to guess system type

    This script
    last modified 2007-03-06has failed to recognize
    the operating system you are using
    It is advised that you
    download the most up to date version of the config scripts from


    If the version you run (configure_aux/config.guessis already up to dateplease
    send the following data 
    and any information you think might be
    pertinent to 
    <config-patches@gnu.orgin order to provide the needed
    information to handle your system

    config.guess timestamp 2007-03-06

    -#18 Sun Mar 30 13:13:29 MSD 2008

    /usr/bin/uname -=
    bin/uname -X     =

    hostinfo               =
    bin/universe          =
    usr/bin/arch -k       =
    bin/arch              =
    usr/bin/oslevel       =
    usr/convex/getsysinfo =

    #18 Sun Mar 30 13:13:29 MSD 2008
    configureerrorcannot guess build typeyou must specify one 
    so what do I need to do?
    I think the router also doesn't know "make"

    I also have been told by conceptronic that their NAS is completely compatible with the media player I own.
    The good news is, their firmwares are open-source! and, the nas also uses a mips processor.
    The firmware should contain an intel A/V server, but till now... I did not find it in the sources
    would be great to have it builded, can someone give me a hand with this?
    it's downloadable here:
    Last edited by wpte; 27-04-2008 at 14:27.

  14. #14
    Join Date
    Jul 2008
    Groningen, Netherlands
    I did the above thing, but no mediatomb running?
    I run Oleg on WL-500gP

    total used free shared buffers
    Mem: 30164 29560 604 0 1428
    Swap: 250856 2068 248788
    Total: 281020 31628 249392

    fdisk -l

    Disk /dev/scsi/host0/bus0/target0/lun0/disc: 40.0 GB, 40020664320 bytes
    64 heads, 32 sectors/track, 38166 cylinders
    Units = cylinders of 2048 * 512 = 1048576 bytes

    Device Boot Start End Blocks Id System
    /dev/scsi/host0/bus0/target0/lun0/part1 1 245 250864 82 Linux swap
    /dev/scsi/host0/bus0/target0/lun0/part2 246 978 750592 83 Linux
    /dev/scsi/host0/bus0/target0/lun0/part3 979 38166 38080512 83 Linux

    I downloaded and copied the config.xml from here.
    [admin@WL500GP mediatomb]$ ls

    Here is the db
    [admin@WL500GP root]$ ls .*
    .mediatomb .test

    [admin@WL500GP /opt]$ ipkg install mediatomb
    Installing mediatomb (0.10.0-1) to root...
    Configuring file
    Configuring libexif
    Configuring libiconv
    Configuring libuclibc++
    Configuring mediatomb
    Configuring ncurses
    Configuring ossp-js
    Configuring readline
    Configuring sqlite
    Configuring zlib
    Successfully terminated.

    [admin@WL500GP root]$ mediatomb

    MediaTomb UPnP Server version 0.10.0 -

    ================================================== =============================
    Copyright 2005-2007 Gena Batsyan, Sergey Bostandzhyan, Leonhard Wimmer.
    MediaTomb is free software, covered by the GNU General Public License version 2

    [admin@WL500GP root]$

    I don't know what is going on/wrong!

  15. #15
    Join Date
    Dec 2007
    The Netherlands - Eindhoven
    yeh... I tried compiling it, but neither worked
    I'm still trying to get it runnin, but I'm about to give up the hope...
    this is neither a completed how to, the writer expects you to know stuff wich is written down in a different document

Page 1 of 4 123 ... LastLast

Similar Threads

  1. Replies: 113
    Last Post: 25-07-2012, 12:31
  2. [HowTo] Get a HeadStart on a WL-500gP
    By raas in forum WL-500gP Tutorials
    Replies: 187
    Last Post: 11-01-2012, 09:19
  3. WL-500gP + Mediaserver + XBOX360
    By LeChuck in forum German Discussion - Deutsch (DE)
    Replies: 50
    Last Post: 01-02-2010, 16:20
  4. HowTo: Use Palm as 500gP LCD
    By Tamadite in forum WL-500gP Tutorials
    Replies: 1
    Last Post: 08-02-2009, 22:18
  5. Howto setup WinSCP to connect to my wl500g?
    By ikerstges in forum WL-500g Q&A
    Replies: 1
    Last Post: 21-02-2006, 13:20

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts