Page 1 of 7 123 ... LastLast
Results 1 to 15 of 102

Thread: Проблема компиляции 1.9.2.7-10

  1. #1
    Join Date
    Oct 2006
    Location
    Russia, Kursk
    Posts
    74

    Question Кросскомпилинг из под Win32

    Сабж. Хочется собирать пакеты и прошивку:
    1. Что нужно из компиляторов/библиотек? Есть MinGW и NASM.
    2. Какие подводные камни при сборке?
    3. Где взять поновее сырцы прошиФки от асус и Олега?


    Дорогие Гуру - не поленитесь - отпишите пару строк - я программер не плохой, но вот с линухом впервые столкнулся - могу помочь решить пару-тройку задач для рутера - получится общая польза.

  2. #2
    Join Date
    May 2006
    Location
    Екатеринбург
    Posts
    182
    1 Поставить в VMware Linux и будет как-бы из под Win32

    3 http://wiki.wl500g.info/index.php/co...customfirmware

  3. #3
    Join Date
    Oct 2006
    Location
    Russia, Kursk
    Posts
    74

    Thumbs up

    Quote Originally Posted by TVadim View Post
    1 Поставить в VMware Linux и будет как-бы из под Win32
    +

    +

    Спасибо за ссылку. Примерно такое я искал и почему-то про вики я и забыл...

  4. #4
    Join Date
    Oct 2006
    Location
    Russia, Kursk
    Posts
    74

    Angry Дайте ld.so.1 или перекомпильте Affix - ПЛИИИИИЗ!!!

    Народ жаловался
    http://wl500g.info/showpost.php?p=14131&postcount=22

    И я уже неделю ругаюсь...

    :-(

  5. #5
    Join Date
    Mar 2007
    Location
    Moscow
    Posts
    40

    Проблемы с компиляцией или с установкой?

    Всё таки скомпилял ядро с нужными мне опциями.
    включил advanced router.

    поставил.

    и имею серьёзные подозрения что компиляция или установка прошла успешно.

    1) df -h как не работал так и не работает, хотя в конфигурации busybox-a я эту опцию поставил

    2) iptables -t nat -A PREROUTING -p tcp --dport 80 -j CONNMARK --set-mark 4 всё так же отвечает iptables v1.2.7a: Unknown arg `--set-mark'

    как бы определить где и какой косяк произошёл?

  6. #6
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    По второму - модуль для CONNMARK загрузили?

  7. #7
    Join Date
    Mar 2007
    Location
    Moscow
    Posts
    40
    модуль не загружал - вроде как пометил всё статически линковать в ядро.
    а какое имя может быть у этого модуля?

  8. #8
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    ipt_CONNMARK.o скорее всего.

  9. #9
    Join Date
    Mar 2007
    Location
    Moscow
    Posts
    40
    похоже не в модуле дело. - загрузить его не получилось.

    ещё обратил внимание что всё имеет дату 6 ноября, а не 1е апреля (сегодня). хотя в директории mipsel-uclibc/target даты сегодняшние.

    похоже по какой то причине фирмварь не прошивается. что я мог сделать не так?

    1) подготовил систему как описано на странице
    2) сконфигурировал
    3) gmake
    4) gmake image-WL500gp
    5) upload через web страницу раутера.

  10. #10
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Попробуйте прошить через tftp.

  11. #11
    Join Date
    Mar 2007
    Location
    Moscow
    Posts
    40
    Почему не прошивалось - разобрался.
    пытался шить через wi-fi

    по меди шьётся, но не работает совершенно никак.
    WAN мигает, WiFi не горит. не пингуется.
    откатился на старую прошивку

    попробовал скомпилять прошивку без каких либо изменений.
    прямо "свежераспакованную"

    результат тот же.
    причём размер бинаря прошивки на 250к меньше чем взятой на сайте (3384kb vs. 3620kb)
    видимо из-за этих потеряных 250к и не работает.....

  12. #12
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Разница в размере по другой причине. У меня там лежит ещё tcpdump.

  13. #13
    Join Date
    Mar 2007
    Location
    Moscow
    Posts
    40
    ясно.
    значит не в ту сторону копаю.
    а из-за чего ещё может быть подобный результат?

  14. #14
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Не знаю, обычно работает сразу. Что-то где-то Вы сделали не так.

  15. #15
    Join Date
    Mar 2007
    Location
    Moscow
    Posts
    40
    Спасибо за помощь, Олег!
    попробовал сделать flashfs disable перед прошивкой - почему то помогло.

    но всё это без толку, т.к. CONNMARK оказывается работает только в ядре 2.6

Page 1 of 7 123 ... LastLast

Similar Threads

  1. Проблема с закачкой файла на USB-носитель
    By Red1C in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 2
    Last Post: 21-11-2007, 19:55

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •