If anyone has firmware and problems to connect to the device in WPA-Auto-Personal mode, read this:

WPA-Auto-Personal includes both WPA1 and WPA2 if the allowed encryptions is set to TKIP+AES.
For some reason, the WPA1 devices didn't seem to work with this setting and didn't recognise the encryption.
If you have this problem, you should try to do the following:

When you are in the webinterface, go to wireless -> advanced.
You see the option "Regulatory Mode". This option is specially made for the intel wireless N cards, otherwise they wouldn't work for some reason.
Unfortunately, my old 54G devices don't seem to like this option.
When it's turned off or set on "802.11h" it seems to work perfectly.
To be honest, I have had less problems with the 802.11h mode, so try that one first

when this option is changed, I finally could use WPA1 and WPA2 at the same time again
don't forget to set it to TKIP+AES, otherwise it won't work