Results 1 to 10 of 10

Thread: Xmail 1.2 and mailutils compiled

  1. #1

    Xmail 1.2 and mailutils compiled

    Ok, I've made the xmail 1.20 package and GNU mailutils for wl500g. Xmail is staticaly compiled, so it will work on most system. It will be extremly memory intensive, so don't expect to run it along with a webcam

    I have also some smaller mail tools to do pop check or smtp send, and a lighter package, nullmailler, for those needing a smaller system.

    I would advice anybody not knowing what a iptable is to forget about installing the xmail package, or you will become a new source for spam.

    But the package are quite big. What is the best way to post them? I don't want to split them using rar, as it will probably be a problem for some users. Size is 2,5 megs.
    Attached Files Attached Files

  2. #2

  3. #3
    Quote Originally Posted by hugo
    Whao - It seems to be very interesting,

    Where can we get your package ?

    Happy new year to all of you !

    Thanks a lot.

  4. #4
    I still have a DNS resolution bug. I'll post a binary when I'll have sorted this out.

  5. #5
    Ok, I cannot make the DNS resolution working, but I'm sure of my compiled source. I'm posting them, hoping that someone would make them work. It's fully fonctional, but cannot resolve adress. It will work witl IP.

    If anybody has a clue about the DNS, I'll gladfully hear from him.

    This is a 2 part rar file, that you must unrar with windows, then copy on your box and gzip -d xmailfinal.tar.gz then tar xvf xmailfinal.tar
    sorry for the rar file, but nobody answered my question about a way to split file under linux.

    You must do:

    export MAIL_ROOT=/path to MailRoot folder
    move all files in xmail-1.20/bin to xmail-1.20/MailRoot/bin

    then run xmail. you can use this how to:
    http://www.ubaight.com/xmail/BeginnersGuide.html but to run the mail program, do a
    ./XMail -Md -Pl -Sl -Fl -Cl -Ll -Qn 3 -Ln 2
    Attached Files Attached Files

  6. #6
    The following function is the cullprit:

    Code:
    int SysGetHostByName(char const *pszName, NET_ADDRESS & NetAddr)
    {
    
    	int iErrorNo = 0;
    	struct hostent *pHostEnt;
    	struct hostent HostEnt;
    	char szBuffer[1024];
    
    	if ((gethostbyname_r(pszName, &HostEnt, szBuffer, sizeof(szBuffer),
    			     &pHostEnt, &iErrorNo) != 0) || (pHostEnt == NULL) ||
    	    (pHostEnt->h_addr_list[0] == NULL)) {
    		ErrSetErrorCode(ERR_BAD_SERVER_ADDR, pszName);
    		return (ERR_BAD_SERVER_ADDR);
    	}
    
    	memcpy(&NetAddr, pHostEnt->h_addr_list[0], sizeof(NetAddr));
    
    	return (0);
    
    }
    gethostbyname_r function return bad value or an error.

    I have my include netdb.h properly set, as all other program includes, and no compilation error or warning.

    Does anyone know any incompatibility with this function? The prog is staticaly compiled against glibc and the prog is in c++.
    Last edited by hugo; 29-12-2004 at 10:31.

  7. #7
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,356
    For glibc resolver to work you need nss libraries be installed on the host and /etc/nsswitch.conf present.
    Why don't you link with uclibc?

  8. #8
    Because it won't build with -static, as stdlibc++ is made against glibc. I'm trying the snnswitch file right now. Libs was indeed needed, as I found out with a strace.

  9. #9
    It's still not working, but it should work better with the nsswitch.conf containing
    hosts: dns

    It's probably a question of time before it will be working fully, but I still get no result. Libs nss are also found.

  10. #10
    Got it working. You need a /etc/nsswitch.conf with one entry:

    hosts: dns files


    Also you need the following libs:

    /libnss_dns.so.2
    libresolv.so.2
    /libc.so.6 link pointing to libc-2.2.3.so

    All this must be in your lib folder, from asus source, or from jocky's firmware file.

    Also, if you cannot put them in your lib folder, you must make an alternate lib folder using export LD_LIBRARY_PATH=pathtolib
    or using mount -o bind /pathtonewlibs /lib


    A sample working running commad script is:

    Code:
    #!/bin/sh
    export LD_LIBRARY_PATH='/tmp/hd/conf/usr/lib'
    export MAIL_ROOT='/tmp/hd/conf/usr/xmail/MailRoot'
    /tmp/hd/conf/usr/xmail/MailRoot/bin/XMail -MD 20 -Ql -Yi 600 -Yl -Pl -Sl -Fl -Cl -Ll -Qn 3 -Ln 2
    Be warned, you could be quickly blacklisted. Better use a smarthost. apart from that, it is working perfectly. This little box is really surprising!
    Last edited by hugo; 29-12-2004 at 21:03.

Similar Threads

  1. Vnstat compiled
    By Rob ter Veer in forum WL-500g Q&A
    Replies: 14
    Last Post: 17-12-2007, 17:45
  2. compiled 1950
    By alien433 in forum WL-500g Q&A
    Replies: 0
    Last Post: 23-09-2005, 23:00
  3. Need this compiled properly.
    By Mr.EoniX in forum WL-500g Custom Development
    Replies: 2
    Last Post: 04-09-2005, 09:08
  4. Compiled some tools for x-mas!
    By Rob ter Veer in forum WL-500g Custom Development
    Replies: 29
    Last Post: 22-05-2005, 11:24
  5. Some packages I compiled
    By Jean-Fabrice in forum WL-500g Custom Development
    Replies: 7
    Last Post: 23-03-2005, 13:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •