Page 3 of 4 FirstFirst 1234 LastLast
Results 31 to 45 of 54

Thread: Firmware 1.9.2.7 CR9

  1. #31
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    In the mean time I would release 1.9.2.7-9a with this fix, plus some minor fixes. This would be the last firmware with WL-HDD support.

  2. #32
    Would you mind, if I'll post this information in the German part of the forum? Maybe somebody else has noticed some other bugs. If 1.9.2.7-9a will be defenitely the last version supporting WL-HDD it makes absolutely sense - you could improve the last version. What do you think?

    Regards

    Robert
    Last edited by akbor; 21-03-2008 at 20:05.
    ISP: TV Cable 50/5 Mbit
    Modem: Arris Touchstone TM822S
    "NAS": 1000 GB 2.5" HDD, EXT4, (USB @ RT-AC87U)
    Router: Asus RT-AC87U 380.68 (Merlin build), vsftpd, Samba3, NFS, Transmission, PyLoad...)
    Clients: mittlerweile unzählige...

  3. #33
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    ok, no problems.

  4. #34
    Join Date
    Dec 2004
    Location
    the netherlands
    Posts
    155

    wan disconnects / udhcpc question

    since I am running with cr9 I get disconnected from the internet again. I use automatic ip config, so if I go to the webpages and do a disconnect and then a reconnect every thing goes again.

    In the previous firmwares in the logfiles I did see dhcp renewals, I have not seen this in the cr9 release. So I am thinking I do not get a dhcp renewall. Anyone else with auto ip config running with cr9 that sees similar behavior?

    When I do a manual release I see the following in the syslog:

    Code:
    Mar 22 09:34:27 udhcpc[100]: Unicasting a release of MY.IP.ADDRESS to 84.245.2.1
    Mar 22 09:34:27 udhcpc[100]: Entering released state
    Mar 22 09:34:31 udhcpc[100]: Performing a DHCP renew
    Mar 22 09:34:31 udhcpc[100]: Lease of MY.IP.ADDRESS obtained, lease time 14400
    So this makes me think there's nothing wrong with the firewall settings, else a manual renew would fail too.
    Last edited by wiz; 22-03-2008 at 09:29.

  5. #35
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    This firmware was tested by number of guys here in Russia before it was released. 99% are using dhcp in different flavors and has not reported any problems... So, I beleive this is not a firmware problem.

    You could try flashing old firmware and compare the output: it's the same.

  6. #36
    Join Date
    Dec 2004
    Location
    the netherlands
    Posts
    155
    I have no doubts it has been tested Oleg, I just don't see any renewall statements in my syslog anymore after the update.

    I will put cr8 back to see if that helps.

  7. #37
    Join Date
    Dec 2004
    Location
    the netherlands
    Posts
    155
    I've put cr8 back and left the asus for a while.

    Code:
    Mar 22 15:32:12 udhcpc[105]: Lease of MY.IP.ADDRESS obtained, lease time 14400
    Asus was booted around 13:30, so this is roughly half way through the lease time it renewed the ip address. Seems it works correctly with cr8. I'll stick to that release for now.
    Last edited by wiz; 22-03-2008 at 15:52.

  8. #38
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Well, give me complete cr9 log then.

  9. #39

    NTFS support is broken in CR9?

    I have a USB harddrive formated in NTFS filesystem. the CR9's kernel couldnn't support to read/write it. the CR8 can.

  10. #40
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    NTFS never was writable. As for CR9 - it still works fine:

    [root@WL-0018F33285EF root]$ mount
    /dev/root on / type squashfs (ro)
    none on /dev type devfs (rw)
    proc on /proc type proc (rw)
    ramfs on /tmp type ramfs (rw)
    usbfs on /proc/bus/usb type usbfs (rw)
    /dev/discs/disc0/part1 on /tmp/mnt/disc0_1 type ntfs (ro)

    Mar 22 19:52:04 kernel: hub.c: new USB device 01:03.0-1, assigned address 2
    Mar 22 19:52:04 kernel: scsi0 : SCSI emulation for USB Mass Storage devices
    Mar 22 19:52:04 kernel: Vendor: Model: Rev:
    Mar 22 19:52:04 kernel: Type: Direct-Access ANSI SCSI revision: 02
    Mar 22 19:52:04 kernel: Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
    Mar 22 19:52:04 kernel: SCSI device sda: 1013000 512-byte hdwr sectors (519 MB)
    Mar 22 19:52:04 kernel: sda: Write Protect is off
    Mar 22 19:52:04 kernel: Partition check:
    Mar 22 19:52:04 kernel: p1
    Mar 22 19:52:04 kernel: WARNING: USB Mass Storage data integrity not assured
    Mar 22 19:52:04 kernel: USB Mass Storage device found at 2
    Mar 22 19:52:08 USB storage: ntfs(ro) fs at /dev/discs/disc0/part1 mounted to /tmp/mnt/disc0_1
    Mar 22 19:54:39 vsftpd[245]: CONNECT: Client "192.168.0.4"
    Mar 22 19:54:39 vsftpd[244]: [ftp] OK LOGIN: Client "192.168.0.4", anon password "?"
    Mar 22 19:54:41 vsftpd[246]: [ftp] OK DOWNLOAD: Client "192.168.0.4", "/IMG_4599.jpg", 732289 bytes, 5019.34Kbyte/sec

    If does not work for you - post system log then.

  11. #41

    after mount, CR9 is fine to mount NTFS

    The NTFS problem solve after I type `mount` in console, it is strange. I reboot after upgrade to CR9 but the NTFS partition isn't work, I reboot after solve the NTFS problem by issue 'mount' command, but NTFS partition still work....

    Any way, thanks Oleg for your great firmware and quickly response

  12. #42
    Join Date
    Dec 2004
    Location
    the netherlands
    Posts
    155
    Quote Originally Posted by Oleg View Post
    Well, give me complete cr9 log then.
    Nah, if it is just my setup then leave it, I can live with cr8, that does the job too.

    Thanks anyway Oleg.

    regards,

    Wiz

  13. #43
    Join Date
    Dec 2003
    Location
    Russian Federation
    Posts
    8,353
    Quote Originally Posted by wiz View Post
    Nah, if it is just my setup then leave it, I can live with cr8, that does the job too.

    Thanks anyway Oleg.

    regards,

    Wiz
    Well, I just want to be sure, that it works in the same way as CR8... There are was some changes in the dhcp code, but they should not change anything in respect to renewals...

  14. #44
    Join Date
    Dec 2004
    Location
    the netherlands
    Posts
    155
    I'll see if I get away with testing with cr9 again (my wife and kids were already complaining )

    cheers,

    Wiz

  15. #45

    wifi problems

    I keep getting wifi-disconnects, it works for a while and then it disconnects. I can reconnect, but only for a short period of time before it disconnects.

    I have tried setting regulatory mode to d/h and off but nothing helps.

    Nothing special is displayed in syslog either, only dhcp requests when reconnecting to router.

    I have these problems in cr8 and cr9. I'm connecting with a netgear wg511t pc card.

    Does any body have any idea of how to solve this problem? Right not I'm forced to use older firmware.

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. WDS Problem bei Firmware 1.9.2.7 endlich gelöst
    By Wisi in forum German Discussion - Deutsch (DE)
    Replies: 70
    Last Post: 10-12-2009, 15:51
  2. Weird problem building original Asus 1.2.3.9 firmware
    By Bing in forum WL-HDD Custom Development
    Replies: 0
    Last Post: 31-12-2007, 14:19
  3. wan to lan filter on default firmware 1.0.7.8?
    By nully in forum WL-700g Firmware Discussion
    Replies: 1
    Last Post: 10-11-2007, 23:36
  4. Upgraden naar nieuwe firmware mislukt steeds
    By Weiry© in forum Dutch Discussion - Nederlands
    Replies: 31
    Last Post: 28-09-2006, 22:29
  5. Flashing Oleg's Firmware in WL HDD
    By hugo in forum WL-HDD Custom Development
    Replies: 29
    Last Post: 21-10-2004, 14:55

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •