Page 6 of 7 FirstFirst ... 4567 LastLast
Results 76 to 90 of 101

Thread: Проблемы с tagged vlan (802.1q)

  1. #76

    wifi и йота по vlan-ам

    Хочется разбросать йоту и wifi (как точка доступа) по разным vlan-ам. Все равно - на базе портов или тегировано. Возможно ли это как?
    DIR-320, 1.9.2.7-d-r2624

  2. #77

    tagged VLAN на WL-500gP v2

    Знаю что для таких задач нужны железки посерьезней, но может кто-то пробовал поднимать.
    Стоит на филиале WL-500gP v2, получает инет через PPPoE и подключен к центральному оффису по PPTP без НАТ (делал скриптом для ppp). Клиентов около 10.

    Тут появились орендаторы и не хотелось-бы чтоб они шарились в нашей сети, а тем более в сети центрального оффиса, но интернет им нужен. Вот и думал - создать для них отдельный VLAN с DHCP и развести управляемым свичем.

    Если есть у кого-то опыт, прошу поделиться

  3. #78
    Есть еще в теме кто живой?

    Можно как-то сделать таггированый или по порту ВЛАН и запустить на нем НАТ, ДХЦП и ДНС?

  4. #79
    Quote Originally Posted by masters View Post
    Можно как-то сделать таггированый или по порту ВЛАН и запустить на нем НАТ, ДХЦП и ДНС?
    Можно и описано в этой теме.
    Вместо использования robocfg можно настраивать через vlanXports/vlanXhwname

  5. #80

    Тегирование трафика. wl500gp

    Всем привет!
    Прошивка 1.9.2.7-9
    Вопрос к знатокам существует поддержка стандарта 802.1q на данном устройстве?
    Кто-нибудь пробовал настраивать?
    Wl500gP v1
    Wl520Gc

  6. #81
    Join Date
    Oct 2009
    Posts
    529
    Blog Entries
    1

  7. #82
    ок, будем разбираться.
    Wl500gP v1
    Wl520Gc

  8. #83

    Настройка VLAN и тегирование порта.

    Здравствуйте. реально ли реализовать на ASUS RT-N 16
    вот такую схему?

    Name:  rout.JPG
Views: 893
Size:  13.8 KB

    Если да то подскажите команды для работы с vlan!
    можно ли сделать тегированый порт?
    Last edited by melnikdima; 08-07-2012 at 08:39.

  9. #84

    Нестабильность vlan на RT-N16

    Добрый день, настроил на роутере RT-N16 дополнительный vlan с помощью robocfg и вроде всё работает. Но со временем начинает появляться странный vlan с большим номером, а ещё со временем всё начинает очень сильно тормозить, пинги по 600 мс и работать практически невозможно.

    Code:
    [root@lan root]$ robocfg show
    Switch: enabled gigabit
    Port 0:  100FD enabled stp: none vlan: 2 jumbo: off mac: 6c:f0:49:7a:4f:1a
    Port 1:   DOWN enabled stp: none vlan: 3 jumbo: off mac: 00:00:00:00:00:00
    Port 2:  100FD enabled stp: none vlan: 1 jumbo: off mac: f8:d1:11:12:e0:73
    Port 3:  100FD enabled stp: none vlan: 1 jumbo: off mac: 00:e0:52:b6:dc:bf
    Port 4:  100FD enabled stp: none vlan: 1 jumbo: off mac: 28:10:7b:ee:7b:4b
    Port 8: 1000FD enabled stp: none vlan: 1 jumbo: off mac: 48:5b:39:e8:0b:75
    VLANs: BCM53115 enabled mac_check mac_hash
       1: vlan1: 2 3 4 8t
       2: vlan2: 0 8t
       3: vlan3: 1 8t
    2685: vlan2685: 0t 2t 3t 4t 8t
    Подскажите, что можно посмотреть с такой проблемой и, если кто знает, где можно прочитать подробнее про символы "t" и "*" при указании портов? В целом я понимаю, что это указывает передавать теггированные пакеты, но не понятно при чём здесь 8 порт, и зачем на нём теггированные пакеты.

    • прошивка : 1.9.2.7-rtn-r3936
    • роутер : RT-N16

  10. #85
    Про t: как я понял, Ethernet порты на роутере - это не сетевые карты, а порты встроенного свитча. Соответственно, 8 порт - подключение к "компьютеру", т.е. той части роутера, на которой запущен линукс. Зачем он тегированный - чтобы различать LAN и WAN, а также прочие VLAN'ы. По основному вопросу не скажу - не знаю.

  11. #86
    QuickeneR2, спасибо, это проясняет немного ситуацию...

  12. #87

    D-Link DIR320NRU + 802.1Q vlan + MSSID ReadWrite Access to FS

    Доброго времени суток! Имеется роутер D-Link DIR320NRU Rev.B1, на котором необходимо создать 2 SSID, каждый из которых будет присоединён в своему VLAN. Роутер подключается к свичу Trunk-портом. Альтернативных прошивок для этой модели я не нашёл, по-этому пытаюсь всё это проделать на родном ПО. С VLAN и SSID проблем не возникло (в Web-интерфейсе были созданы SSID'ы, VLAN'ы и соответствующие им бриджи). В итоге трафик с каждого SSID тегируеться. Но тут возникла одна проблема - дело в том, что при доступе к одному из SSID необходимо пройти аутентификацию через WPA2PEAP radius, доступ к которому разрешён лишь с VID10, то есть необходимо чтобы менеджмент роутера был в 10-м VLAN, но дело в том, что на роутер можно назначить IP-адрес только на бридж нетегированного трафика, назначить адрес на бридж 10-го vlan'a в прошивке возможности нет. Через telnet был назначен IP-адрес на br10 (vlan10), с br0 (untagged) адрес удалён, после этого всё полетело, radius-client роутера подключался к radius-server'у с 10-го VLAN'а соответствующего IP - это до первой перезагрузки роутера. И тут возник вопрос: можно ли получить доступ на запись к одному из стартовых скриптов прошивки роутера, чтобы в нём прописать (ifconfig br10 1.1.1.1/24 && ifconfig br0 0.0.0.0)? Всё содержимое ReadOnly. mtd unlock и mount -o remount,rw / не решил проблемы

  13. #88

    Question tagged+untagged

    Всем здравствуйте.
    Настроил на томатовской прошивке Интернет (тегированный) и IPTV (нетегированный), все вроде бы работает нормально, но как мне прокинуть на br0 нетегированный трафик, как бы сбриджить LAN и WAN (WAN=tagged)? Вообще это реально?
    Name:  vlan.jpg
Views: 651
Size:  43.0 KB
    Last edited by ITC; 10-04-2013 at 16:18.
    ASUS RT-N16

  14. #89
    Подскажите, как сделать и возможно ли такое вообще:
    Нужно на WAN вернуть влан локалки, но в тэгированом виде. в идеале и инет в тэге брать.

    Схема следующая:
    Name:  SCGEME.png
Views: 636
Size:  11.3 KB

    конфинг свича:
    Code:
    vlan 1
    !
    vlan 2
     name Internet
    !
    Interface Ethernet1/1
     name TO_VOIP
    !
    Interface Ethernet1/2
     name TO_DVD2516
    !
    !
    Interface Ethernet1/6
     name REAL_IP
     switchport access vlan 2
    !
    Interface Ethernet1/7
     name REAL_IP
     switchport access vlan 2
    !
    Interface Ethernet1/8
     name LINK_TO_ISP_IS74
     switchport access vlan 2
    !
    Interface Ethernet1/9
     combo-forced-mode copper-forced
     name LINK_TO_RA1
     switchport mode trunk
     switchport trunk allowed vlan 1-2
    Если я верно разобрался, должно быть что то такое
    Code:
    vlan2ports=0t 8
    vlan1ports=0t 1 2 3 4 8*
    Так ли это? или я что то не так понял?
    И как сбросить настройки вланов, на случай если накосячу и после перезагрузки не смогу зайти? только перепрошивка?


    UPD
    Вроде получилось. Инет на роутере есть. больше того: локалка возвращается на свитч:
    Code:
    SW1#sh mac-address-table interface ethernet 1/9
    Read mac address table....
    Vlan Mac Address                 Type    Creator   Ports
    ---- --------------------------- ------- -------------------------------------
    1    00-1e-58-39-ec-54           DYNAMIC Hardware Ethernet1/9
    1    00-25-d3-67-72-1b           DYNAMIC Hardware Ethernet1/9
    1    00-26-f2-68-11-a9           DYNAMIC Hardware Ethernet1/9
    1    20-cf-30-ce-17-3e           DYNAMIC Hardware Ethernet1/9
    1    74-e1-b6-a7-b5-cd           DYNAMIC Hardware Ethernet1/9
    1    d4-20-6d-80-96-0d           DYNAMIC Hardware Ethernet1/9
    2    20-cf-30-ce-17-3e           DYNAMIC Hardware Ethernet1/9
    но почему то нет доступа к железкам, вклчюеным со свича. то ли роутер не может в через ван маршрутизировать. то ли что..


    UPD
    Были предположения что всему виной IPTABLES. поумолчанию в WAN запрещена локалка и DHCP... но ведь там все на vlan1 vlan2 навешано. а это у меня не изменилось.

    UPD
    не пойму. пакеты летают, в обе стороны. арпы вижу. ответы на арпы есть. дальше дело не идет..
    Last edited by DeeZ; 25-05-2013 at 15:28.

  15. #90

    Разобрался

    Не работало на 2 влане. сделал 3, добавли его тоже в бридж и все стало ок.

    Code:
    nvram show | grep vlan | sort
    lan_ifnames=vlan1 vlan3 eth1
    lan_ifnames_t=vlan1 vlan3 eth1
    landevs=vlan1 vlan3 wl0
    vlan1hwname=et0
    vlan1ports=1 2 3 4 8*
    vlan2hwname=et0
    vlan2ports=0t 8
    vlan3hwname=et0
    vlan3ports=0t 8*
    vlan_enable=1
    wan0_ifname=vlan2
    wan0_ifnames=vlan2 
    wan_ifname=vlan2
    wan_ifname_t=vlan2
    wan_ifnames=vlan2 
    wandevs=vlan2
    wl0_vlan_prio_mode=off
    wl_vlan_prio_mode=off 
    
    brctl show
    bridge name	bridge id		STP enabled	interfaces
    br0		8000.20cf30ce173e	no		vlan1
    							vlan3
    							eth1
    							tap0
    Конфиг свича:
    Code:
    vlan 1 
    !
    vlan 2
     name Internet
    !
    vlan 3
     name Local
    !
    Interface Ethernet1/1
     name TO_Think
     switchport access vlan 3
    !
    Interface Ethernet1/2
     name TO_DVD2516
     switchport access vlan 3
    !
    Interface Ethernet1/3
     name TO_MEDIAPLAYER
     switchport access vlan 3
    !
    Interface Ethernet1/4
     name TO_VOIP
     switchport access vlan 3
    !
    Interface Ethernet1/5
    !
    Interface Ethernet1/6
     name REAL_IP
     switchport access vlan 2
    !
    Interface Ethernet1/7
     name REAL_IP
     switchport access vlan 2
    !
    Interface Ethernet1/8
     name LINK_TO_ISP
     switchport access vlan 2
    !
    Interface Ethernet1/9
     combo-forced-mode copper-forced
     name LINK_TO_RA1
     switchport mode trunk
     switchport trunk allowed vlan 2-3 
    !
    interface Vlan2
     description EXT_Management
     ip dhcp-client enable
    !
    interface Vlan3
     description LOC_Management
     ip address 172.16.2.200 255.255.255.0

Page 6 of 7 FirstFirst ... 4567 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •