Page 8 of 8 FirstFirst ... 678
Results 106 to 114 of 114

Thread: [HowTo] Upgrading RAM to 128 MB (WL-500gP, WL-500W and WL-700gE)

  1. #106
    I'm not an expert, but I think is because of the RAM .. if there is no RAM, there is no CPU, and if is no CPU there is nothing .. no response. When I first upgraded my RAM, router didn't start .. all LEDs went on. Then I reheated all connections and it worked.

    Your problem might be a cold solder joint too .. recheck connections (even though it worked first time you tried .. a little shake and a bad joint won't work). Though, I'm not sure what does it mean the fact that your power LED doesn't turn on. Maybe you got in a nasty coincidence and your AC-DC adapter went faulty .. also check the 5V power input port under load.

    edit: ) .. I just noticed that the thread was started almost 3 weeks ago. Hope is not to late ...
    Last edited by expert_vision; 18-10-2011 at 12:20.

  2. #107

    problem solved


    It was a silly bug in openwrt-backfire. See also and

    Pin9-trick solved the problem.

    Cheers, Peter

  3. #108
    Join Date
    Dec 2010
    I have a little problem with my router after memory up-grade to 128MB.
    After each reboot or power off of the router my total available memory is only 64MB.
    Each time I have to enter the commands
    nvram set sdram_init=0x0011
    nvram set sdram_ncdl=0
    nvram commit
    to actvate the whole 128MB.
    Everyoane else having this issue ?
    If this is normal,could a script be made to execute those commands on each start-up ?

    Thank you.

  4. #109
    hy , i think you have to use flashfs command to do it permanently,
    flashfs save && flashfs commit && flashfs enable && reboot
    instead of commit

    but , yes you can make a script too to start automatically. i think

  5. #110
    I don't think an startup script will make any difference since the nvram value is used during early CFE loading, you have to reboot to apply changes .. I think.
    The flash chip is repartitioned in few areas :
    -CFE boot loader
    -NVRAM settings
    -kernel -- linux firmware/system files
    Nvram tool operates on NVRAM section and flashfs tool operates on file system section, so I don't think "flashfs save && flashfs commit..." will work either.
    What probably happens is that during CFE loading, luckily, it recovers a correct value for sdram_init. I made a typo during configuring NVRAM once (my correct value is 0x0013 and I typed 0x013 or something) and I had to revive my router with a JTAG cable to erase NVRAM(here is how to use tjtag, here is the software)
    To see if the value of sdram_init remains after reboot use:
    nvram get sdram_init
    Are you sure 0x0011 fits your RAM geometry?
    Here is a explanation of sdram_init value.
    I would arm my self with a JTAG cable before any experiments.
    What router, RAM chip and firmware do you use ?

  6. #111

    I like to upgrade to 128Mb, too. I have Samsung RAMS K4H511638B-TCB3 from an kingston memory module here.

    I have some question regarting the procedure.

    I like to have very less excessive (above specs) heat applied to the components around the RAM-ICs. From my experience on Amiga fixing. A good idea was to prehead the PCB to 50 to 60 °C in an oven and the desolder quickly with a heatgun. Resoldering is also done with a preheated PCB.
    So I want to remove U3 and U4 in only one run if possible.

    So the question (particular for debugging is in case somthing goes wrong - TSOP are many PINs ;) ):
    Will the router boot if U3 is already replaced and U4 is already desoldered if the following commands were issued before:
    Quote Originally Posted by Oleg View Post
    nvram set sdram_init=0x000b
    nvram set sdram_config=0x0032
    nvram commit
    This would turn U4 chip off and prevent my firmware from auto enabling it. The router would be halted too, so you could safely remove power from it.

  7. #112
    Here is an explanation of what those commands do.
    I myself upgraded wl-500gP V2 to 64 RAM (one chip) and everything was fine.

    From what I understand after issuing those commands you will be able to boot only with U3.

    Replace original U3 chip with your new memory chip. Be sure to remove PB free solder completely from the PCB pads before soldering your new chip!
    Power your device on. It should now start normally and report 32MB of RAM (use free to check this).

  8. #113
    Well, thanks. It runs with only with U3 soldered and no U4.

    I wonder what the correct sdram_init values would be to have 64MB only with U3 soldered in.
    I guess sdram_init=0x0013. Am I right?

    As far as I understand with only U3 populated, the router should be stable?
    Currently it boots but does not reboot, or crashes aber about 3 minutes with an "unaligned memory access".
    Last edited by junix; 24-07-2012 at 18:28.

  9. #114
    Yes, sdram_init=0x0013 should enable 16-bit mode (instead of 32) with 10 columns, those disabling the second chip U4 and detect 64MB. In fact that's what I used to enable 64MB ram on my WL-500gP V2 (I did not touch sdram_config).

    If you ever get in trouble by making a typo when entering sdram_init (like I did, silly me :P), you can recover by erasing NVRAM with a JTAG cable.
    Here are some pictures and links regarding the issue.

    edit: I'm clueless about error you are experiencing though. You said you used Samsung chips, so you shouldn't need any capacitors. In fact I used the exact same type of chip from ebay (K4H511638B-TCB3) on my router and everything is fine.
    Last edited by expert_vision; 25-07-2012 at 11:43.

Page 8 of 8 FirstFirst ... 678

Similar Threads

  1. Hardware Encryption on WL-500gP / WL-500gD / WL-700gE
    By staticroute in forum Russian Discussion - РУССКИЙ (RU)
    Replies: 10
    Last Post: 07-02-2013, 12:53
  2. [HowTo] Setup MediaTomb (mediaserver) on WL-500gP and WL-500W
    By rathalian in forum WL-500gP Tutorials
    Replies: 53
    Last Post: 20-12-2012, 21:14
  3. [HowTo] Get a HeadStart on a WL-500gP
    By raas in forum WL-500gP Tutorials
    Replies: 187
    Last Post: 11-01-2012, 08:19
  4. WL-500g Premium died After Upgrading Firmware
    By acidbrain in forum WL-500gP Firmware Discussion
    Replies: 166
    Last Post: 17-06-2011, 07:59
  5. HowTo: Use Palm as 500gP LCD
    By Tamadite in forum WL-500gP Tutorials
    Replies: 1
    Last Post: 08-02-2009, 21:18

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts