Results 1 to 5 of 5

Thread: edit smb.conf manually ?

  1. #1

    edit smb.conf manually ?

    I am using JockyW Custom firmware 1.1.2.8 and tried to fine tune my samba configuration.
    I made my modifications to ...conf/usr/local/samba/lib/smb.conf, but after every reboot this file is reset to some default values which i set by the web interface i first used.
    How can i make permanent changes to smb.conf ?

    Thank you

  2. #2
    Yes, smb.conf is written at boottime. You can cheat by renaming nmbd and smbd to nmbd.orig and smbd.orig and then create shellscripts named nmbd and smbd which start nmbd.orig and smbd.orig using your own smb.conf (nmbd -s path/to/your/smb.conf -D, same for smbd)

    JockyW

    PS: If you can give recommendations for smb.conf please post them here

  3. #3
    Code:
    flashfs enable
    echo "/etc/smb.conf" > /usr/local/.files

    edit your /etc/smb.conf

    Code:
    flashfs save
    flashfs commit

  4. #4
    Quote Originally Posted by alpha5
    Code:
    flashfs enable
    echo "/etc/smb.conf" > /usr/local/.files

    edit your /etc/smb.conf

    Code:
    flashfs save
    flashfs commit
    This does unfortunately not work in WL-HDD 1.1.2.8 firmware

  5. #5
    Quote Originally Posted by JOCKYW2001
    Yes, smb.conf is written at boottime. You can cheat by renaming nmbd and smbd to nmbd.orig and smbd.orig and then create shellscripts named nmbd and smbd which start nmbd.orig and smbd.orig using your own smb.conf (nmbd -s path/to/your/smb.conf -D, same for smbd)

    JockyW
    This did not work for me. If i make a ps -A the sh daemon is loaded after smbd. so i think that script processing is working after loading of smbd.

    But you hinted me in the right direction. I moved my smb.conf to a different directory and changed the default path to it in your smbd and nmbd binary with a hex-editor.
    Sorry for that hack - but it was my last resort.

    Concerning my smb.conf file, I needed user level security, as different users had their e-mail folders on the WL-HDD.
    With the web-interface i got no write access to any directory when i unchecked guest - writable. the line :

    write list = USERX

    had no effect as long as the line:

    valid users = USERX

    was missing. This line was only infrequently created by the web script.
    I also experianced the strange effect, that the global setting of

    security = USER

    was changed back to share after some reboots.

    So now with my smb.conf at a different location, I hope my configuration will remain stable.

    Cheers

    Martin

Similar Threads

  1. Cannot Manually Assign IP nos according to MAC adds
    By judgenick in forum WL-500g Q&A
    Replies: 9
    Last Post: 26-07-2005, 11:12
  2. HDD spin down with 1.2.3.4 firmware - how to edit?
    By jpritzkat in forum WL-HDD Q&A
    Replies: 0
    Last Post: 01-05-2005, 23:08
  3. Edit a file
    By Flappie in forum WL-500g Q&A
    Replies: 1
    Last Post: 05-01-2005, 18:14
  4. more Manually Assigned IP ???
    By Viper_Jaro in forum WL-500g Q&A
    Replies: 5
    Last Post: 03-01-2005, 11:47
  5. How to edit Firmware ?
    By ardidi in forum WL-HDD Q&A
    Replies: 1
    Last Post: 19-10-2004, 19:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •