Results 1 to 6 of 6

Thread: 250gb ext3/2 samba problems

  1. #1

    250gb ext3/2 samba problems

    hello, i have searched through these forums, read several how to's, and searched through google for about a day now and can't seem to find a solution to my problem . . .

    Problem: No matter what my drive is formatted to the router is unable to mount it

    Devices:

    1. obviously wl-500w router
    2. running oleg's latest custom f/w (as of jan 29th 08)
    3. Western Digital 250gb Sata 1.5gbps 7200rpm hard drive
    4. Antec 3.5" external enclosure USB 2.0

    Details:

    What I have done so far

    I have followed the following guide found here on how to set up a usb drive with oleg's f/w - didn't work

    I have tried formatting within Knoppix live cd - I think drive recognized the ext3 partition but it wouldnt share it over samba

    I have tried using a custom partion cd (same tool knoppix uses but without knoppix) - did same thing as above option

    I have also tried using partition magic within windows - this did the same as the above two the first time, but when i tried again the program gives me partition table errors and a mount error (then format within windows and it doesnt)

    also, so far the only file systems i have been using are ext3 and fat. NOT NTFS!

    What I want

    My 250gb hard drive to have one partition (can be any file system fat, fat32, ntfs, ext2, ext3). I do not need to disconnect the drive from the router for use in windows. The drive will only be and always be connected to the router for samba sharing and ftp'ing. I need (need) to be able to read AND WRITE to the drive through the samba share (this is why i stayed away from ntfs - read it doesnt work for write with this router).

    Additional Info


    System Log from router when i tried following the tutorial posted above...

    megaupload link
    it is also attached to this post


    ---------------

    -thats all i got to say, sorry about the long post wanted to make sure everything was clear.

    P.S. Please, any help would be greatly greatly appreciated!
    Attached Files Attached Files

  2. #2
    Join Date
    Feb 2007
    Location
    Moscow, Russia
    Posts
    3,805

  3. #3
    thats a great tutorial, it looked a bit hard to follow for the hd set up though . . .

    anyways, i will try it and report back

    but, from glancing at it, it doesnt look like it will help me . . . my hd is/was already partitioned and ready to go but the router wont pick it up or share it . . .

  4. #4
    alright...heres an update on the problem...

    i started to follow the tutorial but gave up to try something else
    - i booted into my util cd and used gparted to partition the full drive to ext3

    the drive is now recognized by the router and is mounted. i have access to ftp . . .

    now i have samba enabled and the workgroup is set to my workgroup name and access level is read/write . . . why doesnt it show up under my network ?

    i need to start putting data onto the drive now and ftp will be to slow

  5. #5
    another update and yet more fixed...

    i found out why i cant see the drive under samba within windows...i am running vista

    so i set out (following a tutorial) to install samba2 that has support for vista (according to tutorial). but when i try to install ipkg durring the first step...mkdir /opt/tmp - it gives me error saying cannot create directory because filesystem is read-only . . . now wtf ?

  6. #6
    seems like every hour I mess with this router I get a little closer.

    i have installed ipkg (wasnt before) along with samba2, xinetd, and nano . . .

    i configured samba within the web utility, the samba is disabled from the routers utility however, and ftp is still enabled via the routers utility...

    so now vista can see the "computer" within network . . but it errors saying i do not have access . . . also ftp doesnt work anymore...

Similar Threads

  1. Upgrading Samba
    By xmeister in forum WL-700g Q&A
    Replies: 0
    Last Post: 13-11-2007, 11:48
  2. Help please... SAMBA config
    By Pettt[cz] in forum WL-500gP Q&A
    Replies: 1
    Last Post: 06-11-2007, 23:23
  3. SAMBA 2 will not run
    By rj.2001 in forum WL-500g Q&A
    Replies: 9
    Last Post: 15-08-2007, 12:54
  4. problems installing samba on my router
    By a-beck in forum WL-500g Q&A
    Replies: 1
    Last Post: 28-11-2006, 17:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •