Page 7 of 12 FirstFirst ... 56789 ... LastLast
Results 91 to 105 of 174

Thread: Custom 1.0.7.8 firmware is ready to download

  1. #91
    Quote Originally Posted by mumsoft View Post
    I just tested ipkg update as root, but I have now the original /opt from the firmware, that is not writable. Guess what I got...
    I'm getting the same... I had 1.0.4.6 and upgraded to kfurge Rel1 and the Rel2 of 1.0.7.8, so it's not like I had custom 1.0.4.6 previously...

    i just found Midnight Commander File Manager as optware and wanted to try to install it... but ipkg update and ipkg upgrade return errors as Hytekk wrote...

    D.

  2. #92
    Success! The mistake was that I tried ipkg update without copying opt directory!

    now i have mc.... :-) COOL!


  3. #93
    Looks good, you should do a tutorial on that.

  4. #94
    Quote Originally Posted by LeperKing View Post
    Looks good, you should do a tutorial on that.
    It's actually pretty simple, as written in kfurge's tutorial.

    * Logon to the router via PuTTY as admin, then type exactly as here (replace [PASSWORD] with your password:

    sudo bash -l
    [PASSWORD]

    (cd /; tar cf - opt) | (cd /shares/MYVOLUME1; tar xf -)

    mount -o bind /shares/MYVOLUME1/opt /opt

    ipkg update

    ipkg upgrade

    ipkg install mc

    * finally, run the program with

    mc

    or

    mc -c

    in case it doesn't run in color

  5. #95
    Quote Originally Posted by kfurge View Post
    I could pretty easily make this configurable like wan SSH access.

    - K.C.
    I'd definitely use this if enabled.

    BTW, thanks for the new package. Installed without problems.

  6. #96

    MLDonkey User Guide

    Does anyone know where I can find a decent MLDonkey user guide for this version?

    I'm trying to change the default port (BT-client_port) from 6882 to something else, but the changes won't take affect (press enter, reboot router). I am also applying Kfurge's commands:
    4# Type "nvram set kc_bt_port=XXXXX"
    5# Type "nvram commit"

    Am I missing something?

  7. #97

    WAN Telnet Access

    Kfurge, should I be able to externally telnet to the router if I enable these settings? (From your setup guide).

    To allow ssh access from the WAN (external) interface
    1. Telnet or ssh to the router
    2. Gain root access
    3. Type "nvram set kc_ssh_wan_access=Yes"
    4. Type "nvram commit"
    5. Restart the router

    I tried the commands above multiple times and keep getting:
    Connecting To <WAN IP address>...Could not open connection to the host, on port 23: Connect failed

  8. #98
    Quote Originally Posted by yeller View Post
    Kfurge, should I be able to externally telnet to the router if I enable these settings? (From your setup guide).
    No. You can only access the router via SSH (port 22), not telnet (port 23). Telnet is open on the LAN interface only.

    - K.C.

  9. #99
    Quote Originally Posted by kfurge View Post
    No. You can only access the router via SSH (port 22), not telnet (port 23). Telnet is open on the LAN interface only.

    - K.C.
    I'm using Putty now. Thanks for the clarification.

  10. #100

    Question

    Quote Originally Posted by dalanik View Post
    It's actually pretty simple, as written in kfurge's tutorial.
    Whats wrong? why i cant get this right?

    Code:
    [admin@WL700gE /]$ sudo bash -l
     
    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these three things:
     
        #1) Respect the privacy of others.
        #2) Think before you type.
        #3) With great power comes great responsibility.
     
    Password:
    [root@WL700gE /]$ (cd /; tar cf - opt) | (cd /shares/MYVOLUME1; tar xf -)
    [root@WL700gE /]$ mount -o bind /shares/MYVOLUME1/opt /opt
    [root@WL700gE /]$ ipkg update
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages.gz
    Inflating http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages.gz
    Updated list of available packages in /opt/lib/ipkg/lists/optware
    Successfully terminated.
    [root@WL700gE /]$ ipkg upgrade
    Upgrading sudo on /opt/ from 1.6.9.11-1 to 1.6.9.12-1...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/sudo_1.6.9.12-1_mipsel.ipk
        Configuration file '/opt/etc/sudoers'
        ==> File on system created by you or by a script.
        ==> File also in package provided by package maintainer.
           What would you like to do about it ?  Your options are:
            Y or I  : install the package maintainer's version
            N or O  : keep your currently-installed version
              D     : show the differences between the versions (if diff is installed)
         The default action is to keep your current version.
        *** sudoers (Y/I/N/O/D) [default=N] ?D
    Upgrading uclibc-opt on /opt/ from 0.9.28-12 to 0.9.28-13...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/uclibc-opt_0.9.28-13_mipsel.ipk
    Upgrading wget on /opt/ from 1.10.2-4 to 1.11-1...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/wget_1.11-1_mipsel.ipk
    Configuring sudo
    Configuring uclibc-opt
    Updating /opt/etc/ld.so.cache
    Configuring wget
    Successfully terminated.
    [root@WL700gE /]$ ipkg install mc
    Installing mc (4.6.1-3) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/mc_4.6.1-3_mipsel.ipk
    package slang suggests installing pcre
    package slang suggests installing libpng
    Installing glib (2.9.6-1) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/glib_2.9.6-1_mipsel.ipk
    Installing slang (2.1.2-1) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/slang_2.1.2-1_mipsel.ipk
    Installing e2fsprogs (1.40.3-2) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/e2fsprogs_1.40.3-2_mipsel.ipk
    Configuring glib
    Configuring slang
    An error ocurred, return value: 22.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 1: `wget    -q -P /opt/ipkg-dR58hZ http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/e2fsprogs_1.40.3-2_mipsel.ipk'
    Failed to download e2fsprogs. Perhaps you need to run 'ipkg update'?
    [root@WL700gE /]$ 
    [root@WL700gE /]$ ipkg upgrade
    Nothing to be done
    Successfully terminated.
    [root@WL700gE /]$ ipkg update
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages.gz
    Inflating http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/Packages.gz
    Updated list of available packages in /opt/lib/ipkg/lists/optware
    Successfully terminated.
    [root@WL700gE /]$ ipkg install mc
    Installing mc (4.6.1-3) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/mc_4.6.1-3_mipsel.ipk
    Installing e2fsprogs (1.40.3-2) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/e2fsprogs_1.40.3-2_mipsel.ipk
    Nothing to be done
    An error ocurred, return value: 22.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 1: `wget    -q -P /opt/ipkg-kilScV http://ipkg.nslu2-linux.org/feeds/optware/oleg/cross/stable/e2fsprogs_1.40.3-2_mipsel.ipk'
    Failed to download e2fsprogs. Perhaps you need to run 'ipkg update'?
    [root@WL700gE /]$ mc
    bash: mc: command not found
    [root@WL700gE /]$ df -g
    df: illegal option -- g
    BusyBox v1.9.0 (2007-12-27 10:43:06 UTC) multi-call binary
     
    Usage: df [-hmk] [FILESYSTEM...]
     
    Print filesystem usage statistics
     
    Options:
            -h      Human readable (e.g. 1K 243M 2G)
            -m      1024*1024 blocks
            -k      1024 blocks
     
    [root@WL700gE /]$ df -h
    Filesystem                Size      Used Available Use% Mounted on
    rootfs                   67.1M     67.1M         0 100% /
    /dev/root                 1.3M      1.3M         0 100% /mnt
    /dev/ide/host2/bus0/target0/lun0/part2
                             67.1M     67.1M         0 100% /
    /dev/se/2               152.8G     12.2G    140.6G   8% /shares/MYVOLUME1
    /dev/se/2               152.8G     12.2G    140.6G   8% /opt
    [root@WL700gE /]$

  11. #101
    Hm, I forgot about the prompt where it asks you whether to overwrite or use existing config. I wasn't sure what to do, so I just kept the old file.

    ==> File on system created by you or by a script.
    ==> File also in package provided by package maintainer.
    What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
    D : show the differences between the versions (if diff is installed)
    The default action is to keep your current version.
    *** sudoers (Y/I/N/O/D) [default=N] ?D
    I really am not a Linux expert, but the fault seems to be in the "ipkg install mc" command, it terminates with error, the rest seems fine:

    [root@WL700gE /]$ ipkg install mc
    Installing mc (4.6.1-3) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/op...1-3_mipsel.ipk
    package slang suggests installing pcre
    package slang suggests installing libpng
    Installing glib (2.9.6-1) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/op...6-1_mipsel.ipk
    Installing slang (2.1.2-1) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/op...2-1_mipsel.ipk
    Installing e2fsprogs (1.40.3-2) to /opt/...
    Downloading http://ipkg.nslu2-linux.org/feeds/op...3-2_mipsel.ipk
    Configuring glib
    Configuring slang
    An error ocurred, return value: 22.
    Did you try to install it one more time?

    D.

  12. #102

    Installed 1.0.7.8, but printing very very slow

    I've also installed 1.0.7.8 after making a mistake in my old rc.local with the 1.0.4.6 kfurge firmware.

    Thanks Kfurge for that last change, it saved my day.

    Now having got everything running for a couple of weeks now, I've played with MLdonkey and found it's performance less than satisfactory. I've now settled on Transmission which works very well.

    I have only one problem at this stage and that is that ever since upgrading to 1.0.7.8, my USB connected Canon MP780 printer is printing extremely slowly. For example, the test page from WinXP takes about 10 minutes to print. If I try to print anything with any images on it, it's much worse. I note that top reports that most of the time there is at most 2MB of free memory.

    I also note that upnp seems to have a much higher "time" than anything else, and seems to be using more CPU than anything else. I have no other upnp devices on the LAN.

    A picture of the router running top shows this "higher time":

    Name:  topi.jpg
Views: 579
Size:  100.4 KB

    Any suggestions? How can I disable upnp so that it isn't running; I want to experiment on what might be slowing the box down.

    Thanks

    eznet.
    Last edited by eznet; 20-02-2008 at 05:56. Reason: Added a picture.

  13. #103
    Hi at all,

    I just installed this great firmware and while finetuning it I made a non reproducable mistake
    After rebooting I tried to login via telnet and I got:
    login: cannot run /opt/bin/bash: No such file or directory

    SSH login wont work also.

    I installed the software again with the Asus Firmware Restoration Tool 'cause I hoped everything would be resetted but this also did not help.

    Who can help me with this ?

    Regards,

    Extreme

  14. #104
    Quote Originally Posted by Extreme View Post
    I just installed this great firmware and while finetuning it I made a non reproducable mistake
    Make sure to flash the latest image from here:

    http://www.wl500g.info/files/asus/cu...kc_1078_02.nas

    Press and hold the copy button when the ready light blinks three times until it stops blinking. This will bypass any of your customizations and should allow the router to boot.

    - K.C.

  15. #105
    KFURGE.. I have never been able to add a user thru the web interface using any of your custom firmware.. is it a problem on my router ??

    I use the web interface and it allows me to change the setting to user based access.. but then when I click on add user.. it allows me to enter username and password etc.. but when I click on apply.. it always fails and a error box pops up.. Somehow this problem goes away when I use the Asus Firmware..(both 4.6 and 7.8)..

    Why could this be happening??

Page 7 of 12 FirstFirst ... 56789 ... LastLast

Similar Threads

  1. Installing Optware Packages on Asus Firmware 1.0.7.8
    By emailpr in forum WL-700g Firmware Discussion
    Replies: 3
    Last Post: 16-01-2008, 02:13
  2. wan to lan filter on default firmware 1.0.7.8?
    By nully in forum WL-700g Firmware Discussion
    Replies: 1
    Last Post: 11-11-2007, 00:36
  3. Custom Firmware v1.1.2.7
    By JOCKYW2001 in forum WL-HDD Firmware Releases
    Replies: 59
    Last Post: 11-12-2004, 13:26

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •